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Fugro-Jason
Please see our web site www.fugro-jason.com for a list of our offices, addresses, and contact numbers.

For general information please send an email with your request to info@fugro-jason.com.

Technical Support
When you need assistance with your work in Rock Physics Module for PowerLog, contact these 
resources in the Fugro-Jason RPM Technical Support Group:

Phone +1 214 368 2191

Fax +1 214 368 5281

E-mail support.RPM@fugro-jason.com

Hours 8:00 AM - 6:00 PM (CST), Monday through Friday

Address PETCOM, Inc.
1600 North Collins, Suite 1700
Richardson, TX 75080

Website www.fugro-jason.com

http://www.fugro-jason.com
http://www.fugro-jason.com/powerbench/RPM.htm
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USING THIS DOCUMENT
This section describes the initial tasks and information you want to know prior to first 
installing the Rock Physics Module (RPM) for PowerLog software. It includes:

• Introduction
• Where to find information
• Document conventions
• Using the Acrobat online guides
• Document revisions
• Technical support 

Introduction

Audience
This document is for petrophysicists, geophysicists, geologists, and reservoir 
engineers who want to develop standard and customized workflows for determining 
rock physics and pore fluid properties in well curves.

Where to find information
RPM for PowerLog — Getting Started Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 
procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “Installation”, describes the procedures needed to install the RPM for 
PowerLog software and a brief introduction to rock physics workflows.

• Section 3, “Frequently Asked Questions”, describes answers to common questions 
and work-around procedures for specific software issues.

• Section 4, “Best Practices”, provides some advice about handling specific 
situations in RPM for PowerLog, based on some initial software testing by the 
Fugro-Jason Professional Services group.

• Section 5, “Release Notes”, provides last-minute information about (a) issues 
resolved in this release, (b) known issues the development team is correcting, and 
(c) new features added from the previous RPM for PowerLog software release.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information throughout this document.

RPM for PowerLog — User Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 
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procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “RPM Concepts”, shows you the components that make up the 
elemental calculation nodes and how these nodes assemble as a workflow.

• Section 3, “Planning Workflows”, describes how to manage and plan your 
workflow. This involves defining input PowerLog curves, creating named 
constants, preparing mix defaults, and organizing rock physics properties.

• Section 4, “Building Rock Physics Workflows”, illustrates the step-by-step 
procedures used to create a complete workflow.

• Section 5, “Performing Advanced Workflow Tasks”, describes how to better 
organize the workflow, setup user preferences, troubleshoot calculations, import 
another RPM project parameters, and do curve fitting.

• Section 6, “Tutorial Workflows”, uses several workflows to illustrate general 
principles for developing a workflow, while providing individual users the freedom 
to create customized workflows with their unique methodologies. Topics covered 
include:
– Setting up input curves and rock parameters
– Organizing computations into groups
– Comparing calculated values against measured logs
– Selecting different error evaluation criteria
– Reducing the number of nodes for a mature workflow by using the 

SimpleExpression function
– Using conditional logic within the workflows

• Section 7, “RPM User Interface”, describes the organization of the Windows 
menus, mouse button three (right-click) functionality, tool bars, and significant 
dialog windows you use in developing the RPM workflow.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information throughout this document.

RPM for PowerLog — Function Reference Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 
procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “Rock Physics Introduction”, provides information common to the rock 
physics and basic functions. Topics include:
– Relevant publications
– Common Greek symbols used for rock properties
– Parameter types and how mineral default values are selected
– Rock and Fluid properties
– Algorithms for mix velocity rho, Vp, and Vs

• Section 3, “Function Overview”, provides a one line summary of each basic (math, 
trigonometry, conditional logic, statistics, and random numbers) and rock physics 
function provided by RPM. RPM organizes the functions into these groups:
– Anisotropy
– Anisotropy Inversion Support Arithmetic
– Arithmetic
– Discrimination and Conditional Logic
– Empirical Velocity
– Fluid/Rock Physics Functions for Brine, Gas, and Oil
– Gardner’s 
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– Gassmann’s Functions for Fluid Substitution
– Greenberg-Castagna
– Media-Bounds Functions (Two-phase Media)
– Media-Bounds Functions (Three-phase Media)
– Miscellaneous Supporting Functions
– Random Numbers
– Simple Modulus-related Functions
– Statistical
– Trigonometric
– Velocities for Bounds
– Velocity-Synthesis Functions

• Section 4, “Rock Physics Functions”, uses a terse, standard presentation format to 
describe how to use each rock physics function.

• Section 5, “Basic Functions”, uses the same standard presentation format to 
describe the use of basic mathematical, trigonometric, conditional logic, statistical, 
and random number functions.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information within the document.

Document conventions
This guide uses concise menu notation, typeface changes, and reader alerts to define 
information in a structured way that makes it easy for the user to read.

Menu selection notation
Throughout the RPM for PowerLog documentation set, a shorthand notation is used to 
indicate the exact manner to invoke a specific menu command. The notation uses the 
format Menu > Command (or cascading menu name) > Command and displays the 
text in a bold font.

Example If the documentation shows how to select the command needed to display the
RPM for PowerLog Getting Started Guide, you would see Help > 
Printable Documentation > Getting Started Guide in the text.

Figure 1. Help menu for RPM for PowerLog
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Typeface notation

Reader alerts
These reader alerts provide valuable information throughout the Rock Physics Module 
for PowerLog documentation set.

Note Note text that alerts you to additional information to help with the work procedure. The 
note does not contain information necessary for you to complete the procedure. The 
note may extend the circumstances (If you want to save your project to a network 
drive) of a procedure.

Hint Hint text provides you with shortcuts or insight that help you gain the more experience 
and efficiency with the RPM software.

Caution! The cautions text alert you to situations when you can possibly lose information or 
work that was just performed. For example, cautions are used for situations where 
project files can potentially get corrupted or you could accidently delete critical files.

Example This is an in-line example used to quickly clarify a point just made in the document.

Step 1 The tutorial step 1 begins a series of tutorial steps that stand-out from the text to call 
attention to this procedure for the user.

Step 2 Second step

Step 3 Step number three

Table 1. Typeface conventions and symbols

Typeface convention Purpose

italics • Document or software titles
• Introduction of a new term
• Words that require emphasis

Bold Denotes graphical user interface objects and RPM functions. 
For example, RPM function names, menus, button labels, win-
dow names, option buttons, text fields, drop-down selection 
lists, and so forth.

[Alt+F] Keyboard keys are enclosed in square brackets and bold font. 
If the keys must be pressed simultaneously, a plus sign is used 
in the text.

{ } Text surrounded by braces (or curly brackets) indicates more 
than one option.

[ ] Text surrounded by plain square brackets indicate optional 
elements

... Horizontal ellipsis indicates you can supply more than one 
value or parameter for the preceding item(s)
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Step 4 Second to the last step

Step 5 Final step of the tutorial procedure.

Using the Acrobat online guides
The online Fugro-Jason documentation can be read using the Adobe Acrobat™ 
Reader. (If you do not have this software, you can download a free version of the 
Acrobat Reader software from Adobe’s Internet site - http://www.adobe.com/) The 
Adobe Portable Document File (PDF) displays the Fugro-Jason guides in full color and 
acts similar to an online help system. With the online guides you can:
• Control the size of the displayed document
• Print all or a portion of an RPM for PowerLog guide
• Find a specific topic using full-text search procedure
• Use bookmarks and hyperlinks to swiftly navigate among the pages

Note Throughout the Fugro-Jason documentation you will see text that is colored as Blue. 
This text is a hyperlink (active link) that takes you to another portion of the document 
or to an external Internet site.

Displaying the online user guides

Step 1 Select the Help > Printable Documentation command and choose from the 
documents found on the cascading menu.
or
Outside the RPM application, use Microsoft Explorer to find the Acrobat PDF 
document in the X:\Pwrlog32\RPM installation directory and double-click on one of 
these guides:

• RPM_PowerLog_User_Guide.pdf
• RPM_PowerLog_Function_QuickRef_Guide.pdf
• RPM_Freq_Asked_Questions.pdf
• RPM_PowerLog_Getting_Started_Guide.pdf

Step 2 Click in the left pane to display the table of contents Bookmarks and access specific 
document pages.

Setting the navigation menu for the online user guides
The RPM for PowerLog documentation files can be navigated similar to HTML pages 
on the Internet, using a Forward and a Back button to display pages. To display the 
Acrobat Navigation toolbar for this functionality, do this:

Step 1 Choose the View > Toolbars command.

Step 2 Ensure that the check box beside the Navigation toolbar is selected. Your screen 
should look like Figure: 2, ‘Display the Acrobat Navigation toolbar”, on page 11, 
for version 6 of Acrobat Reader.

Step 3 [Optional] To dock the Navigation toolbar with other Acrobat toolbars, press 
[Alt+Ctrl+D] keys.

http://www.adobe.com/products/acrobat/readstep2.html
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Changing the display size of online user guide text

Step 1 Press [Ctrl+M] keys to access the Zoom To dialog box.

Step 2 Type a value for the Magnification and click OK. The user guide page displays at the 
specified magnification.

Viewing an online user guide with bookmarks

Step 1 Click the Bookmarks tab on along the left side of the Acrobat Reader window. The 
bookmarks display as an interactive table of contents.

Step 2 Click the Bookmark for the user guide section you want to view. The Bookmark’s 
page and location display in the Acrobat window.

Jump to a specific page in an online guide

Step 1 Press [Ctrl+Shift+N] keys to display the Go To Page dialog.

Step 2 Type a value for the Page and click OK. The specified user guide page displays.

Figure 2. Display the Acrobat Navigation toolbar
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Printing part or all of an online user guide

Step 1 Choose the File > Print command or press [Ctrl+P] keys to access the Print 
dialog.

Step 2 Select the printer and specify the number of copies to print.

Step 3 Type the page numbers (starting and ending) in the From and To text fields.

Step 4 Click Print button.

Note To print an online user guide, you must have Adobe Acrobat Reader or the full Acrobat 
Exchange product installed on your computer.

Searching an online user guide

Step 1 Choose the Edit > Find command or press [Ctrl+F] keys to display the Search 
PDF pane.

Step 2 Type your search in the What word or phrase would you like to search for? area. It 
can be a word, words, or part of a word.

Step 3 Search only in the current PDF document (Figure: 3, ‘Acrobat search text”, on 
page 13). Select any of the applicable check boxes below the All PDF Documents in 
drop down-selection list:

• Whole words only—finds only occurrences of the complete word typed.
• Case-Sensitive—finds only occurrences of words in the exact combination of 

lower- and upper-case you typed in the search area.
• Search in Bookmarks—searches the text in the Bookmarks pane as well as the 

document text.
• Search in Comments—searches the comment annotations and the document 

text. Any Comment instances found have an icon beside the search word and a 
word or two of the context.

Step 4 Click Search button.

Step 5 When the search results display (Figure: 4, ‘Acrobat search results displayed”, on 
page 13), click the underlined search words (hyperlinked) to go to this page in the 
online user guide.

Step 6 If you want to do another search or refine your current search to yield a more specific 
result, click the New Search button.
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Figure 3. Acrobat search text

Figure 4. Acrobat search results displayed
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Document revisions
Revisions and corrections to the Rock Physics Module for PowerLog documentation 
set are recorded in the next table.

Technical support
Fugro-Jason provides detailed documentation to help you efficiently install, configure, 
and use your purchased software investments. Fugro-Jason documentation is 
designed to help you find descriptions of product functionality and step-by-step 
procedures to accomplish your exploration goals. For answers to your technical 
support questions or to suggest ways to improve this Fugro-Jason product, please 
contact us.

When you need assistance with your work in Rock Physic Module for PowerLog, 
contact these resources in the Fugro-Jason RPM Technical Support Group:

Phone +1 214 368 2191

Fax +1 214 368 5281

E-mail support.RPM@fugro-jason.com

Hours 8:00 AM - 6:00 PM (CST), Monday through Friday

Address PETCOM, Inc.
1600 North Collins, Suite 1700
Richardson, TX   75080

Internet www.fugro-jason.com

Table 2. Document revisions

Date Author Changes made

05/01/2006 Lance Smith Revised Document into three distinct RPM for PowerLog 
Guides.

05/09/2006 Lance Smith Added menu selection convention and metric well conversion 
procedures. Inserted remaining FAQ and best practice items

05/13/2006 Lance Smith Updated complete list of enhancements, known issues

05/31/2006 Lance Smith Reviewed Beta Version completed.

06/11/2006 Lance Smith Add uninstall procedure

http://www.fugro-jason.com/powerbench/RPM.htm
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RPM FOR POWERLOG 2.7 INSTALLATION
This section describes the initial tasks and information you want to know prior to first 
starting the Rock Physics Module (RPM) for PowerLog software. It includes:

• RPM for PowerLog functionality
• Software and hardware requirements
• Obtaining an RPM for PowerLog v2.7 software license
• Downloading software from Fugro-Jason
• Tools for downloading PowerLog and RPM software
• Performing the RPM installation
• Uninstalling RPM for PowerLog
• Starting a new RPM project
• Workflows
• Rock and Fluid Properties
• Publications
• Symbols used in Rock Physics
• Parameter conventions used in RPM

Algorithms from a Jason Geosciences Workbench product were used to create the 
RPM (Rock Physics Module) product that runs on the Windows platform and is 
integrated with Petcom, Inc. PowerLog® software. Using RPM with PowerLog helps 
users with the project management, presentation results, and provides some 
calculation functions previously done with the older product.

RPM for PowerLog functionality

Capabilities
The Rock Physics Module for PowerLog:
• Implements the Jason Geosciences Workbench product spreadsheet capabilities 

using a Windows interface that helps a user to design, correct, and standardize 
calculation workflows.

• Performs all the Rock Physics functions and integrates PowerLog’s project, well, 
and curve management/display features.

• Improves workflow management by demonstrating calculation dependencies and 
order.
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Temporary limitations
To achieve these enhanced capabilities for our users and automate the entire 
workflow, RPM currently has minor and temporary limitations1:
• If a workbench function exists in PowerLog, it is not duplicated in the RPM 

software. You may need to interrupt your workflow to create the curve using an 
existing PowerLog function and use the output as an input to a workflow function.

• Only one well can be selected at a time in PowerLog for the workflow operations. 
RPM can be extended to allow multiple well selections at a later date.

• Because PowerLog works with US units, only US units are used in the calculations 
(exceptions are ρ-density, K-bulk modulus, and µ-shear modulus). The specified 
units for each parameter are shown in the node display. Unitless values are shown 
as none or blank.

Installing the RPM software

Important notes
Note [Windows 2000 Users Only] If you are installing RPM for PowerLog on the Windows 

2000 operating system, you must be an Administrator to install and run the 
software.

Caution! If a previous RPM for PowerLog software version exists on your machine, perform 
“Uninstalling RPM for PowerLog” on page 20 before you install the latest RPM for 
PowerLog software.

Introduction
The RPM for PowerLog installation software integrates RPM into the PowerLog menu. 
PowerLog must already be installed for you to begin using RPM. You should have a 
PowerLog project directory defined where the well data for your PowerLog project is 
stored This is where the RPM for PowerLog project file, drawing file and default 
parameters should be stored; however you can store the RPM project data in 
whatever local or network directory you want.

The installation software installs a sample RPM project, example workflows, and the 
default file ProjDefaults.rpm, which includes preliminary rock properties and other 
project defaults, in the C:\Pwrlog32\RPM directory. Once you create a new RPM 
project, it contains its own project defaults and RPM-defined properties that you can 
modify.

The example workflows must be modified to use the curve names for your well. 

To use the curve fitting and anisotropy functions you must install the Numerical 
Algorithms Group (NAG) license file. This is a temporary license that expires on 
September 1, 2006. Additional information can be found in the “Installing the NAG 
licence” on page 20 section and in the cldll074zl_license_readme.txt file.

1. Fugro-Jason’s current short-term plans are to enhance the RPM functionality. However, no statement in 
this document should be interpreted as a commitment to this development effort.
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Software and hardware requirements

Software
• Windows 2000 or Windows XP
• [Ideal] A PowerLog version 2.7 (with RPM enabled) license must be installed in the 

two directories [C:\Pwrlog32\Working and C:\Flexlm\Powerlog]. See 
Figure: 5, ‘Example RPM for PowerLog license file”.

• A project directory defined for storing the well data and RPM project files

Hardware
• Pentium 4 with 2.0 GHz processor speed or higher
• 256 MB RAM or more
• 300 MB or more of hard disk space
• [Ideal] Dual-monitor video card (Windows XP) - display PowerLog curves and 

RPM workflows at the same time

Obtaining an RPM for PowerLog v2.7 software license
To obtain an RPM for PowerLog v2.7 license from Fugro-Jason
1 Contact Joe Jacquot - Strategic Marketing Manager for Fugro-Jason

Office Telephone: +1 713-369-6938
Mobile Telephone: +1 832-474-7191
Email your request to: jjacquot@fugro-jason.com
or support@petcominc.com

Downloading software from Fugro-Jason
To access the Fugro-Jason FTP Internet server:
1 Copy and paste the Internet link into your browser (Internet Explorer, FireFox, 

Opera, etc.) address line:
ftp://petcomcust:RPM@ftp.fugro-jason.com

2 Download these RPM for PowerLog installation files:
PowerLog_27.zip (unzip with password “petcom” and run setup.exe)
RPMforPowerLog2.7Setup.exe

Figure 5. Example RPM for PowerLog license file

SERVER MYRPMBOX COMPOSITE=DCF8A15XXXXX
VENDOR Fugro-Jason
FEATURE NPowerLogRPMS petcom 99.000 14-aug-2006 1 SIGN=2EB46B5885D0

# License Request Parameters:
#
# type = Petcom
# statmin/rpm = 1
# recipient = HYPERLINK "mailto:yourname@yourcompany.com"yourname@yourcompany.com
# company = Fugro-Jason
# timeout = 14-aug-2007
# server = MYRPMBOX
# key = DCF8A15XXXXX
# status = On
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RPM_for_PowerLog_27_Installation_Instructions.pdf
NAG_License_App_and_Serial_Number.zip (if needed)

Note If the Internet browser fails to access the Fugro-Jason FTP site, use one of the free 
software tools (Table 3 on page 18) and log in to the FTP with these credentials:

– FTP Site: ftp.fugro-jason.com
– UserID: <Provided with software license>
– Password: <Provided with software license>

Tools for downloading PowerLog and RPM software
There are several free tools to download the PowerLog and RPM software installation 
packages from the Fugro-Jason Internet server:

Performing the RPM installation
RPM runs as an integrated part of PowerLog. A licensed PowerLog 2.7 software 
version must previously have been installed to run RPM. A project directory must be 
defined for storing the well data and RPM project files (drawing file and default 
parameters).

Once RPM for PowerLog is installed, you can use the PowerLog command 
Interp > Rock Physics Module to start RPM.

Once a new project has been created, it has its own copy of this data and it can be 
modified to suit your project needs.

To install the Rock Physics Module software
1 Close other Windows applications.
2 Download the RPM for PowerLog v2.7 software from the Fugro-Jason website 

using this URL:
http://www.fugro-jason.com/Downloads/RPMSetup.exe

3 Once the installation package (14 Mb) completes its download from the website, 
place it in a temporary installation directory on the PC where you want to run 
PowerLog and RPM.

Table 3. Where to obtain free tools to download software

Software Internet address

Core FTP LE 1.3 http://www.coreftp.com/download.html

FileZilla http://sourceforge.net/project/showfiles.php?group_id=21558

FTP Commander http://www.internet-soft.com/ftpcomm.htm

FTP Surfer http://www.whispertech.com/surfer/

i.FTP http://www.memecode.com/iftp.php

Star Downloader http://www.stardownloader.com/

WinGet http://www.indentix.com/winget.html

Net Transport http://www.xi-soft.com/
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4 Double-click the RPM for PowerLog v2.7 installation file:
RPMSetup.exe.

5 When the Welcome to the RockPhysicsModule Setup Wizard displays, click 
Next.

6 Supply the password necessary to install the software and click Next.
7 If all your selections are correct, click Install after the Ready to Install screen 

displays. The Install screen displays the progress of copying RPM files to your 
local drive.

8 When the Information screen displays, note carefully the most recent changes 
(Release Notes) to the RPM for PowerLog software and its project files.

Caution! This screen often has information and instructions you want to follow to ensure correct 
results.

9 When the Completing the RockPhysicsModule Setup Wizard displays, click 
Finish.

Caution! RPM for PowerLog v2.7 primarily uses Imperial units (with a few exceptions). Wells 
sampled at metric intervals can be converted to feet using the procedure found in 
“How can I work with well curves sampled in meters?” on page 38.

Figure 6. Release Notes
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Installing the NAG licence
Note You only need to install the Numerical Algorithm Group (NAG) license if you want to 

use the Curve Fitting or Anisotropy functionality in RPM for PowerLog.

To install the NAG license file
1 Unzip the RPMNagBeta.zip into a temporary directory.
2 Open the text file cldll074z_license_readme.txt.
3 Copy the license number having the format xxxx-yyyy-zzzz-aaaa to the 

Windows clipboard.
4 Double-click to run the file: cldll074zl_key_inst.exe
5 Paste the NAG license number into the NAG License Key Installer window (see 

Figure: 7, ‘Inserting NAG license number”) and click OK.

The license installer should provide this message, indicating a successful installation.

Uninstalling RPM for PowerLog
Prior to installing a new version of RPM for PowerLog, you should completely un-
install the previous software version. Using the Uninstalling RPM for PowerLog l 
procedure ensures that all previous RPM software is removed, except for your RPM 
projects and PowerLog files.

To remove RPM for PowerLog from your machine
1 Click the windows start icon and navigate to the Control Panel using

(Windows XP) start > Control Panel
or
(Windows 2000) Start > Settings > Control Panel

Figure 7. Inserting NAG license number
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2 When the Control Panel window displays, select the Add or Remove Programs 
icon/item.

3 The Add or Remove Program window displays and builds a list of applications 
installed on your machine. Select RockPhysicsModule and click Remove.

4 A confirmation window displays. Click Yes if the window title is 
RockPhysicsModule Uninstall.

5 Once the installation successfully finishes, an information window displays a 
confirmation message. Click OK.

6 Close the Add and Remove Programs window.
7 Close the Control Panel window.

You can now install a new version of the RPM for PowerLog software on your 
machine.

Starting a new RPM project
Note [Windows 2000 Users Only] If you are running RPM for PowerLog on the Windows 

2000 operating system, you must be a user with Administrator authority level.

Your first RPM project

Step 1 Start the PowerLog application using the Windows Start menu or the PowerLog 
desktop icon.

Step 2 Select a PowerLog project using the File > Project > Open command.

Figure 8. Add or Remove Programs window



Rock Physics Module for PowerLog v2.7 — Getting Started Guide [Maintenance Release] August 25, 2006 Page 22

RPM for PowerLog 2.7 Installation Starting a new RPM project

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Step 3 Display each well you need to use by repeatedly using the File > Well > Open 
command. The well name, depth range, and sample interval display in a list.

Step 4 Select a single well from the project well list (see Figure: 13, ‘PowerLog window title 
and <project name> Well List”, on page 38).

Caution! If you attempt to start the RPM for PowerLog application before selecting a project and 
a well, the warning in Figure: 12, ‘No PowerLog well selected”, on page 36 displays 
when RPM for PowerLog begins. Additionally, the Status bar displays no well name.

Step 5 Start the RPM application using the PowerLog Interp menu. The Rock Physics 
Module command displays as the last menu item of the Interp menu.

Step 6 Create a new project using the File > New Project command. Fugro-Jason 
recommends you select the project directory where the well data is stored.

Hint Keeping the well data and the rock physics projects associated with these wells 
together helps your data management.

Step 7 Define nodes for the workflow by using the Edit > Add Node command. 

Step 8 Define the function for each node by double-clicking on the node to bring up the 
Function Selection dialog. (For more options and choices. see the Function 
Selection dialog described in the RPM for PowerLog User Guide.)

Step 9 Select parameter values, right-click (third mouse button) in the Value/Name column 
and a context menu displays. Select node, curve, curve alias, constant, rock property 
or user value, and choose its appropriate value. There are parameters which are 
necessary for the computation (mandatory parameters) and some that trigger the 
function to perform additional, more complex calculations (optional parameters). The 
mandatory parameters are denoted by dark blue text in the parameter window. The 
units expected for each value are shown (if defined). A value with matching units must 
be entered. The optional parameters are shown in green. (See Input Parameter 
Types in the RPM for PowerLog User Guide for more information about RPM 
parameter types.)

Close the window when all of the values have been selected. A value can be entered 
in a cell using the menus. The menus help the user to choose a rock property, for 
example, Quartz.rho, and have that value always match the value in the rock Rock 
and Fluid Properties. The shortcut menus are context-sensitive, so only parameters 
with units matching the current cell display for this cell.

Step 10 Save the data by clicking OK.

Step 11 If you select a node as input to a cell, RPM automatically draws the connection from 
the appropriate node. The connections represent the inputs and outputs to a particular 
function at each node.

Step 12 Save the project with the Save Project icon on the tool bar. If you hover over the icon 
you see a status line message that says, Save Project. 

Step 13 Calculate a function for a node by hovering over a particular node, right-clicking to 
bring up the shortcut menu and selecting the Calculate command The resulting curve 
or value generates in RPM or error messages are displayed. You may also calculate 
nodes in a group, path, or the entire workflow. (See the Calculate menu in RPM for 
PowerLog — User Guide, for additional workflow calculation options.)
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Key files used by RPM
• Project file—has a filename of <projectname>.proj. The project file contains 

the project name, the graphic workflow file name, the rock and fluid properties list, 
the constants list, and the defined end members for the mixing functions. The 
default values supplied with each new project are stored in the read-only 
ProjDefaults.proj file. Once the workflow is defined, the project can be saved 
under the current project name or be renamed. The project has its own set of rock/
mineral/fluid properties that you can modify using the RPM user interface.

Note See the File menu in the RPM for PowerLog User Guide to rename a project or to 
create a backup copy to preserve your work.

• Node definitions file—is defined by the filename <projectname>Node.txt. It 
contains the function details for individual nodes, that is, the input parameters, the 
output, and the function name.

• Graphic Workflow file—has the filename of <projectname>.dot. The .dot 
file contains the instructions for drawing the workflow.

Note All the RPM project files are text files, which can be displayed in a text editor.

Figure 9. Generic RPM workflow
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Workflows
Nodes can be linked together in workflows by using the output value or output curve of 
one node as an input for another node.

In this example you can calculate a new bulk modulus (K) for a sandstone when the 
original fluid (100% gas) is replaced by 100% water.

Consider this three node workflow that looks like Figure: 10, ‘Simple three node 
workflow”, one node for each rock physics function:

• GasK—calculates the original fluid bulk modulus.
• BrineK—calculates the bulk modulus for the water for specific physical conditions 

in the reservoir.
• Gassmann—requires a bulk modulus for a replacement fluid (K_F_new) and an 

original fluid (K_F_old) for two of it’s input parameters.

The input for GasK is P=2900 psi, T=176 degrees F, and spec_grav=0.6. The result 
is a value for the node (node n1) of 4.0502e7 N/m2.

Similarly, the input for BrineK is P=2900 psi, T=176 degrees F, and salin=35000 
ppm, but a value for the node (node n0) of 2.64747e9 N/m2.

Once n0 and n1 are calculated, the Gassmann function node n2 inputs become:
Kbulk = 12.29e9 N/m2

Kmineral = 36.0e9 N/m2

Porosity = 0.20
K_F_new = node n0 (BrineK - bulk modulus of brine node)
K_F_old = node n1 (GasK - bulk modulus of gas node)

The connecting arrows in Figure: 10, ‘Simple three node workflow” display when 
the n2 node is saved, because node n2 is an output descendent of nodes n0 and n1. 

When the Gassmann function node calculates, the result is a node n2 with the 
constant value Ksandstone = 1.7148e10 N/m2, which is the sandstone bulk modulus 
with the replacement fluid (water) and verified by manual computation with 
Gassmann’s equation.

This workflow can be modified to use curves (also curve alias names) instead of 
UserValues for pressure and temperature in BrineK and GasK, thus actual 

Figure 10. Simple three node workflow
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measured pressure and temperature variations in the well are used for the 
computation. Curves for pressure and temperature in PowerLog can be used. The 
resulting bulk density curve will vary in value, but still be approximately 1.7e10 N/m2.

Rock and Fluid Properties
The Rock and Fluid Properties contains parameters for minerals, fluids, and rocks. 
Parameters for minerals and fluids are available from the defaults for input as 
parameters in functions. Parameters for rocks, minerals, and fluids are available for 
input parameters in functions using the shortcut menus in the Function-Selection 
dialog for specific functions.

As initially provided with RPM, the Rock and Fluid Properties includes only those 
parameters suitable for minerals on rows with named minerals, only those parameters 
suitable for rocks on rows with named rocks, and only those parameters suitable for 
fluids on rows with named fluids. 

Caution! You can modify the Rock and Fluid Properties. However, any new rock, mineral, 
fluid, or property names must not contain spaces.

Importing rock, mineral, and fluid properties from another RPM project
RPM for PowerLog v2.0 will provide a feature to import and export rock and fluid 
properties from existing projects. For those who want to import properties today, you 
can manually import rock and fluid properties from one RPM project to another, using 
a standard text editor.

Note RPM for PowerLog comes with a default set of rock, mineral, and fluid properties. You 
only need to import properties if you want your own custom values for these 
properties.

To import rock and fluid properties manually
1 Ensure that neither project (*.proj) file is in use by the RPM for PowerLog 

software.
2 Using a text editor application such as NotePad®, TextPad®, or UltraEdit®, open 

your source RPM project (project containing the rock, mineral, and fluid properties 
you want to copy).

3 Open the destination RPM project (project for which you want to include these 
specific existing rock, mineral, and fluid properties).

4 In the source project find the ROCK, MINERAL, or FLUIDORGAS property you 
want to copy.

5 Select the entire section of the property, include a blank line, so that what you copy 
is similar to Figure: 11, ‘Property imported into an RPM project”, on page 26.

Note Each RPM property begins with a dollar sign ($) and ends with a blank line, line feed, 
or return character.

Caution! All properties must be inserted into any RPM project file above the Constants section, 
which begins with the text ($$Constants).

6 Copy and paste the text to the destination RPM project. Each new property should 
look similar to the portion of the RPM project file displayed.



Rock Physics Module for PowerLog v2.7 — Getting Started Guide [Maintenance Release] August 25, 2006 Page 26

RPM for PowerLog 2.7 Installation Publications

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

7 Repeat steps four through six for each property you want to import into the 
destination RPM project.

8 Save and close the destination RPM project using the text editor.

Publications

Figure 11. Property imported into an RPM project

Table 4. Selected RPM Publications

Document title

[1] Alkhalifah, T. and Tsvanklin, I. (1995) Velocity analysis for transversely isotropic 
media. Geophysics, volume 60, pages 1550-1566.

[2] Alkhalifah, T. et. al. (1996) Velocity analysis and imaging in transversely isotropic 
media: Methodology and a case study. The Leading Edge, 15, #5, pages 371-378.

[3] Avseth, P., Mukerji, T. and Mavko, G. (2005) Quantitative Seismic Interpretation: 
Applying Rock Physics Tools to Reduce Interpretation Risk, Cambridge University 
Press, ISBN 0521816017, 376_pages.

[4] Baldwin, J. (2006) Petrophysics/Rock Physics Integration: PowerLog and RPM Log 
Modeling. RPM Rollout-July, Fugro-Jason Internal Communication, PowerPoint 
Presentation.

[5] Batzle, M.N. and Wang, Z. (1992) Seismic properties of pore fluids: Geophysics, 57, 
pages 1396-1408.
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[6] Berryman, J. G. (1992) Journal of Acoustic Society of America 68 (1980) pages 1809-
1831 [reprinted in Seismic and Acoustic Velocities in Reservoir Rocks, volume 2, 
Z. Wang and A. Nur (editors), Society of Exploration Geophysics (SEG), Geophysics 
reprint series, No. 10.]

[7] Berryman, J. and Milton, G. (1991) Exact results for generalized Gassmann's 
equations in composite porous media with two constituents. Geophysics, Volume 56, 
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Symbols used in Rock Physics

[41] Vernik, L. (2001) Elastic Seismic Inversion. EAGE/SEG Research Workshop on 
Reservoir Rocks, Pau.

[42] Walls, J. D., Dvorkin, J. and Smith, B.A. (1998) Modeling Seismic Velocity in the 
Ekofisk Chalk, Society for Exploration Geophysics, 68th Annual International Meeting, 
pages 1016-1019.

[43] White, R. and Xu, S. (2000) Geophysical Prospecting 43 (1995) page 91. and erratum 
in Geophysical Prospecting 48, page 629.

[44] Xu, S. and White, R.E. (1995) A new velocity model for clay-sand mixtures: 
Geophysical Prospecting 43, pages 91-118.

White, R.E., Simm, R. and Xu, S. (1998) Geophysical Prospecting 46, page 323.

Xu, S., Doorenbos, J., Raikes, S. and White, R. (1997) Developments in Petrophysics, 
edited by M.A. Lovell and P.K. Harvey, Geological Society London, Special publication 
122, page 87.

Table 5. Commonly used symbols in rock physics

Symbol Name Purpose

λ lambda Lamé’s constant (K – 2µ/3)

Κ -- bulk modulus

Ε Epsilon Young’s modulus

µ mu shear modulus (G also used in literature)

ρ rho (1) density or (2) correlation coefficient

φ phi porosity

σ sigma standard deviation (variance is σ2)

ν nu Poisson’s ratio

ω omega angular frequency

α alpha
(Vp0)

(1) crack (pore) aspect ratio, (2) P-wave velocity along the vertical 
symmetry axis of a transversely isotropic media, (3) mean deviation.

β beta 
(Vs0)

S-wave velocity along the vertical symmetry axis of a transversely 
isotropic media

∆ Delta Acoustic and shear sonic travel times (measured in µsec/ft.)

Μ -- P wave modulus (Μ = ρVp
2)
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Parameter conventions used in RPM
[between 0 and 1] - denotes a porosity or fraction that has a value between 
0.0 and 1.0.

(MANDATORY-NO DEFAULT) - you must specify a value for this parameter type.

(MANDATORY-defaulting) - you can specify a value. Nonetheless a value is required 
for the calculation and defaults are chosen according to Table 6, “RPM Function 
input parameter types,” on page 30.

(OPTIONAL-NO DEFAULT) - you must specify a value for this parameter type for the 
optional calculation.

(OPTIONAL-defaulting) - you can specify a value. Nonetheless a value is required for the 
optional calculation and defaults are chosen according to Table 6, “RPM Function 
input parameter types,” on page 30.

Input parameter types

θ theta (1) well bore or (2) formation dip angle deviation from true vertical1 2

ϕ phi (1) well bore or (2) formation azimuth (AZ) clockwse deviation from true 
magnetic north1 2

Thomsen’s anisotropy parameters - relates P-wave and S-wave velocities along the vertical 
symmetry axis to three phase velocities propagating in the direction of a deviated well.

γ gamma The fractional difference in Vsh between the horizontal and vertical 
directions, and the normalized difference between Vsh and Vsv in the 
horizontal propagating S-waves (Mavko et al, [27]).

δ delta Thomsen anisotropy parameter that relates P-wave and S-wave 
velocities along the vertical symmetry axis to the three phase velocities 
propagating in the direction of a deviated well (Mavko et al, [27]).

ε epsilon Thomsen anisotropy parameter for P-wave anisotropy or the fractional 
difference in P-wave velocity between the horizontal and vertical direc-
tions (Mavko et al, [27]).

1. Well bore angle input parameters in RPM begin with a track_ suffix.
2. Formation angle input parameters in RPM begin with an aniso_ suffix.

Table 6. RPM Function input parameter types

Type Display Parameter type description

mandatory-no default MN You must explicitly specify a value in the Function Selection dialog input 
parameter

Table 5. Commonly used symbols in rock physics (Continued)

Symbol Name Purpose
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The parameter type for all function inputs is shown on the Function Selection dialog 
when you edit a node.

Input parameter type examples

mandatory-no default
Each of the RPM function input parameter lists begin with the (MANDATORY-
NO DEFAULT) parameters displayed in bold blue text. These parameters require a 
value or curve input for the calculation to succeed.

mandatory-defaulting
The input parameters rho_1, rho_2, and rho_F for MixVelocityRho are an example 
of (MANDATORY-defaulting) parameters. The parameters must be specified explicitly. 
Alternatively, a shortcut menu helps you select a value from the Rock and Fluid 
Properties, such as quartz.density for rho_1. If neither options are used, these 
parameters default from the Rock and Fluid Properties according to the default 
settings and the default values displayed on the status bar. For example, rho_1 
defaults to the density for the first mineral member.

optional-no default 
Consider the Bubble point pressure at in-situ temperature (P_bubble) in the 
LiveOilRho function as an example of an (OPTIONAL-NO DEFAULT) parameter. When this 
optional parameter is used, it overrides any input value for Rs the calculation, but there 
is no default value.

optional-defaulting
The input parameters for GreenCastVptoVs are an example of (OPTIONAL-defaulting) 
parameters. When this function is simply used to determine Vs from Vp in brine-

mandatory-defaulting MD You may specify a value. A value is required for the calculation. If no value is 
specified explicitly by the user, the value defaults to:
• a value from the Rock and Fluid Properties corresponding to the mineral 

member or fluid specified in the Function Selection dialog shortcut menu, 
where the input value is specified.

• a value from the Rock and Fluid Properties corresponding to the default 
mineral member or fluid.

optional-no default ON You must explicitly specify OPTIONAL-NO DEFAULT parameters. Optional 
parameters require a function to perform additional or different calculations. 
Using optional parameters is often (but not always) triggered by a value of a 
mandatory parameter (such as a clay fraction vol_2>0). 

optional-defaulting OD You may specify a value. Optional parameters require a function to perform 
additional or different calculations. Using optional parameters is often triggered 
by a value of a mandatory parameter (such as a clay fraction vol_2>0).
OPTIONAL-defaulting parameters default to:
• a value from the Rock and Fluid Properties corresponding to the mineral 

member or fluid specified in the Function Selection dialog shortcut menu, 
where the input value is specified.

• a value from the Rock and Fluid Properties corresponding to the mix 
default mineral.

Table 6. RPM Function input parameter types (Continued)

Type Display Parameter type description
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saturated rocks, there are four mandatory parameters. But when a fluid substitution is 
required to calculate Vs from Vp for rocks saturated with fluids other than brine, using 
the ten optional parameters (both defaulting and no default) requires that an optional 
calculation happens.
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FREQUENTLY ASKED QUESTIONS

Troubleshooting
1 RPM for PowerLog is not starting, is something wrong?

2 Why does the RPM curve alias list not display?

3 Why does an error happen when I try to start a new project?

4 Why does the RPM online help not display?

5 Where did the Greek symbols go in the online help?

RPM and PowerLog
1 Can I display my curves in RPM for PowerLog?

2 What project and well is this RPM workflow using?

3 How can I work with well curves sampled in meters?

RPM User Interface
1 What determines if a node generates a curve or a single value?

2 Does RPM handle rocks and minerals differently?

3 How can I systematically remove my errors from a workflow?

4 How can I minimize workflow calculation messages, yet still fix any 
problems?

5 How rules does RPM use to name properties, constants, and curves?

6 What keyboard shortcuts can I use for frequent RPM commands?

7 How can I simplify the workflow once all calculations are working?

8 How do I find an individual node in a complex workflow?
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9 Can I select a curve name for a node output?

10 Is there a quick way to see if a node curve calculation is correct?

11 How do I fix nodes when a RockProperty and Constant is renamed?

12 What can I do if all my connections don’t redraw on a complex workflow?

13 How can I copy project properties from one RPM project to another?

14 Can I position the RPM tool bar icons anywhere?

15 How does curve fitting work with workflow nodes?

16 Where can I display details about the curve fitting computations?

Workflow building
1 What example workflows can I use to get started?

2 What is an example of an effective workflow color scheme?

3 Can I get a hardcopy of my workflow?

4 How do I delete multiple workflow nodes?

5 Will workflows accommodate comments or titles?

6 What is the best way to define constants for a workflow?

Problems and suggestions
1 What’s the procedure to report a software problem?

2 What makes an effective problem report?

3 How do I make suggestions to improve RPM for PowerLog?

Functions
1 What basic functions are most useful for RPM workflows?

2 How do I make sense of all the parameters in the MixVelocity functions?

3 Where do I find details about basic and rock physics functions?

4 How do I determine which nodes or curves are correct for a function?
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5 What are the assumptions for using Gassmann’s fluid substitution?

6 How do I know if a calculation failed or succeeded?

7 Can I use an expression for inputs to the ConditionalExpression function?

8 How do I use conditional logic to select calculations for specific 
situations?

9 How can I simplify the workflow once all calculations are working?

10 Can I avoid retyping the same function input values?

Documentation
1 How is information in the RPM documentation organized?

2 What example workflows can I use to get started?

3 Where do I find details about basic and rock physics functions?

4 What tools can I use to successfully create a robust workflow?

5 Is there an RPM reference of all software commands and functions?

6 What keyboard shortcuts can I use for frequent RPM commands?

RPM for PowerLog is not starting, is something wrong?
No, RPM for PowerLog has two requirements for the software to begin building or 
using workflows:
• RPM for PowerLog version 2.7 software (see “Downloading software from 

Fugro-Jason” on page 17)
• Version 2.7 RPM for PowerLog license (see “Obtaining an RPM for PowerLog 

v2.7 software license” on page 17)

To determine the PowerLog software version
1 Start the PowerLog software.
2 Select the Help > About command. The About dialog should display the text 

“Powerlog Version 2.7”.

Caution! PowerLog version 2.61a and earlier versions do not support the RPM for PowerLog 
license.

If you have not selected a PowerLog well when the RPM for PowerLog application 
starts, you receive the large warning displayed in Figure: 12, ‘No PowerLog well 
selected”.
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If a well name does not display in the RPM for PowerLog Status bar (Figure: 14, ‘RPM 
for PowerLog status bar information”, on page 38), use PowerLog to select a 
project and a well.

To select a PowerLog project and well
1 Select a PowerLog project using the File > Project > Open PowerLog command.
2 Display each well you need to use by repeatedly using the File > Well > Open 

PowerLog command. The well name, depth range, and sample interval display in a 
list similar to Figure: 13, ‘PowerLog window title and <project name> Well 
List”, on page 38. 

3 Select a single well from the project well list.
4 Select the Interp > Rock Physics Module PowerLog command.
5 When RPM for PowerLog starts, the well name displays in the status bar. An 

example well would look like Figure: 14, ‘RPM for PowerLog status bar infor-
mation”, on page 38.

Why does the RPM curve alias list not display?
If the curve alias list has not been created by PowerLog, then the RPM for PowerLog 
software cannot display the list.

Create the initial Curve Alias Table by using the Tools > Curve Alias Table command 
in PowerLog.

Why does an error happen when I try to start a new project?
If you get an error message, that states, “Cannot open defaults file for new 
project - ProjDefaults.rpm”, exit the RPM for PowerLog software, exit 
PowerLog, and perform the next procedure. You must start both PowerLog and RPM 
for PowerLog software before you begin switching PowerLog projects.

Starting PowerLog, RPM, and switching PowerLog projects
1 Start PowerLog v2.7 (or more recent) software.
2 Use the PowerLog Interp > Rock Physics Module command to start the RPM for 

PowerLog software.
3 Begin with the PowerLog File > Project > Open command to locate your 

PowerLog project.
4 Use the PowerLog File > Well > Open command to open one or more wells.
5 In the RPM for PowerLog software, use the File > New Project command to cre-

ate a new project.

Figure 12. No PowerLog well selected
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Why does the RPM online help not display?
The RPM online help for the mathematical and rock physics functions:
• Displays in an HTML browser window
• Requires that Javascript option for the browser is enabled.

1 Check to see that the browser displays HTML files on your local drive.
2 Verify the Javascript is enabled. For Internet Explorer, use the Tools > Internet 

Options command. Enable active content on your local machine.
3 Verify that the RPM online help is in this directory:

C:\Pwrlog32\RPM\Help\Quick Ref

Where did the Greek symbols go in the online help?
If you have a Mozilla Internet browser (Netscape or FIreFox) defined as your default 
browser, the Greek symbols are rendered incorrectly. Also some of the fonts display 
abnormally large due to Mozilla’s rendering of cascading styles.

For optimum viewing, Fugro-Jason recommends you use Internet Explorer as your 
Internet browser for the RPM for PowerLog online help.

To correct FireFox and Netscape bowsers to display the Greek symbols:
1 Find the Internet Browser fontEncoding.properties file on your PC.

For the Netscape browser, it is located in the folder:
Program Files\mozilla.org\Mozilla\res\fonts\fontEncoding.properties

For the FireFox browser, it is located in the folder:
Program Files\Mozilla Firefox\res\fonts\fontEncoding.properties

2 Make a backup copy of the fontEncoding.properties file.
3 Change the line in the fontEncoding.properties file

From this,
encoding.symbol.ttf = Adobe-Symbol-Encoding
to this,
encoding.symbol.ttf = windows-1252

4 Save the fontEncoding.properties file.
5 Restart your Internet browser program.

Can I display my curves in RPM for PowerLog?
RPM for PowerLog is a calculation engine for implementing rock physics 
computations. To display your curves for the best possible presentation, use 
PowerLog. PowerLog contains many graphic views [log plots-with tops, histograms, 
cross plots, and cross-section collages] that automatically update whenever your 
curves (recorded or synthetic) are updated with RPM and PowerLog calculations.

What project and well is this RPM workflow using?
The PowerLog and RPM for PowerLog applications provide a detailed description of 
how the current workflow is being used. As shown in Figure: 13, ‘PowerLog window 
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title and <project name> Well List”, on page 38, the PowerLog application window 
title and the project Well list describe the current PowerLog project and well name 
used by the workflow. Additionally, the top and bottom well depths are displayed, 
along with the step (sampling interval). In this example, the project name is 
WestTexasBC1 and the currently selected well name is TREVINO ESTATE ET AL 
#1.

The RPM for PowerLog window title provides project and calculation elements 
(defaults):
• RPM Workflow Project name
• End member #1 (Quartz, a mineral)
• End member #2 (Clay, a mineral)
• Pore Fluid (Water)
• Algorithm used to determine the bulk modulus (none)

The RPM for PowerLog status bar provides this information:
• PowerLog well name in use
• Indication that PowerLog curve overwriting is in effect (OVR)
• Current size of the workspace in pixels

How can I work with well curves sampled in meters?
The first release of RPM for PowerLog, with few exceptions, works only with Imperial 
units. Later RPM and PowerLog software versions will permit you to use whatever 
units you want. To use a well sampled at metric intervals, you need to convert the well 
depth values to feet. We recommend you use 1/2 foot sample spacing.

To convert a PowerLog well from metric sampling to feet:
1 Shutdown RPM for PowerLog software and any other PowerLog plug-ins running.
2 Select a well in a project to convert using the File > Well > Open command.

Figure 13. PowerLog window title and <project name> Well List

Figure 14. RPM for PowerLog status bar information
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3 Select the File > Well > Depth Conversion command.
4 When the Depth Conversion window displays, click the Change Well Interval or 

Depth Units option button.
5 Under the New column, select FT for Depth Units in the drop-down selection list.

Caution! Start curve on integer number (not fraction) of feet and use .5 FT sample spacing.

6 Click Run and a confirmation alert asks, Do you want to pack the well?.
7 Click Yes and the well curves are now sampled in feet.

How do I make sense of all the parameters in the MixVelocity functions?
Many of the parameters for the MixVelocityRho, MixVelocityVp, and MixVelocityVs 
rock physics functions are specific to the chosen mixing function algorithm (Xu-White 
Approximation, Layered Clay, Critical Porosity, and so forth).

Mixing function algorithm groups
The mixing function algorithms (20) can be classified into six groups:
• Group 1—Grain supported, Layered clay, Matrix supported, Self consistent, Xu-

White (iterative), Xu-White approximation, and Woods
• Group 2—Dispersive clay and Dispersive and layered clay 
• Group 3—Cemented spheres scheme 1 and Cemented spheres scheme 2
• Group 4—Critical porosity
• Group 5—Backus, Hashin-Shtrikman Lower Bound, Hashin-Shtrikman Upper 

Bound, Reuss, Voigt, Voigt-Reuss-Hill, and Wyllie
• Group 6—mixing algorithm Krief-Gurevich-Goldberg

Figure 15. PowerLog Depth Conversion window
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Mixing algorithm specific parameter usage

Consult the online help topic named Mixing Function Algorithm Examples - 
MixVelocityVp and a similar discussion in the RPM for PowerLog — Function Quick 
Reference Guide.

These topics provide:
• A table showing what input parameters are needed for each mixing function 

algorithm (MixVelocityVp method parameter)
• Two sets of MixVelocityVp function example inputs
• A results summary obtained from using different mixing function algorithms. 

(method) with the two examples.

How is information in the RPM documentation organized?
Each RPM document begins with a Using this Document section and contains in the 
Where to find information area, a description of what information each Adobe Acrobat 
document contains.

What determines if a node generates a curve or a single value?
If the function contains at least one input curve (curve alias name), a curve is the 
function output.To state it conversely, if all inputs are single values, the function output 
is a value.

Exceptions to the statements apply to functions that specifically create only a single 
value for output. See the RPM for PowerLog Function Quick Reference Guide for 
functions marked: Output Single Value Only.

How do I make suggestions to improve RPM for PowerLog?
As customers begin using RPM for PowerLog to enhance their rock physics modeling 
and exploration decision-making, we want to hear your ideas for making this software 
more efficient, easier to use, and oriented to helping you develop new methodologies.

Table 7. MixVelocityVp Parameter Usage Matrix by Mixing Function Algorithm Group

Mixing Function Algorithm Group 1 2 3 4 5 6
Input Parameter for MixVelocityVp
alpha_1 Crack (pore) aspect ratio 1st mineral MD MD
alpha_2 Crack (pore) aspect ratio 2nd mineral MD MD
Dalpha_1 Change in aspect ratio with change in porosity for 1st mineral OD OD
Dalpha_2 Change in aspect ratio with change in porosity for 2nd mineral OD OD
Orig_Poro1 Original porosity first rock MD MD
Crit_por_1 Critical porosity 1st mineral MD
Crit_por_2 Critical porosity 2nd mineral MD
KGG_A0 Krief-Gurevich-Goldberg coefficient 0 MD
KGG_A1 Krief-Gurevich-Goldberg coefficient 1 MD
method algorithm - insert appropriate mixing function algorithm MD MD MD MD MD MD
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You can send, and we will respond to enhancement requests at:
• Email— support.RPM@fugro-jason.com
• Telephone— +1 214 368 2191

See “Scheduled Enhancements” on page 63, for the current enhancement items 
planned for RPM for PowerLog in 2006.

What example workflows can I use to get started?
RPM for PowerLog comes with four, ready-to-use tutorial workflows. These workflow 
files can be accessed from the C:\Pwrlog32\RPM\Workflow Templates 
directory.

Documentation that describes the key goals and strategies for these workflows can be 
found in the Tutorial Workflows section of the RPM for PowerLog — User Guide. The 
documentation describes the (1) input curves, (2) resulting PowerLog curves, 
(3) named constants, and (4) key equations used.

How do I know if a calculation failed or succeeded?
To determine the success of a calculation at a specific node:
• Examine the Output Log dialog and look for errors.
• If a curve is output, place the cursor over the node and examine the status bar. 

You should see the mean value of the curve, number of samples, node number, 
and curve name. See Figure: 21, ‘Displaying node curve mean value”, on 
page 55 as an example.

• When you place cursor over a node, node n: Output curve is <curve 
name> or node n: <Output type> is <value> displays, the calculation 
succeeded.

When a node calculation fails, the message displaying in the status line says, “node n: 
output is undefined and calculation failed.”. 

What’s the procedure to report a software problem?
You can quickly report any software problems to the RPM for PowerLog team by:
1 Select the Help > Create Problem Report menu command. Fill-out the 

Microsoft® Word document and save it to a file. Attach this Problem Report to an 
email, along with any PowerLog and RPM project data files.

2 Select the Help > Printable Documentation > Problem Report Form menu 
command. Print this Problem Report and fill-out the form. Fax or send this problem 
report to our offices at:
– Email— support.RPM@fugro-jason.com
– Fax number— +1 214 368 5281
– Address—1600 North Collins, Suite 1700, Richardson, Texas 75080 USA

To help us resolve the software difficulty fast and efficiently
1 Include your contact information. We may need to ask more questions.
2 Provide your three RPM workflow files. We can examine the files and help spot 

any difficulties.
– RPM Project file: <projectname>.proj
– RPM Node Definition file: <projectname> + Node.txt
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– RPM Workflow graphic file: <projectname>.dot

3 Is the problem related to a specific rock physics or basic function? Please list the 
input parameters and types of curves so we can run tests to duplicate the issue.

4 Is the problem data-dependent? Does the error happen on a specific well or using 
a specific curve? Depending upon the well’s confidentiality, we can discuss how to 
resolve the problem, while constantly protecting your commercial and intellectual 
property.

What makes an effective problem report?
Problem reports that get effective results, concisely provide three key pieces of 
information:
• Inputs—PowerLog project name, well name used with workflow, plus curves and 

constants used as inputs in the workflow.
• Customer RPM settings—functions used, function input parameters, and rock 

physics properties. Most of this information is in the three RPM workflow files.
• Reproduction—the steps you remember taking before the problem in RPM 

happened.
• Final output—curves saved to PowerLog and modeling constants estimated.

Reproducing your situation in our test environment, is the key for the RPM software 
development team to diagnose, fix, and document any software problem.

We (Fugro-Jason) cannot say enough about recalling and writing down the sequence 
of steps that brought the RPM software problem to your attention. Some tips for writing 
steps to re-enact a software problem include:
• Goal—state in the problem description what you were attempting to do.
• Unexpected result—what first happened (visually or in a message) that indicated 

things were not correct.
• Concise steps—write brief descriptions of each step (you don’t need to say why 

you did the step) so we can duplicate your actions.

Fugro-Jason is your partner in successfully developing your rock physics modeling 
projects with the RPM for PowerLog software.

Does RPM handle rocks and minerals differently?
RPM for PowerLog handles minerals and rocks differently. How the defaulting 
mechanism differs for minerals and rocks, requires more explanation.

RPM makes a distinction between minerals (such as quartz and calcite) and rocks 
(sandstone and limestone). Properties unsuitable for minerals (such as original 
porosity OriginalPorosity) have values that are initially set as undefined 
(UNDEF). Properties unsuitable for rocks (such as the density, Rho, which would imply 
dependencies on other Properties table parameters such as porosity) have values 
which are also initially undefined. From Set Mix Defaults dialog, only mineral property 
values (not rocks) can be used as an automatic default in an RPM function parameter.

Example If the bulk modulus of a mineral phase is required as an input parameter K_1 in 
MixVelocityVp (Xu-White Approximation method) function and the user does not 
specify a value, the quantity found in the Rock and Fluid Properties for mineral1.K 
is used. This is indicated by the tool tip displayed when the cursor hovers over the 
input field. If mineral1 is quartz, then the default value is quartz.K.
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Caution! This automatic default value mechanism does not apply to rocks. There is no specifi-
cation of a default rock or rocks, and rock values are not automatically used from the 
Rock and Fluid Properties, if the user leaves the input parameter blank.

Example In MixVelocityVp (Xu-White Approximation method), if the Orig_Poro1 parameter is 
blank, it cannot default to OriginalPorosity for a rock (such as sandstone). The 
reason is there is no default rock, and the function cannot default to Origi-
nalPorosity for the default mineral. The user may change the UNDEF values for a 
rock or mineral in the Rock and Fluid Properties to specific values, but these prop-
erty values associated with a rock or mineral are still not used as a default if the user 
leaves an input field (with a rock blank, as opposed to a mineral) in a function. Input 
fields associated with rocks that are left blank default to undefined (UNDEF) values. 
The documentation and the tool tips indicate which input parameters default to unde-
fined values for this reason.

The limitations on automatic defaulting described do not inhibit your ability to explicitly 
select a rock or mineral value from the Rock and Fluid Properties. You can still enter 
a numerical value as a rock input for an RPM function.

For complete details, see the RPM for PowerLog User Guide.

How can I systematically remove my errors from a workflow?
There are many techniques and user interface elements you can use to find and 
remove workflow errors. One systematic approach might look like this:
1 Use the Calculate > Output Log menu command to determine what nodes are 

generating errors. Look for the initial node where the calculation fails.
1 Check to see that all input curves exist for the well you selected Use the Curve 

List and Curve Alias List dialogs to determine possible well curve names.
2 Check to see that all input node calculations (those with input curves) succeeded. 

If not, check the constants and the input curve names used.
3 Isolate a node calculation that failed. Use the Show Ancestors command to 

identify all nodes that contribute inputs to the failed node’s calculation.
4 Determine a path where most calculations are failing. Beginning with the initial 

failing node (examine the Output Log to identify this node), calculate each node 
one at a time.

5 Check each node’s result by hovering the cursor over the node. Each node dis-
plays the calculated value (mean value for curves) or an undefined message in the 
status bar.

Where do I find details about basic and rock physics functions?
The documentation about the rock physics and basic (math, trigonometric, statistics, 
random numbers, and conditional logic) functions can be accessed several ways:
• In the Function Selection dialog (when you edit a node), click the Help button to 

display details about the results, input parameters, and procedures.
• Use the Help > Function Quick Reference command to display summaries of all 

the rock physics and basic functions. Use this online help to print function 
reference sheets.

• Read the RPM for PowerLog — Function Reference Guide to see examples, 
references, and explanations about each Rock Physics function.
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How can I minimize workflow calculation messages, yet still fix any 
problems?

To minimize the number of message alerts you receive when you calculate the 
workflow, do this:
• Turn-off the PowerLog curve overwrite warnings by using the Calculate > Block  

Curve Overwrite Warnings command.

Caution! This setting permits RPM for PowerLog to overwrite PowerLog curves that are not 
write-protected.

• Remove the check mark beside the Calculate > Show Node Process Order 
command to eliminate this quality control display.

• Send any node warning and error messages to your output log file by displaying 
the Output Log dialog before you calculate the entire workflow. Do this with the
Calculate > Output Log command, then calculate the workflow by pressing [F8].

Note The PowerLog curve overwrite warnings are blocked from one RPM work session to 
another, until you remove the check mark from the Calculate menu by selecting the 
Calculate > Block Curve Overwrite Warnings command once again.

Note PowerLog curves that are “write-protected”, are not overwritten with new data. You 
only need to protect the input curves from changing. RPM for PowerLog creates and 
writes all other calculation curves to PowerLog.

Can I use an expression for inputs to the ConditionalExpression 
function?

(Conditional Logic category) The if_true and if_false input fields cannot have an 
expression. If you need to make a calculation such as converting an acoustic log to a 
velocity function (1000000/n4), create another node that implements this operation 
and put the conversion node number in the if_true field within the Function 
Selection dialog.

What can I do if all my connections don’t redraw on a complex workflow?
Select the Edit > Reconnect command or press the [F6] function key. RPM for 
PowerLog redraws and saves all the connections when the workflow gets complex.

How can I copy project properties from one RPM project to another?
In RPM for PowerLog version 2.0, the software will contain functions to import and 
export rock, fluid, and mineral properties among RPM projects. For now, you must use 
a text editor and manually copy the desired rock, fluid, and mineral properties using 
this procedure in the RPM for PowerLog Getting Started Guide.

To import rock and fluid properties manually
1 Ensure that neither project (*.proj) file is in use by RPM for PowerLog.
2 Using a text editor such as NotePad, TextPad, or UltraEdit, open your source RPM 

project (project containing the rock, mineral, and fluid properties you want to copy).
3 Open the destination RPM project.
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4 In the source project find the ROCK, MINERAL, or FLUIDORGAS property you 
want to copy.

5 Select the entire section of the property, include a blank line.

Caution! Each RPM property begins with a dollar sign ($) and ends with a blank line, line feed, 
or return character. All properties must be inserted into any RPM project file above the 
Constants section, which begins with the text ($$Constants).

6 Copy and paste the text to the destination RPM project.
7 Repeat steps four to six for each property you want in the destination RPM project.
8 Save and close the destination RPM project

What keyboard shortcuts can I use for frequent RPM commands?
RPM for PowerLog menus contain shortcut keys to help you quickly choose RPM 
commands instead of clicking on main or context-sensitive menus.

Note If you are running on Windows XP and the shortcut keys are not displaying, use the 
procedure found in the RPM GUI Reference section of the RPM for PowerLog User 
Guide to display the menu shortcuts.

Table 8. Common RPM for PowerLog shortcut commands 

Shortcut keys RPM command

Ctrl + Keypad “+” Add node to workflow

Ctrl + R Ancestor display for selected workflow node

Ctrl + Keypad “-” Block Curve Overwriting Messages

F8 Calculate the entire workflow

Ctrl + L Curve list for selected well displays

Ctrl + D Descendents display for selected workflow node

Ctrl + F Find a node in the workflow

Alt + h + r Function quick reference documentation displays

Ctrl + O Open RPM project file (can browse through directories)

Ctrl + / Output Log displayed to show calculation messages

F5 Refresh the workflow display

Ctrl + S Save the current RPM project

Ctrl + Z Undo the last workflow operation

F1 User Guide documentation displays



Rock Physics Module for PowerLog v2.7 — Getting Started Guide [Maintenance Release] August 25, 2006 Page 46

Frequently Asked Questions How do I use conditional logic to select calculations for specific situations?

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

How do I use conditional logic to select calculations for specific 
situations?

Three functions can implement conditional logic within workflows:
• IsUndefined—detects undefined parameters or curves within your workflow.
• ConditionalExpression—helps you compare two values and create your output 

from one input if the relationship evaluates True, and takes output from another 
input if False.

• SimpleExpression—helps you develop a more complex mathematical and logic 
expression, using up to 20 input parameters to build the custom function.

See the RPM for PowerLog Function Quick Reference Guide for details and 
examples.

What tools can I use to successfully create a robust workflow?
RPM for PowerLog provides a number of integrated tools to help you successfully 
build a rock physics model consistent with your available logs. Consult the RPM for 
PowerLog User Guide to get additional details about each of these tools.

The RPM for PowerLog tools you can use include:
• Documentation—you can access all of the RPM for PowerLog documentation 

using the Adobe Acrobat Reader (version 6 recommended) to quickly find 
information. Each document has an extensive index and you can employ a full-text 
search to find significant keywords.

• RPM User Interface—you can quickly define input nodes (that incorporate 
available well logs), define your calculations using the Function Selection dialog, 
and create output curves to display in PowerLog.

• Function Help buttons—each basic or rock physics function has a Help button, 
which displays function documentation in an Internet browser window.

• Shortcut menus—nodes, connections, groups, and the workflow workspace itself 
contain context-sensitive menus that permit you do operations quickly.

• Right-click selection lists—within many of the dialogs you can right-click (MB3) 
to display a selection list that provides appropriate choices for this parameter, 
parameter type, and so forth.

• Status bar and node tool tips—as you build the workflow, you can use the cursor 
to “hover” over a node to get node function and calculation result information.

How can I simplify the workflow once all calculations are working?
Fugro-Jason is currently developing techniques to enhance the workflow calculation 
and to optimize the calculation procedure. One of the first steps toward this 
optimization is creating the SimpleExpression function. This function helps you 
construct a useful arithmetic expression within a single node, which can also include 
conditional logic.

See the RPM for PowerLog Function Reference Guide for exact details and 
examples for using the SimpleExpression function.
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What basic functions are most useful for RPM workflows?
Some of the more useful basic functions include:
• Add—add samples for two curves or just two values together.
• Conditional—Have the output be one of two results, based on a conditional 

relationship test.
• DivideBy—divide one value by another
• GetCurve—define a curve or a parameter as an input node.
• Mean—mean value of a curve’s samples (undefined samples ignored)
• Power—raise parm1 to a power specified by parm2 (single values or curves)
• Product—multiply samples for two curves or just two values together.
• Rms—Root-mean-squared power of a curve.
• SimpleExpression—create a simple expression from up to 20 inputs. Use to 

reduce the number of nodes after calculations are validated and known to provide 
predictable results.

• Subtract—take the difference of two values

How do I determine which nodes or curves are correct for a function?
The output from any RPM node can be assigned a type. RPM function input 
parameters take a specific type, such as bulk modulus or shear velocity. You can 
define your output as a specific type. Later, when you need that node as an input to 
another function (that requires this input) type, the right-click selection list only displays 
nodes with the appropriate types.

If you perform an arithmetic calculation such as addition, the default output type is 
any. For some functions, if you know the output type, you can choose it from the Type 
drop-down selection list on the Function Selection dialog.

For a complete list of output types defined by RPM, see the Outputs and types area of 
the RPM Concepts section within the RPM for PowerLog User Guide.

How do I find an individual node in a complex workflow?
RPM for PowerLog uses its Find Node function to help you locate any node within the 
workflow.

To find a node in the workflow
1 Use one of these methods to invoke the Find Node command:

– Select the View > Find Node menu command.
– Right-click in an empty workspace area and select Find Node from the 

Workspace shortcut menu.

– Click the toolbar icon.

2 When the Node Locator dialog displays, select the desired node and click OK.

The specified node flashes with a yellow background twice. If the node location is 
outside the screen display area, the screen scrolls left or right to display the node. 
If the specified node is hidden within a minimized group, the group opens to reveal 
the node.
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Is there an RPM reference of all software commands and functions?
Currently you can find a list of all:
• All functions and user interface commands—RPM at a Glance quick reference 

PDF.
• Software commands—the RPM User Interface section within the RPM for 

PowerLog User Guide.
• Rock physics and basic functions—the Functions Overview section of the RPM for 

PowerLog Function Reference Guide.

How do I delete multiple workflow nodes?
To delete several nodes at once
1 Move the nodes you want to delete by clicking and dragging each node to an 

unused portion of the workflow.
2 Click and hold the mouse down at a point in the workspace representing the top 

left-hand corner of your node deletion area.
3 Drag the cursor to the bottom right-hand corner of the area containing all the 

nodes you want to delete. Release the mouse button. Your workflow would look 
similar to Figure: 16, ‘Deleting multiple nodes within a workflow area”.

4 Press the [Delete] key. This deletes the enclosed nodes.

Hint If you included a node you did not want to delete, use the Edit > Undo command to 
restore all the deleted notes to your workflow.

Can I avoid retyping the same function input values?
RPM for PowerLog has two features that help you define rock model constants:
• Rock and Fluid Properties—helps you define constant properties for rocks, 

minerals, fluids, and gases.
• Constants—helps you define named constants for a (a) literature value, 

(b) equation coefficient obtained from empirical measurements, or (c) any number 
you want to use consistently as a function input parameter.

Use the Data > Rock Fluid Properties command to supply different values to rocks, 
minerals, gas, and fluids defined by the software. Alternatively you can add other 

Figure 16. Deleting multiple nodes within a workflow area
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rocks, minerals, gases, and fluids to the list. Once you add a new Rock, Fluids, and 
Minerals list item, you can define values and units for one or more properties that are 
associated with your new list item.

Use the Data > Constants command to define any named constant that you want to 
use in the node function input parameters. When editing any node using the Function 
Selection dialog, right-click on a space under the Value/Name column and select 
Constant. Select the constant you want to use as a function input parameter.

Hint At any time, you can add, change, or delete your Rock, Fluids, and Minerals list 
items and properties. Also you can do the same with the Constants. However, the 
default list of Rock and Fluid properties defined by RPM for PowerLog can be 
changed, but never deleted.

Caution! You need to take care whenever you rename an existing RockProperty (for example, 
quartz.K) or a named constant. RPM for PowerLog currently does not automatically fix 
all the Constant and RockProperty names in existing nodes. See “How do I fix nodes 
when a RockProperty and Constant is renamed?” on page 57.
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How does curve fitting work with workflow nodes?
RPM for PowerLog performs curve fitting within its workflow node structure by using 
three workflow components:
• Function—node containing a rock physics or basic function with one or more 

parameters.This is the function for which you vary the input parameters.
• Curve—node whose output is the curve you want to approximate with the 

Function Node.

Note RPM for PowerLog minimizes error between the fitted curve and Curve Node output 
using Mean Least-squares or Average Difference error criteria.

Example Curve fitting in an RPM for PowerLog workflow generally follows the procedure in this 
example, However a user can experiment by varying multiple combinations of function 
input parameters.

1 Identify the Function Node. This is the workflow node that has the approximating 
function you want to fit to the Curve node. This example uses the GardnerVtoRho 
function with several empirical coefficients (GardA and GardB) that the curve 
fitting algorithm can vary. The output curve is named RHOCalc.

2 Identify the Curve Node. This is the curve that the Function Node attempts to 
approximate by varying its input parameters. The output curve is named RhoMeas.

3 Select the Calculate > Curve Fitting command. The Curve Fit dialog displays.
4 Right-click in the Function (Calculated Node to Fit) text box. Select Node and 

choose n2 from the node list. Immediately the GardnerVtoRho function 
parameters found in the Function Node n2 display in the Curve Fit dialog.

5 Right-click in the Curve (Observed Data Node) text box. Select Node and choose 
n1 from the node list. This is your Curve Node.

6 Select the Optimization Method used to calculate the error between the 
approximating function (Calculated Node to Fit) and the curve (Observed Data):
– Mean Least Squares, default setting
– Averaged Difference, used for large sample values

7 In the User Param column select the check box beside parameter GardA. For the 
Lower Bound cell, type 250. For the Upper Bound cell, type 270. The software 
varies the GardA parameter within this range and attempts to minimize the error.

8 Leave the Log output to file box unchecked (minimizes the calculation time) and 
use the default value for Fit Precision of 1.0e-15.

9 Click Compute. The Curve Fit dialog displays the parameters that found the 
minimum error (GardA = 253.059) between the output from the Function Node 
(n2) and the Curve Node output (n1). The curve FITCURVE is stored in the 
PowerLog well and can be plotted with the Curve (RhoMeas).

10 Click Apply. The GardA input parameter value that produced the minimum error 
(GardA = 253.059) is copied to the Function node n2.
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Figure 17. Curve Fitting example

Function Node

Curve Node

Curve NodeFunction Node
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Where can I display details about the curve fitting computations?
To see the computation details about the curve fitting
1 Perform the desired curve fitting and select the Log output to file check box under 

the Custom Parameters area of the Curve Fit dialog. (See Figure: 17, ‘Curve 
Fitting example”, on page 51.)

2 Once the curve fitting completes, select the Calculate > View Curve Fitting Log 
File menu command to display the computation details.

3 [Optional] You can plot the curve you wanted to approximate on top of or alongside 
the FITCURVE curve in PowerLog to compare your results.

Can I select a curve name for a node output?
Yes. You can right-click (MB3) the Output field when editing any node with the 
Function Selection dialog. RPM for PowerLog displays the current list of PowerLog 
well curve names (Figure: 18, ‘Selecting a curve name for output”). Click on the 
desired curve name to place it in the Output field.

Caution! Prior to selecting curves that you can overwrite in your PowerLog well, you may want 
to protect your input curves to avoid accidental well data loss.

To protect PowerLog curves from accidental overwriting
1 In PowerLog, select the File > Well > Information command.
2 Click the Curves tab.

Figure 18. Selecting a curve name for output
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3 Select the check box found under the Protect column, beside each curve name 
you wish to protect (Figure: 19, ‘Protecting curves in PowerLog”).

4 Click OK.

Can I get a hardcopy of my workflow?
Yes, use this procedure to print your workflow.

To print an RPM for PowerLog workflow
1 Using the Edit > Set Workspace Size menu command to customize your 

workspace size to contain your workflow, without excess surrounding space. 
Figure: 20, ‘Customize the workspace size”, on page 54 shows how you can 
customize the workspace size to fit your workflow complexity.

Figure 19. Protecting curves in PowerLog
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Hint Because the hardcopy output of a single page is scaled to the RPM workspace size, 
setting the workspace too large reduces it to a smaller size on the printed copy or 
plotter. Set the workspace too small and parts of the workflow may not print.

2 Use the Edit > Preferences menu command to set your workspace color so it is:
– A light background that does not obscure the printed workflow contents
– Compatible with your node, connection, and group colors chosen
– Easy to view on the screen

Note See the example found in “Background workspace color” on page 61.

3 Select the File > Print Workflow menu command.
4 When the Print window displays, select one of your local printers in the Select 

Printer area.
5 Change the Number of Copies if necessary and click Print.

Is there a quick way to see if a node curve calculation is correct?
Yes, after running a calculation at one or more nodes (or the entire workflow), place 
your cursor over the desired node. The tool tip displays the function name and 
parameters. The status bar displays the mean value, the number of samples, node 
number, and curve name. See Figure: 21, ‘Displaying node curve mean value”.

Figure 20. Customize the workspace size
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Will workflows accommodate comments or titles?
Not at the moment. If you want to add titles or comments to your workflow, use the 
node or group procedure shown.

To add a comment using a node
1 In any blank area of the workspace, right-click (MB3) and select the Add Node 

shortcut command.
2 Click in the workspace to add the node.
3 Double-click the node and display the Function Selection dialog.
4 Use the default Add Function. Type 1 for the values of val1 and val2.
5 Type the node number in the Output field.
6 In the Label field add your title or comment. The function dialog should look similar 

to Figure: 22, ‘Adding a node title or comment”, on page 56.

Hint The title displays as a single line so you should not try to insert multiple sentences. 
You can make several comments or titles throughout the workflow.

Figure 21. Displaying node curve mean value
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7 Right-click (MB3) on the node and select the Change Color shortcut command.
8 Select a basic color or add a custom color in the Select Color dialog. Click OK.
9 The node displays the contents of the Label field on the workflow.

Creating a multi-line comment using a group
To add a comment using a group rectangle
1 In any blank area of the workspace, right-click (MB3) and select the Define Group 

shortcut command.
2 Left-click (MB1) in the workspace. Hold the MB1 down and drag the mouse to 

define an area for the group. Release the mouse button (MB1).
3 Double-click in the group.
4 When the Group Name dialog displays, type your comment in the Type Group 

Name text field.

Hint The Type Group Name field is small, yet it accommodates a very long multi-line 
comment.

5 When you finish typing the comment in the Group Name dialog, click OK. The 
comment displays as the group name.

6 Place the cursor on the top, left, right, or bottom group border. When the cursor 
changes to a resizing cursor (two arrows), click and resize the group rectangle 
smaller or larger.

Figure 22. Adding a node title or comment
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7 Repeat step 6 to adjust the comment in the group rectangle.
8 Click in the group center. Hold the mouse button (MB1) down and drag the group 

to the desired location in your workspace.

What is the best way to define constants for a workflow?
If the constants are not linked to rock, mineral, gas, or fluid properties, two approaches 
exist to define constants:
• Individual nodes—create a node with a UserValue or perform a needed basic 

mathematics function. Repeat this for each constant you require. The node Label 
documents the constant and the node Output can be used as an input parameter 
throughout the workflow. For examples and procedures, see the Setting up typical 
input curve and constant nodes area of the Planning Workflows section in the RPM 
for PowerLog — User Guide.

• Named constants—define several named constants and document with a group 
box. This approach minimizes the number of additional nodes added to the 
workflow. For procedures, see the Creating named constants area of the Planning 
Workflows section in the RPM for PowerLog — User Guide.

To document named constants for a workflow
1 Create all the named constants using procedures found in the RPM for PowerLog 

— User Guide.
2 Create a new group for a multiple line comment using the procedure: “Creating a 

multi-line comment using a group” on page 56.
3 Adjust the spacing between the constants so they display as a vertical list of 

names in the format: ConstantName = value (units). This has to be done 
by trial and error.

How do I fix nodes when a RockProperty and Constant is renamed?
To fix nodes with a renamed RockProperty or Constant
1 Double-click the desired node or right-click (MB3) desired node and select the Edit 

Node shortcut menu command.
2 Right-click (MB3) on the RockProperty or Constant input parameter.
3 When the input parameter type list displays, select the type.
4 When the RockProperty selection list displays, select a rock, mineral, fluid, or 

gas, then choose the desired property.
or
When the Constants selection list displays, select the desired named constant.

5 Repeat steps two through four for each input parameter to fix.
6 Click OK to save the node changes.
7 Repeat steps one through six for all affected workflow nodes.

How rules does RPM use to name properties, constants, and curves?
RPM for PowerLog uses these business rules to name your data items:
• Named constants—constants defined by the user are case-insensitive and can 

not have blank characters in their names. The two named constants 
Shale_Velocity and Shale_velocity are considered the same constant.



Rock Physics Module for PowerLog v2.7 — Getting Started Guide [Maintenance Release] August 25, 2006 Page 58

Frequently Asked Questions What is an example of an effective workflow color scheme?

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

• RockFluidProperty—the RPM-defined and user-added rock, mineral, fluid, and 
gas, plus their property names, are case-insensitive and can not have blank 
characters in their names. The user-added items Halite, HALITE, and halite 
are considered the same item by RPM.

• PowerLog curve names—the curve names are case-insensitive, can not have 
blank characters, and are limited to a maximum of eight characters. PowerLog 
curve names display in capitals letters (GR, DT, RHOB, and so forth) in the RPM 
for PowerLog dialogs, regardless of whether lower-case letters or capitals were 
used in the curve names.

What is an example of an effective workflow color scheme?
RPM for PowerLog provides you the ability to set the colors of each workflow:
• Node
• Group
• Connection
• Workspace background

While using individual colors can make your workflow take on a kaleidoscopic 
appearance, you may want to use a color scheme that helps you easily recognize 
workflow elements, displays well on the screen, and provides a good printed workflow.

Note This color scheme is used in the RPM User Guide to document the Tutorial Workflows.

Table 9. Example workflow color scheme

Workflow Element Color
Color Specification
Red: xxx, Green: yyy, Blue: zzz

Workspace (background) Red: 255, Green: 255, Blue: 192

PowerLog input curves (nodes) Red: 255, Green: 85, Blue: 0

Computation nodes Red: 255, Green: 255, Blue: 127

Groups (background) Red: 255, Green: 170, Blue: 0

Output results (nodes) Red: 173, Green: 216, Blue: 230

Labels - workflow and constants Red: 85, Green: 170, Blue: 255

Connections Black Red: 0, Green: 0, Blue: 0
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What are the assumptions for using Gassmann’s fluid substitution?
Before using Gassmann’s fluid substitution functions, you should ensure that the 
underlying assumptions for this model are satisfied and that your input parameters 
take into account these assumptions (Mavko et al, 2005 [27]):
• Rock solid phase is elastic and homogeneous

– In practice, estimate average bulk modulus of mineral mix and substitute this 
average.

– Works for quartz, feldspar, calcite, and dolomite. Large clay volumes induce 
errors and clay pore-filling and structural clay impact mixing differently

• All saturations are pure and 100%, without mixtures
– Estimate average density and compressibility of pore fluid mixture
– Determine whether the fluid mix is fine or the saturation is “patchy”

• Isotropic rocks - in practice, ignored
• Perfect fluid communication in pore space

– Good for low viscosity pore fluids and high porosity rocks 
– Poor for heavy oil, high shale content, and low permeability

Can I position the RPM tool bar icons anywhere?
You can move the RPM for PowerLog tool bar icons to the left, right, bottom, or top of 
the workspace area.

To undock and dock the tool bar icons:
1 Place the mouse on the extreme left top portion of the tool bar until the cursor 

looks like Figure: 23, ‘Drag dockable tool bar to new location”.
2 Click (MB1) and drag the tool bar to the left, right, bottom, or top side of the RPM 

workspace.
3 Release the mouse button (MB1).

Figure 23. Drag dockable tool bar to new location
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BEST PRACTICES
This section describes some of the best practices developed at Fugro-Jason for using 
the RPM for PowerLog software:

• Minimizing the number of temporary curve names
• Using workflow color preferences
• Using input nodes effectively in a workflow
• Using node numbers and curve names wisely
• Determining inputs to a problem calculation

Minimizing the number of temporary curve names
You can use the same name for multiple curves (for example, TEMPCALC) provided 
the curves are not used as input to other calculations. This helps eliminate the 
situation where you have a large number of extra curve names that are not used in 
other parts of the workflow. However, this does not permit you to review the 
intermediate results produced.

Using workflow color preferences
At any time during the construction of an RPM workflow, you can change the colors of:
• background workspace
• nodes
• connections
• groups
• selected path

Using the Edit > Preferences command, you can display the Preferences dialog 
where you can select specific colors (see “Background workspace color” on 
page 61) for each of the items and apply the colors to existing workflow elements.
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Hint You want your selected colors to be high-contrast and not very dark, so the workflow 
image can be displayed on a black and white printer.

Caution! For your workspace, you want to avoid a dark gray (R-128, G-128, B-128) or a 
light gray (R-192, G-192, B-192) color.

Background workspace color
To create a background workspace color that decreases eye strain and displays well 
on a black and white printer, follow this procedure.

Setting the workspace color:
1 Select the Edit > Preferences command to display the Preferences dialog.
2 Click the Default Color for the Workspace area.

Figure 24. Preferences dialog
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3 When the Select Color dialog displays, type these numbers:
Red: 255, Green: 255, Blue: 192.

4 Click Add to Custom Colors to define this light-maize background.
5 Select this new maize color that displays under Custom colors and click OK.
6 On the Preferences dialog, click OK.

Using input nodes effectively in a workflow 
Several nodes within your workflow are classified as input nodes, that is, nodes that 
use PowerLog curve names (or curve aliases), defined RPM constants, or numbers to 
define an output that can be connected to multiple nodes throughout the workflow.

Most input nodes are usually defined as:
• A user value
• A pre-defined constant from the Constants dialog or a property from the Rock 

Fluid Properties dialog
• A single curve read from the PowerLog well (use the GetCurve function to specify 

the curve as a node output)
• A simple computation using a PowerLog curve and a constant (such as converting 

an acoustic log to velocity, as done in Figure: 26, ‘Input nodes example”, on 
page 63).

Hint To help you effectively use input nodes in a workflow that is applied to multiple wells, 
you may want to provide a unique color code (such as red or blue) to all your input 

Figure 25. Select color dialog
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nodes. See the RPM for PowerLog User Guide for the procedure to apply a color to 
a single node.

Using node numbers and curve names wisely
Workflow calculation nodes can specify a node number or a curve name as the output 
(written to the PowerLog project well). Curves are created as the results of RPM node 
calculations and written to the PowerLog well project. On the positive side, populating 
PowerLog with a number of intermediate curve results can be helpful in reviewing your 
calculations as you develop the workflow. The downside, you may need to delete 
curves later or the curve selection list contains too many entries.

Figure 26. Input nodes example
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The RPM calculation nodes can be classified into three categories:
• Input nodes—Use PowerLog curve names or constants, along with the GetCurve 

function for these nodes.
(See Using input nodes effectively in a workflow.)

• Connection nodes—These nodes create outputs that are used as input 
parameters in other nodes. You should always use the node name for the input 
parameter, even if the curve has a different name. This creates the visual 
connections between nodes in the workflow.

• Output nodes—These nodes produce results that you want to store in the 
PowerLog project well. Specify a curve name [maximum eight characters, no 
blank spaces] for the result you want stored.

Determining inputs to a problem calculation
When a calculation at a node fails, one of the initial steps you can perform to resolve 
the problem is to determine all the inputs that affect this node.

To determine the nodes inputs

1 Select the View > Show Ancestors command or click the  toolbar icon.
2 Click the node where your calculation had difficulty. The nodes inputs are 

highlighted. according to your preferences.
3 [Optional] If the highlighted nodes are not distinctive enough, use the 

Edit > Preferences command to change your workflow element color 
preferences.

Hint Alternatively, you can determine the problem node if you select the Calculate > 
Output Log command. The log messages show the calculation sequence and the first 
error message indicates often where the calculation failed.

Figure 27. Show Ancestors example
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RELEASE NOTES
This section provides some of the most current documentation about last-minute 
changes made to the RPM for PowerLog software. These include:

• Resolved Issues—Issues and problems that were fixed in this software release.

• Known issues—These are problem areas in which the RPM for PowerLog 
software may required the user (temporarily) to perform a more lengthy procedure 
or other work around.

• New Features—Functionality or features recently added to the software, but are 
not yet documented in the RPM for PowerLog User Guide. Sections “Frequently 
Asked Questions” on page 33 or the “Best Practices” on page 60 may provide 
brief descriptions of how to use these new features.

Resolved Issues
This is the initial release of the RPM for PowerLog software.

Known issues
1 Lassoing nodes that include a group box and then moving them does not move the 

group box, only the nodes inside the group.
2 Displayed connections can get out of synchronization with the RPM project. If this 

happens, the displayed connections can be restored by pressing the [F6] key or 
by selecting the Edit > Reconnect command.

3 Adding a new rock/mineral/fluid/gas and three new properties and then deleting 
one property results in two properties removed from the interface. Only the 
interface is incorrect. If you click Save and request the Rock and Fluid Properties 
dialog again, the missing property displays.

4 The GeometricMean function cannot handle undefined values. It gives an error if 
any of the values are UNDEF_POWERLOG. The function needs to check for 
undefined values on input.

5 RanVector and RanVectorGauss function do not create output PowerLog curves 
filled with random numbers.

• Tan and Atan functions not processing all input values correctly.

New Features
All features are new for this release of the RPM for PowerLog software.
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ancestors The collection of workflow nodes that affect the input connections to a 

selected node.

anisotropy Predictable variation of a property of a material with the direction in which it is 
measured, which can occur at all scales. For a crystal of a mineral, variation 
in physical properties observed in different directions is anisotropic. In rocks, 
variation in seismic velocity measured parallel or perpendicular to bedding 
surfaces is a form of anisotropy. See isotropy.

AVO Amplitude Variation with Offset. Variation in seismic reflection amplitude with 
change in distance between shotpoint and receiver that indicates differences 
in lithology and fluid content in rocks above and below the reflector. AVO 
analysis is a technique by which geophysicists attempt to determine 
thickness, porosity, density, velocity, lithology and fluid content of rocks. 
Successful AVO analysis requires special processing of seismic data and 
seismic modeling to determine rock properties with a known fluid content.

azimuth The compass direction of a directional survey or of the wellbore as planned or 
measured by a directional survey. The azimuth is usually specified in degrees 
with respect to the geographic or magnetic north pole.

bubble point pressure Pressure below which (for constant temperature) gas in solution in oil is 
released. Also called saturation pressure.

connection Input from one node of a workflow to another node which defines the 
ancestor and descendent relationships within the workflow.

crack aspect ratio Also called pore aspect ratio. The ratio [α = a/b] of the minor (a) and 
major (b) ellipsoidal axes that characterize the spheroidal pore shape of the 
representative reservoir rock.

critical porosity Porosity below which compressive load is transmitted through mineral grain 
physical contact, and above which compressional load is transmitted through 
the pore fluid, and the rock becomes a slurry.

crossplot porosity Porosity obtained by plotting two porosity logs against each other, normally a 
density and neutron porosity. The computation assumes a particular fluid, 
usually fresh water, and particular response equations. The result is largely 
independent of lithology and is often a more reliable porosity estimate than 
one porosity log.



Rock Physics Module for PowerLog v2.7 — Getting Started Guide [Maintenance Release] August 25, 2006 Page 67

Glossary dead oil

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

dead oil Oil that contains no gas in solution.

DEM Differential Effective Medium. This method is derived by assuming the 
composite is formed by successively mixing very small (infinitesimal) 
fractions of one inclusion material in another host material.

descendents The collection of workflow nodes affected by the output connections from a 
selected node.

deviation The angle at which a wellbore diverges from vertical. Wells can deviate from 
vertical because of the dips in the beds being drilled through.

directed graph Another name for a workflow containing nodes (where calculation functions 
happen) and connections (with arrows) that determine the calculation 
dependencies.

effective porosity Porosity due to movable plus hydrostatically bound fluids. The interconnected 
pore volume or void space in a rock that contributes to fluid flow or 
permeability in a reservoir. Effective porosity excludes isolated pores and 
pore volume occupied by water adsorbed on clay minerals or other grains. 
Usually less than total porosity.

function A calculation or a boolean operation applied to one or more connection inputs 
and yielding an output (value or curve).

gas-oil ratio The volume of liberated gas at one atmospheric pressure (and 15.6° C) 
produced per unit of oil produced. Given as Rs as a dimensionless volume 
ratio and as GOR in Scf/BBl. 

group A collection of nodes that can be named and manipulated together, so that 
the workflow complexity can be managed. These node collections help a user 
associate a workflow subsection with a computation goal.

isotropy A quality of directional uniformity in material such that physical properties do 
not vary in different directions. In rocks, changes in physical properties in 
different directions, such as the alignment of mineral grains or the seismic 
velocity measured parallel or perpendicular to bedding surfaces, are forms of 
anisotropy. See anisotropy.

inclination The deviation from vertical, irrespective of compass direction, expressed in 
degrees. For most vertical wellbores, inclination is the only measurement of 
the path of the wellbore.

inversion A mathematical process by which data are used to generate a model that is 
consistent with the data, the process of solving the inverse problem. In 
seismology, surface seismic data, vertical seismic profiles and well log data 
can be used to perform inversion, the result of which is a model of Earth 
layers and their thickness (seismic trace), density and P- and S-wave 
velocities. Successful seismic inversion usually requires a high signal-to-
noise ratio and a large bandwidth.
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live oil Oil that contains some gas in solution.

node A point in the workflow where you can define a function, using one or more 
connection inputs (values or curves), and generate an output (value or 
curve). A node’s output can be delivered to one or more other nodes.

MRU Most Recently Used list. List of the last five RPM projects accessed with the 
RPM software on this computer.

path A set of RPM nodes defined by a selected beginning node, a selected final 
node, and all connection nodes between the two selections. RPM for 
PowerLog permits you to perform all the calculations along a chosen 
workflow path.

RPM Rock Physics Module for PowerLog. A porting of the rock physics portion of 
the Jason Geoscience Workbench product that uses a Windows graphical 
user interface and takes advantage of the project and well management 
capabilities of PowerLog. PowerLog provides presentation displays and also 
performs some of the computations found in the previous product.

saturation equation An equation for calculating the water saturation from resistivity and other 
logs. There are many saturation equations. Practical equations are all 
extensions of the Archie equation, which is valid for a rock with very little clay, 
or very high salinity water, and with a regular pore structure. The majority 
deal with the problem of shaly sands, and can be divided into two main 
groups; (1) those that treat the shale as a volume of conductive material (Vsh 
models), and (2) those that analyze the effect of clay counter-ions.

Vsh models take many forms. Typical examples are the Simandoux, 
laminated sand, and Indonesian equations. The clay counter ion group 
includes the Waxman-Smits, Dual Water and SGS equations. Most nonshaly 
sand equations deal with the problem of mixed pore types, for example 
combinations of fractures, isolated pores, and intergranular pores.

specific gravity The ratio of a material’s density to the density of water; often used for gas.

survey A completed measurement of the inclination and azimuth of a location in a 
well (typically the total depth at the time of measurement). In both directional 
and straight holes, the position of the well must be known with reasonable 
accuracy to ensure the correct wellbore path and to know its position in the 
event a relief well must be drilled. The measurements themselves include 
inclination from vertical, and the azimuth (or compass heading) of the 
wellbore if the direction of the path is critical.

total porosity Total porosity = effective porosity + clay (electrostatically) bound porosity. 
The total pore volume per unit volume of rock. It is measured in volume/
volume, percent or porosity units. Total porosity is the total void space and as 
such includes isolated pores and the space occupied by clay-bound water.
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workflow A set of nodes that define the order and calculation dependencies for a set of 
rock physics calculations. Nodes can be linked together by using the output 
value or output curve of one node as an input for another node. A workflow is 
developed in an iterative manner and refined as you develop your 
methodology.

workspace A rectangular screen size chosen to construct and display the workflow.
The compass direction of a directional survey or of the wellbore as planned or 
measured by a directional survey. The azimuth is usually specified in degrees 
with respect to the geographic or magnetic north pole.
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