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Fugro-Jason
Please see our web site www.fugro-jason.com for a list of our offices, addresses, and contact numbers.

For general information please send an email with your request to info@fugro-jason.com.

Technical Support
When you need assistance with your work in Rock Physic Module for PowerLog, contact these resources 
in the Fugro-Jason RPM Technical Support Group:

Phone +1 214 368 2191

Fax +1 214 368 5281

E-mail support.RPM@fugro-jason.com

Hours 8:00 AM - 6:00 PM (CST), Monday through Friday

Address PETCOM, Inc.
1600 North Collins, Suite 1700
Richardson, TX 75080

Website www.fugro-jason.com

http://www.fugro-jason.com
http://www.fugro-jason.com/powerbench/RPM.htm
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USING THIS DOCUMENT
This section describes the initial tasks and information you want to know prior to first 
installing the Rock Physics Module (RPM) for PowerLog software. It includes:

• Introduction
• Where to find information
• Document conventions
• Using the Acrobat online guides
• Document revisions
• Technical support 

Introduction

Audience
This document is for petrophysicists, geophysicists, geologists, and reservoir 
engineers who want to develop standard and customized workflows for determining 
rock physics and pore fluid properties in well curves.

Where to find information
RPM for PowerLog — Getting Started Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 
procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “Installation”, describes the procedures needed to install the RPM for 
PowerLog software and a brief introduction to rock physics workflows.

• Section 3, “Frequently Asked Questions”, describes answers to common questions 
and work-around procedures for specific software issues.

• Section 4, “Best Practices”, provides some advice about handling specific 
situations in RPM for PowerLog, based on some initial software testing by the 
Fugro-Jason Professional Services group.

• Section 5, “Release Notes”, provides last-minute information about (a) issues 
resolved in this release, (b) known issues the development team is correcting, and 
(c) new features added from the previous RPM for PowerLog software release.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information throughout this document.

RPM for PowerLog — User Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 8

Using this Document Where to find information

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “RPM Concepts”, shows you the components that make up the 
elemental calculation nodes and how these nodes assemble as a workflow.

• Section 3, “Planning Workflows”, describes how to manage and plan your 
workflow. This involves defining input PowerLog curves, creating named 
constants, preparing mix defaults, and organizing rock physics properties.

• Section 4, “Building Rock Physics Workflows”, illustrates the step-by-step 
procedures used to create a complete workflow.

• Section 5, “Performing Advanced Workflow Tasks”, describes how to better 
organize the workflow, setup user preferences, troubleshoot calculations, import 
another RPM project parameters, and do curve fitting.

• Section 6, “Tutorial Workflows”, uses several workflows to illustrate general 
principles for developing a workflow, while providing individual users the freedom 
to create customized workflows with their unique methodologies. Topics covered 
include:
– Setting up input curves and rock parameters
– Organizing computations into groups
– Comparing calculated values against measured logs
– Selecting different error evaluation criteria
– Reducing the number of nodes for a mature workflow by using the 

SimpleExpression function
– Using conditional logic within the workflows

• Section 7, “RPM User Interface”, describes the organization of the Windows 
menus, mouse button three (right-click) functionality, tool bars, and significant 
dialog windows you use in developing the RPM workflow.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information throughout this document.

RPM for PowerLog — Function Reference Guide:
• Section 1, “Using this Document”, describes (a) locating information in the RPM for 

PowerLog documents, (b) documentation font conventions used, (c) effective 
procedures for using Adobe Acrobat documentation, and (d) Technical Support 
contact information.

• Section 2, “Rock Physics Introduction”, provides information common to the rock 
physics and basic functions. Topics include:
– Relevant publications
– Common Greek symbols used for rock properties
– Parameter types and how mineral default values are selected
– Rock and Fluid properties
– Algorithms for mix velocity rho, Vp, and Vs

• Section 3, “Function Overview”, provides a one line summary of each basic (math, 
trigonometry, conditional logic, statistics, and random numbers) and rock physics 
function provided by RPM. RPM organizes the functions into these groups:
– Anisotropy
– Anisotropy Inversion Support Arithmetic
– Arithmetic
– Discrimination and Conditional Logic
– Empirical Velocity
– Fluid/Rock Physics Functions for Brine, Gas, and Oil
– Gardner’s 
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– Gassmann’s Functions for Fluid Substitution
– Greenberg-Castagna
– Media-Bounds Functions (Two-phase Media)
– Media-Bounds Functions (Three-phase Media)
– Miscellaneous Supporting Functions
– Random Numbers
– Simple Modulus-related Functions
– Statistical
– Trigonometric
– Velocities for Bounds
– Velocity-Synthesis Functions

• Section 4, “Rock Physics Functions”, uses a terse, standard presentation format to 
describe how to use each rock physics function.

• Section 5, “Basic Functions”, uses the same standard presentation format to 
describe the use of basic mathematical, trigonometric, conditional logic, statistical, 
and random number functions.

• Glossary, explains terminology used in this document.
• Index, provides a quick method to locate information within the document.

Document conventions
This guide uses a concise menu notation, typeface changes, and reader alerts to set 
apart information in a structured way that makes it easy for the user to read.

Menu selection notation
Throughout the RPM for PowerLog documentation set, a shorthand notation is used to 
indicate the exact manner to invoke a specific menu command. The notation uses the 
format Menu > Command (or cascading menu name) > Command and displays the 
text in a bold font.

Example If the documentation shows how to select the command needed to display the
RPM for PowerLog Getting Started Guide, you would see Help > 
Printable Documentation > Getting Started Guide in the text.

Figure 1. Help menu for RPM for PowerLog
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Typeface notation

Reader alerts
These reader alerts provide valuable information throughout the Rock Physics Module 
for PowerLog documentation set.

Note Note text that alerts you to additional information to help with the work procedure. The 
note does not contain information necessary for you to complete the procedure. The 
note may extend the circumstances (If you want to save your project to a network 
drive) of a procedure.

Hint Hint text provides you with shortcuts or insight that help you gain the more experience 
and efficiency with the RPM software.

Caution! The cautions text alert you to situations when you can possibly lose information or 
work that was just performed. For example, cautions are used for situations where 
project files can potentially get corrupted or you could accidently delete critical files.

Example This is an in-line example used to quickly clarify a point just made in the document.

Step 1 The tutorial step 1 begins a series of tutorial steps that stand-out from the text to call 
attention to this procedure for the user.

Step 2 Second step

Step 3 Step number three

Table 1. Typeface conventions and symbols

Typeface convention Purpose

italics • Document or software titles
• Introduction of a new term
• Words that require emphasis

Bold Denotes graphical user interface objects and RPM functions. 
For example, RPM function names, menus, button labels, win-
dow names, option buttons, text fields, drop-down selection 
lists, and so forth.

[Alt+F] Keyboard keys are enclosed in square brackets and bold font. 
If the keys must be pressed simultaneously, a plus sign is used 
in the text.

{ } Text surrounded by braces (or curly brackets) indicates more 
than one option.

[ ] Text surrounded by plain square brackets indicate optional 
elements

... Horizontal ellipsis indicates you can supply more than one 
value or parameter for the preceding item(s)
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Step 4 Second to the last step

Step 5 Final step of the tutorial procedure.

Using the Acrobat online guides
The online Fugro-Jason documentation can be read using the Adobe Acrobat™ 
Reader. (If you do not have this software, you can download a free version of the 
Acrobat Reader software from Adobe’s Internet site - http://www.adobe.com/) The 
Adobe Portable Document File (PDF) displays the Fugro-Jason guides in full color and 
acts similar to an online help system. With the online guides you can:
• Control the size of the displayed document
• Print all or a portion of an RPM for PowerLog guide
• Find a specific topic using full-text search procedure
• Use bookmarks and hyperlinks to swiftly navigate among the pages.

Note Throughout the Fugro-Jason documentation you will see text that is colored as Blue. 
This text is a hyperlink (active link) that takes you to another portion of the document 
or to an external Internet site.

Displaying the online user guides

Step 1 Select the Help > Printable Documentation command and choose from the 
documents found on the cascading menu.
or
Outside the RPM application, use Microsoft Explorer to find the Acrobat PDF 
document in the X:\Pwrlog32\RPM installation directory and double-click on one of 
these guides:

• RPM_PowerLog_User_Guide.pdf
• RPM_PowerLog_Function_QuickRef_Guide.pdf
• RPM_Freq_Asked_Questions.pdf
• RPM_PowerLog_Getting_Started_Guide.pdf

Step 2 Click in the left pane to display the table of contents Bookmarks and access specific 
document pages.

Setting the navigation menu for the online user guides
The RPM for PowerLog documentation files can be navigated similar to HTML pages 
on the Internet, using a Forward and a Back button to display pages. To display the 
Acrobat Navigation toolbar for this functionality, do this:

Step 1 Choose the View > Toolbars command.

Step 2 Ensure that the check box beside the Navigation toolbar is selected. Your screen 
should look like Figure: 2, ‘Display the Acrobat Navigation toolbar”, on page 12, 
for version 6 of Acrobat Reader.

Step 3 [Optional] To dock the Navigation toolbar with other Acrobat toolbars, press 
[Alt+Ctrl+D] keys.

http://www.adobe.com/products/acrobat/readstep2.html
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Changing the display size of online user guide text

Step 1 Press [Ctrl+M] keys to access the Zoom To dialog box.

Step 2 Type a value for the Magnification and click OK. The user guide page displays at the 
specified magnification.

Viewing an online user guide with bookmarks

Step 1 Click the Bookmarks tab on along the left side of the Acrobat Reader window. The 
bookmarks display as an interactive table of contents.

Step 2 Click the Bookmark for the user guide section you want to view. The Bookmark’s 
page and location display in the Acrobat window.

Jump to a specific page in an online guide

Step 1 Press [Ctrl+Shift+N] keys to display the Go To Page dialog.

Step 2 Type a value for the Page and click OK. The specified user guide page displays.

Figure 2. Display the Acrobat Navigation toolbar
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Printing part or all of an online user guide

Step 1 Choose the File > Print command or press [Ctrl+P] keys to access the Print 
dialog.

Step 2 Select the printer and specify the number of copies to print.

Step 3 Type the page numbers (starting and ending) in the From and To text fields.

Step 4 Click Print button.

Note To print an online user guide, you must have Adobe Acrobat Reader or the full Acrobat 
Exchange product installed on your computer.

Searching an online user guide

Step 1 Choose the Edit > Find command or press [Ctrl+F] keys to display the Search 
PDF pane.

Step 2 Type your search in the What word or phrase would you like to search for? area. It 
can be a word, words, or part of a word.

Step 3 Search only in the current PDF document (Figure: 3, ‘Acrobat search text”, on 
page 14). Select any of the applicable check boxes below the All PDF Documents in 
drop down-selection list:

• Whole words only—finds only occurrences of the complete word typed.
• Case-Sensitive—finds only occurrences of words in the exact combination of 

lower- and upper-case you typed in the search area.
• Search in Bookmarks—searches the text in the Bookmarks pane as well as the 

document text.
• Search in Comments—searches the comment annotations and the document 

text. Any Comment instances found have an icon beside the search word and a 
word or two of the context.

Step 4 Click Search button.

Step 5 When the search results display (Figure: 4, ‘Acrobat search results displayed”, on 
page 14), click the underlined search words (hyperlinked) to go to this page in the 
online user guide.

Step 6 If you want to do another search or refine your current search to yield a more specific 
result, click the New Search button.



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 14

Using this Document Using the Acrobat online guides

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Figure 3. Acrobat search text

Figure 4. Acrobat search results displayed
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Document revisions
Revisions and corrections to the Rock Physics Module for PowerLog documentation 
modules are recorded in the next table.

Technical support
Fugro-Jason provides detailed documentation to help you efficiently install, configure, 
and use your purchased software investments. Fugro-Jason documentation is 
designed to help you find descriptions of product functionality and step-by-step 
procedures to accomplish your exploration goals. For answers to your technical 
support questions or to suggest ways to improve this Fugro-Jason product, please 
contact us.

When you need assistance with your work in Rock Physic Module for PowerLog, 
contact these resources in the Fugro-Jason RPM Technical Support Group:

Phone +1 214 368 2191

Fax +1 214 368 5281

E-mail support.RPM@fugro-jason.com

Hours 8:00 AM - 6:00 PM (CST), Monday through Friday

Address PETCOM, Inc.
1600 North Collins, Suite 1700
Richardson, TX   75080

Internet www.fugro-jason.com

Table 2. Document revisions

Date Author Changes made

04/03/2006 Lance Smith Internal Beta release - Convert reference documents to 
FrameMaker and make Acrobat file

04/18/2006 Lance Smith Revised miscellaneous user interface elements. Streamlined 
terminology usage

05/01/2006 Lance Smith Revised document into three RPM for PowerLog Guides.
Added mix functions descriptions to function reference.

05/16/2006 Lance Smith Ensure rock physics function parameters match the RPM 
user interface.

06/08/2006 Lance Smith Added RPM concepts

06/12/2006 Lance Smith Added RPM user procedures

http://www.fugro-jason.com/powerbench/RPM.htm
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RPM CONCEPTS
Major sections include:
• What is the Rock Physics Module for PowerLog?
• Using workflows
• Introduction to workflows
• Simple workflow example
• Workflow building blocks
• Inputs for function calculations
• Calculations
• Help building your workflow
• RPM mixing functions
• Curve Fitting
• RPM related publications

What is the Rock Physics Module for PowerLog?
RPM for PowerLog works with PowerLog as an add-on module to integrate the log 
analysis of PowerLog with rock physics elastic modeling for seismic AVO analysis. 

Some of RPM for PowerLog’s foremost features are:
• Directly stores its rock physics elastic modeling results in PowerLog so you can 

professionally display your log plots, crossplots, and other data together in a 
management-ready presentation.

• Constructs a rock physics model consistent with your logs so you can create 
quality synthetic shear logs for AVO analysis and inversion.

• Uses sophisticated rock physics algorithms and simple averaging methods such 
as Voigt, Reuss, and Hashin-Shtrikman.

• Estimates fluid properties based on formulas developed by Batzle and Wang.

In addition to the simple averaging methods mentioned, RPM for PowerLog contains 
these general classes of rock physics algorithms (among others):
• Fast approximation of the Xu and White model
• Greenberg and Castagna relation
• Gassmann’s fluid substitution equation
• Gardner’s relations
• Modified Hashin-Shtrikman method (lower and upper bounds)

Seismic wave propagation in a fluid-filled porous rock depends on the rock matrix 
composition and structure, plus the pore fluid properties. These factors influence a 
correct velocity estimation. RPM for PowerLog enables you to create a theoretical rock 
model to derive the effective elastic rock properties from fluid, mineral, and rock 
structure parameters. You calibrate the derived model parameters by comparing the 
synthetic to the measured elastic sonic logs.
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Once you construct a rock model, you can perform fluid-substitution and inversion 
corrections. Your rock model can also enable you to predict elastic curves for lithology 
parameters that were not recorded in the wells.

Using workflows
The RPM for PowerLog module helps a user create rock models using repeatable 
workflow calculations, integrated with Petrophysical quality control procedures.

For many projects you can use petrophysics, rock physics, and empirical models to:
• Perform quality control of elastic logs
• Do quality control of petrophysical calculations
• Synthesize missing or poor log data
• Correlate elastic logs with borehole effects
• Perform fluid substitution
• Provide a framework to interpret seismic inversion results

For projects with more far-reaching objectives, building a rock model adds value 
beyond the simple empirical models derived from petrophysical quality procedures.

Building rock physics models with RPM workflows can help you:
• Handle more complex models (three phase media)
• Perform fluid substitution easily
• Expose errors
• Increase understanding of rocks
• Extrapolate results in a more straightforward manner

Note Documented RPM workflows are discussed in “Tutorial Workflows” on page 84. 
Example RPM for PowerLog workflow projects and additional Adobe Acrobat PDF 
documentation are in this directory: C:\Pwrlog32\RPM\Workflow Templates.

Introduction to workflows
RPM for PowerLog integrates rock physics calculations using a workflow (sometimes 
called a directed graph) developed on a screen area (workspace). Unlike a 
spreadsheet approach, the workflow directly reveals the calculation dependencies in 
the form of ancestors (nodes that affect this node’s inputs) and descendents (nodes 
affected by this node’s output).

The main user interface is a workflow that shows a directed graph, containing nodes 
(where calculation functions operate) and connections (directed lines) that 
determine the calculation dependencies. The workflow represents the functional 
dependencies, that is, which node calculations must be done before others.



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 18

RPM Concepts Simple workflow example

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

For each node, RPM provides you easy access to its large library of algorithms, along 
with smart menus to guide your input parameter selection.

Workflows are organized into projects and each project has its own rock and fluid 
properties, constants, defaults for mixing, and its own workflow graphic. Because 
project files can be easily modified, constants and properties can be copied and 
customized from one RPM project to another.

Simple workflow example
Nodes can be linked together in workflows by using the output value or output curve of 
one node as an input for another node.

In this example you can calculate a new bulk modulus for a sandstone when the 
original fluid (100% gas) is replaced by 100% water.

Consider this three node workflow that looks like Figure: 6, ‘Simple three node 
workflow”, on page 19, one node for each rock physics function:

• GasK—calculates the original fluid bulk modulus.
• BrineK—calculates the bulk modulus for the water for specific physical conditions 

in the reservoir.
• Gassmann—requires a bulk modulus for a replacement fluid (K_F_new) and an 

original fluid (K_F_old) for two of it’s input parameters.

Figure 5. Partial RPM workflow example
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The input for GasK is P=2900 psi, T=176 degrees F, and spec_grav=0.6. The result 
is a value for the node (node n1) of 4.0502e7 N/m2.

Similarly, the input for BrineK is P=2900 psi, T=176 degrees F, and salin=35000 
ppm, but yields the value for the node n0 of 2.64747e9 N/m2.

Once n0 and n1 are calculated, the Gassmann function node n2 inputs become:
Kbulk = 12.29e9 N/m2

Kmineral = 36.0e9 N/m2

Porosity = 0.20
K_F_new = node n0 (BrineK - bulk modulus of brine node)
K_F_old = node n1 (GasK - bulk modulus of gas node)

The connecting arrows in Figure: 6, ‘Simple three node workflow” display when the 
n2 node is saved, because node n2 is an output descendent of nodes n0 and n1. 

When the Gassmann function node calculates, the result is a node n2 with the 
constant value 1.7148e10 N/m2, which is the sandstone bulk modulus with the 
replacement fluid (water).

This workflow can be modified to use curves (also curve alias names) instead of 
UserValues for pressure and temperature in BrineK and GasK, thus actual 
measured pressure and temperature variations in the well are used for the 
computation. Curves for pressure and temperature in PowerLog can be used. The 
resulting bulk density curve will vary in value, but still be approximately 1.7e10 N/m2.

Workflow building blocks
A workflow is a collection of calculations designed to operate in a specific sequence 
and that forms an “integrated” solution to a rock physics or reservoir investigation. 
RPM for PowerLog acts as a calculation engine to deliver results to the user and 
create log curves for storage in the PowerLog project files. Once you store your results 
in PowerLog, you can take advantage of PowerLog’s curve presentation, crossplot, 
and other graphical tools to display and plot results.

So what are the building blocks of an RPM workflow? For an existing workflow on the 
RPM for PowerLog main window, you first see rectangles (nodes), directed lines 
between rectangles (connections), and organized collections (groups) of nodes.

Figure 6. Simple three node workflow
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Nodes
A node is a location where a calculation (function) or input to a calculation is defined. 
Most RPM for PowerLog nodes consist of:

• one or more inputs (values or curves)
• a basic mathematics or rock physics function
• an output (used in other workflow nodes or stored as a PowerLog curve)

For a complete list of all basic and rock physics functions, see the RPM for PowerLog 
Function Reference Guide.

Nodes all into three classifications, based on function:
• Input nodes—Use PowerLog curve names and constants, along with the 

GetCurve1 function for these nodes.
• Connection nodes—These nodes create outputs that are used as input 

parameters for other nodes. You should always use the node name for the input 
parameter, even if the output curve has a different name. This creates the visual 
connections between workflow nodes.

• Output nodes—These nodes produce curves that you want to store in the 
PowerLog project well. Specify a curve name for the result you want stored.

Caution! PowerLog requires curve names with a maximum of eight characters and no blank 
spaces.

Using the Edit > Preferences command, you can set the default color and border 
width of the nodes. You can also right-click (MB3) on any node and assign it a color.

Node inputs
The inputs to a node can be one of these items:
• Nodes—the calculation output from another node
• Curve—curve samples from a PowerLog curve
• Curve Alias—an alias name that substitutes for several well log curve names of a 

similar type. PowerLog uses the alias to refer to multiple curve names across 
multiple wells within a single PowerLog project. (See PowerLog documentation for 
the procedure to setup curve alias names.)

• RockProperty—a rock, mineral, or fluid property stored in your RPM project file.
• Constant—a named value defined for calculations or a value a user wants to refer 

to by name in the workflow
• UserValue—a user-defined number typed for this node

Note The RPM for PowerLog Function Reference Guide describes what inputs are 
appropriate for each function.

Functions
An RPM function is an operation that uses mathematics, conditional logic, and rock 
physics empirical results to calculate a single value or an output curve.

The RPM for PowerLog classifies its functions into these groups:
• Arithmetic

1. The GetCurve function permits you to show these PowerLog curves as Input nodes in your workflow. No computa-
tions happen with the curve.
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• Discrimination and Conditional Logic
• Empirical Velocity
• Fluid/Rock Physics for Brine, Gas, and Oil
• Gardner
• Gassmann’s Fluid Substitution
• Greenberg Castagna
• Media Bounds Functions (Two-Phase Media)
• Media Bounds Functions (Three-Phase Media)
• Miscellaneous supporting
• Random Numbers
• Simple modulus-related
• Statistical
• Trigonometric
• Velocities for Bounds
• Velocity Synthesis

For additional details, see the RPM for PowerLog — Function Reference Guide 

Node outputs
The output of a calculation node has these characteristics:
• Name
• Curve or value?
• Type
• Units

Name
The name of the function output can be either:
• A curve name that is written to the PowerLog files. This is often used to store 

significant intermediate or final results from an output node.
• A node number (n0, n20, and so forth). Used to provide input to another node 

calculation.

Curve or value?
The physical node output is either:
• A curve, having a depth range and a defined number of samples. Some of the 

samples can be undefined (UNDEF).
• A single value.

What determines if a node generates a curve (samples) or a single value?

If the function contains at least one input curve (curve alias name), a curve is the 
function output.To state it conversely, if all inputs are single values, the function output 
is a value.

Exceptions to the statements apply to functions that specifically create only a single 
value for output. See the RPM for PowerLog Function Reference Guide for 
functions marked: Output Single Value Only.
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Type
The output from any RPM node can be assigned an output type. RPM function input 
parameters take a specific type, such as bulk modulus or shear velocity. You can 
define your output as a specific type. Later, when you need that node as an input to 
another function (that requires this type), the selection list displays only nodes with the 
appropriate type. See Figure: 9, ‘Example node list of acceptable inputs”, on 
page 25.

RPM for PowerLog currently defines the types listed in Table 3, “Node Output 
types,” on page 22.

Units
Each node output can specify the output units of the value or curve it calculates. If you 
specify the output type (for example, velocity), then the units are restricted to the 
velocity PowerLog English units (for this example, ft/sec).

Hint Some functions inherently are setup to know the required output type and units; for 
example GardnerStoRho generates a density type in units of g/cc.

Connections
Whenever you supply a node input parameter with another node in the workflow, you 
create a workflow connection (symbolized by a directed line). These connections 
define the calculation order or sequence, Using the Edit > Preferences command, 
you can set the default color and the line width of the connections. Significant 
connections can be assigned a unique color to highlight significance. See Figure: 5, 
‘Partial RPM workflow example”, on page 18. 

Table 3. Node Output types 

Node Output types Node Output types Node Output types

any freqdepth p_sonic

none freqtime p_velocity

algorithm gammaray shear_modulus

api gardner s_sonic

aspect_ratio gas_oil_ratio s_velocity

azimuth greencast spec_grav

bulk_modulus inv_compressibility thomsen_delta

concentration krief_gurevich_goldberg thomsen_epsilon

conditional lithfrac thomsen_gamma

density modulus time

depth pressure version

dip porosity vp/vs
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Groups
A collection of nodes that work together to accomplish a significant workflow goal. This 
collection can be assigned a name (group name) and nodes can be associated with 
this group. For example, you may organize the nodes that estimate Vs (shear velocity) 
or find the difference between the measured and computed Vp. Group names can be 
edited. Using the Edit > Preferences command, you can set the default color and the 
border width of the groups. You can also right-click (MB3) on any group and assign it a 
color. See Figure: 5, ‘Partial RPM workflow example”, on page 18.

Other node relationships
RPM for PowerLog defines several collections of nodes that it uses to perform calcula-
tions or to highlight node relationships:
• Ancestors—set of nodes whose outputs affect the input parameters of a node.
• Descendents—collection of nodes affected by the output of a single node.
• Path—arbitrary set of RPM nodes defined by a selected beginning node, a 

selected final node, and all connection nodes between the two selections.

In Figure: 7, ‘Example of ancestors, descendents, and a path”, on page 23, we 
can see all these relationships:
• Ancestors—n23, n25, and n26 nodes affect n73 clay bulk modulus calculation.
• Descendents—Node n25 affects descendent nodes n72 and n73.
• Path—selecting n26 as a beginning node and n36 as an ending node defines the 

calculation n26 - n73 - n36 path.

Figure 7. Example of ancestors, descendents, and a path
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Inputs for function calculations
When you add or edit a node, the Function Selection dialog displays the current 
function name and its set of input parameters. Right-clicking on the input parameter in 
the Value/Name column displays the appropriate inputs for this parameter.

For some input parameters, a curve name, curve alias name, or the output from 
another node is the appropriate type. Other parameters need a single value such as a 
rock, mineral, gas, or fluid property, a defined named constant, or a User Value.

Node
Once a node is defined, you can use the node Output as a parameter in another node. 
By right-clicking (MB3) on the input parameter in the Value/Name column and 
selecting Node, RPM displays a list of all nodes that can act as an input for this 
parameter. RPM for PowerLog examines the Output type of each workflow node and 
presents only suitable nodes. For example, if the rock physics function required a Vp 
as its input parameter, only nodes having a acoustic p_velocity output or the type 
any would display in the node list. A sample node list looks like Figure: 8, ‘Input 
parameter selection types”, on page 24.

Figure 8. Input parameter selection types
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Curve
Often, during workflow construction, you want to use PowerLog well curves as inputs 
to your calculations. Right-clicking (MB3) on the Value/Name column parameter and 
selecting Curve, RPM displays the curve names found in the chosen PowerLog 
project well. A curve list would look similar to Figure: 10, ‘Example curve list”.

Figure 9. Example node list of acceptable inputs

Figure 10. Example curve list
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Curve alias name
In the RPM software, using a curve name which starts with the ampersand character 
(&), designates a curve alias rather than an actual well curve. When you use a curve 
alias in a function input parameter, RPM searches the PowerLog Curve Alias Table 
for the first available curve name in that row. Curve aliases can be used for any RPM 
function input parameter as a substitute for an actual curve name.

The Curve Alias Table is accessed through Tools > Curve Alias Table command in 
PowerLog. Figure: 11, ‘PowerLog Curve Alias Table” shows an example of how 
curve aliases are defined in the PowerLog dialog. The yellow column is the alias 
name. You can associate a maximum of 49 curve names in the adjacent columns. The 
alias resolves the actual curve name by searching from left to right—the first curve 
available in the well is used.

Example If we use the alias &GR as an RPM function input, RPM for PowerLog first tries to use 
GRP, then GRCP, but if they are absent in the well, it ends up using NGRC, which is the 
third choice. In situations where your RPM project is used with multiple wells in a 
project reservoir, you want to use PowerLog curve alias names as inputs nodes to 
your workflow. 

Right-clicking (MB3) on the Value/Name column parameter and selecting 
CurveAlias, RPM displays the curve alias names found in the PowerLog project file 
An example curve alias list would look similar to the Figure: 10, ‘Example curve list”, 
on page 25, only all the alias names begin with an ampersand (&).

Rock, mineral, gas, and fluid properties
Every RPM for PowerLog project comes with a pre-defined set of rock, mineral, gas, 
and fluid properties provided. You can add, change, or delete the value of each 
property using the Data > Rock Fluid Properties command. Additional parameters 
can be added for each rock, mineral, gas, and fluid using this same dialog, plus you 
can define other rocks, minerals, gases, and fluids. When you add a new rock, 
mineral, gas, or fluid, you choose the appropriate type in a drop-down selection list.

Figure 11. PowerLog Curve Alias Table
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Note If you need to import the rock, mineral, and fluid properties used from another project, 
use the procedure found in the Installation section of the RPM for PowerLog — 
Getting Started Guide.

Note You cannot delete an RPM-defined rock, fluid, gas, or mineral. These RPM objects are 
protected and an information message displays if you attempt to delete one.

Rock and mineral properties default differently!
RPM for PowerLog handles minerals and rocks, differently, to the extent of using rock 
property default values differently from mineral property default values. How the 
defaulting mechanism described in the “RPM mixing functions” on page 35, differs 
for minerals and rocks, requires additional explanation.

RPM makes a distinction between minerals (such as quartz and calcite) and rocks 
(sandstone and limestone). Properties unsuitable for minerals (such as original 
porosity OriginalPorosity) have values that are initially set as undefined 
(UNDEF). Properties unsuitable for rocks (such as the density, Rho, which would imply 
dependencies on other Properties table parameters such as porosity) have values 
which are also initially undefined. From RPM mixing functions, only property values 
associated with minerals (not rocks) can be used as an automatic default in an RPM 
function parameter.

Example If the bulk modulus of a mineral phase is required as input parameter K_1 in 
MixVelocityVp function and the user does not specify a value, the quantity found in 
the Rock and Fluid Properties for mineral1.K is used; as indicated by the tool tip 
displayed when the cursor hovers over the input field. If mineral1 is quartz, then the 
default is quartz.K.

Figure 12. Rock, Mineral, and Fluid properties example
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Caution! This automatic default value mechanism does not apply to rocks. There is no specifi-
cation of a default rock or rocks, and rock values are not automatically used from the 
Rock and Fluid Properties if the user leaves the input parameter blank for a rock. 

Example In MixVelocityVp, if the Orig_Poro1 parameter is blank, it cannot default to Origi-
nalPorosity for a rock, such as sandstone, because there is no default rock, and 
cannot default to OriginalPorosity for the default mineral. The user may change 
the UNDEF values for a rock or mineral in the Rock and Fluid Properties to specific 
values, but such property values associated with a rock or mineral are still not used as 
a default if the user leaves an input field associated with a rock blank (as opposed to a 
mineral) in a function. Input fields associated with rocks that are left blank default to 
undefined (UNDEF) values. The documentation and the tool tips indicate which input 
parameters default to undefined values for this reason.

The limitations on automatic defaulting described, do not inhibit your ability to explicitly 
select a rock or mineral value from the Rock and Fluid Properties, rather than 
entering a numerical value, as a rock input for a function.

Named constant 
Throughout your workflows, you can add your own named constants and refer to these 
values in the calculations by the assigned name. Right-clicking (MB3) on an input 
parameter in the Value/Name column of the Function Selection dialog, and selecting 
Constant, you can select the desired constant. Use the Data > Constants command 
to add, change, or delete a named constant from your RPM project.

Caution! You cannot delete an RPM-defined named constant. These RPM constants are pro-
tected and an information message displays if you attempt to delete one.

Figure 13. User named constants list
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User values
By right-clicking (MB3) on an input parameter in the Value/Name column of the 
Function Selection dialog, and selecting UserValue, you can directly type a value 
for a function input parameter.

Calculations
A large amount of information can go into a single node, as you observed in the 
previous section. So how do nodes become a workflow? We stated earlier, that nodes 
often fall into three classifications, based on their function:

• Input nodes—Use PowerLog curve names and constants, along with the 
GetCurve function for these nodes.

• Connection nodes—These nodes create outputs that are used as input 
parameters for other nodes. You should always use the node name for the input 
parameter, even if the curve has a different name. This creates the visual 
connections between workflow nodes.

• Output nodes—These nodes produce results that you want to store in the 
PowerLog project well. Specify a curve name for the result you want stored.

Figure: 14, ‘Example of different node types”, on page 30 shows all three node 
types.

Organizing input nodes
Several nodes within your workflow are classified as input nodes, that is, nodes that 
use PowerLog curve names (or curve aliases), named constants, or values to define 
an output that can be connected to nodes throughout the workflow.

Input nodes are either a:
• User value
• Named constant from the Constants dialog
• Property from the Rock Fluid Properties dialog
• Single curve read from the PowerLog well (use the GetCurve function to specify 

the curve as a node input)
• Simple computation using a PowerLog curve and a constant (such as converting a 

sonic log to a measured velocity representation).

In this example, a group contains the measured velocities and density nodes. The red 
nodes designate PowerLog curves (DT and RHOC, for example).
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Hint Its an excellent idea to assign one color (for example, red) for input PowerLog curves 
and another color (green) for the input constants. When you have completed a work-
flow and it works for a single well, you often use the RPM project with another Power-
Log well or PowerLog project. One of your first tasks, when working with another well 
is to check to see that all required input curves exist for the new well. Next, you might 
review your defined constants to verify that these values are also appropriate for this 
project.

Note Input nodes are not required for your workflows. However, using this organizational 
method helps you move your RPM projects from one PowerLog project well to 
another. Additionally, the data flow is more clearly expressed using the input nodes.

Connecting nodes
In RPM for PowerLog, when you define the output of a node as the input to another 
node, the software shows this relationship with an arrow (for example, see nodes n67 
and n68 in Figure: 14, ‘Example of different node types”, on page 30). A 
connection between the example nodes is established when you used n67 as an input 
parameter to the calculation in n68 in Figure: 15, ‘Creating a connection between 
nodes”.

Figure 14. Example of different node types
Co

Output node

Connection node

Input node



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 31

RPM Concepts Calculations

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Creating an output
An output node is the final node of a branch in the workflow. In Figure: 15, ‘Creating a 
connection between nodes”, on page 31, the output of node n68 provides the 
measured acoustic velocity. This log is stored in PowerLog with the well curve name 
pvelmeas and compared against the modelled acoustic velocity. A created node 
output can be used by any number of other workflow nodes.

Figure 15. Creating a connection between nodes
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Calculation types
During the development of your rock physics model you can test all or portions of your 
workflow:
• Node
• Path
• Group
• Workflow (all nodes)

At any selected node in the workflow, you can right-click (MB3) and choose the 
appropriate option under the Calculate command. Results always display in the 
Output Log and the status bar (see “Output Log and status bar” on page 35).

Node
Often you want to test only the currently selected node in your workflow. Right-click 
and use the Calculate > Calculate Node shortcut command.

Path
When you need to see how one calculation affects descendent nodes (later 
calculations), you can select a path (use the View > Select Path command to select 
the start and end path nodes). Right-click and use the Calculate > Calculate Path 
shortcut command to generate results.

Group
This RPM calculation option takes each node in a named group and performs the 
function calculations. Usually one of the group nodes produces an intermediate or final 
workflow result. Select a group, right-click, and use the Calculate > Calculate Group 
shortcut command to focus on this section of the workflow.

Workflow (all nodes)
This RPM calculation option goes through all the workflow nodes sequentially 
performing each defined calculation. You can use the menu Calculate > 
Calculate Workflow command, right-click in any open workspace area (no node, 
group, or connection) and use the Calculate > Calculate Workflow shortcut 
command, or press [F8].

Results quality control
Whenever you run a calculation on part of a workflow (node, path, group) or the entire 
workflow, calculation results and error messages are stored. You can see errors and 
results for each node using the Output Log dialog and the status bar. The results a 
from each node are displayed in the status bar when you position your cursor over the 
node. If the message says the node is undefined, the calculation encountered an error.

Help building your workflow
Throughout the RPM for PowerLog user interface, you have access to all the 
assistance and documentation needed to successfully build a robust rock model with 
your workflow. While the entire RPM user interface helps you construct the workflow, 
these items provide you more guidance as you add additional complexity and test the 
workflow.
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To effectively build rock physics models, use:
• Documentation
• Function Help buttons
• Shortcut menus
• Right-click selection lists
• Node tool tips
• Output Log and status bar

Documentation
The RPM for PowerLog — User Guide (currently reading) covers (1) key RPM 
concepts, (2) user procedures needed to build and test your workflows, (3) the RPM 
user interface that helps you implement the workflow procedures, and (4) descriptions 
of tutorial workflows you can use as examples to develop your own models.

The RPM for PowerLog — Getting Started Guide helps you install the RPM for 
PowerLog software and access your first RPM project. This document contains some 
common questions asked by users and some best practices (recommendations) for 
creating robust workflows. Additionally, if you want Fugro-Jason to add some key 
functionality, before you submit an enhancement request, please look over the list of 
functionality we are adding during 2006.

The RPM for PowerLog — Function Reference Guide provides a comprehensive 
reference for all the basic and rock physics functions available in the RPM for 
PowerLog software. It contains a complete reference of all rock physics functions 
(including examples, developer commentary, and literature citations).

Function Help buttons
When you are editing a node (Function Selection dialog) you can click Help to 
display specific information about the currently selected function. Clicking Help 
displays the function reference material in an Internet browser window. 

Once the function reference displays, you can:
• Minimize, resize, or maximize the browser window 
• Adjust the text size to your preference
• Click on related links to see reference material about other RPM functions
• Jump to the Help table of contents or index to explore information about all the 

RPM functions

Shortcut menus
In the RPM for PowerLog user interface, there are four context-sensitive shortcut 
menus that display whenever you select the object and right-click (MB3) the mouse:
• Node shortcut menu—select any node to perform these functions.
• Connection shortcut menu—select any connection to customize its color.
• Group shortcut menu—select any group to perform these functions.
• Workflow shortcut menu—right-click anywhere in the workspace that does not 

have a node, group, or connection to display this shortcut menu.
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Right-click selection lists
In some of the RPM dialogs, you must select an input type, an input curve, an 
algorithm, or a node number. You can right-click (MB3) on some Value/Name cells 
and a selection list displays appropriate values.

Other examples shown in the RPM Concepts section include:
• Figure: 8, ‘Input parameter selection types”, on page 24.
• Figure: 9, ‘Example node list of acceptable inputs”, on page 25.
• Figure: 10, ‘Example curve list”, on page 25.

Node tool tips
At any time during the workflow construction, you can place the mouse cursor over a 
node and a brief function description displays in the tool tip (small pop-up text).

Figure 16. Workflow shortcut menu
if

Figure 17. Example of a right-click selection list
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Figure: 18, ‘Tool tip and status bar example”, on page 35 illustrates a function tool 
tip and the status bar showing the results of the node calculation.

Output Log and status bar
After you have performed calculations for a portion or the entire workflow, you can 
place the cursor over each node involved and see a result or an error message in the 
status bar. The Output Log lists all the messages created during the calculation for a 
node, a path, a group, or an entire workflow.

RPM mixing functions
Currently, you can use the Set Mix Defaults dialog and select these minerals for end 
members 1 and 2:
• Anhydrite
• Calcite
• Clay
• Dolomite
• Feldspar
• Quartz

Figure 18. Tool tip and status bar example

Figure 19. Output Log example
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• Pyrite
• Salt
• Siderite

You can select from these pore fluids:
• Brine
• Deadoil
• Gas
• Liveoil
• Water

Mix algorithms
Currently, RPM provides these mixing algorithms:
• Backus
• Cemented Spheres Scheme 1 2

• Cemented Spheres Scheme 2 2

• Critical porosity 2

• Dispersive and layered clay 2

• Dispersive Clay 2

• Grain supported 2
• Hashin-Shtrikman Lower Bound
• Hashin-Shtrikman Upper Bound
• Krief-Gurevich-Goldberg
• Layered clay 2

Figure 20. Set Mix Defaults dialog

2. These algorithms are valid only for two member mixing.
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• Matrix supported 2
• Reuss
• Self consistent
• Voigt 
• Voigt-Reuss-Hill
• Woods
• Wyllie
• Xu-White
• Xu-White Approximation (fast)

Notes for mixing algorithms
All of these algorithms, except the Critical Porosity and Cemented Spheres Schemes, 
start from the Kuster-Toksöz theory [20] to account for the effect of mixing in pores with 
a given height-width (α) pore aspect ratio. The algorithms assume material isotropy, 
that is directional uniformity in the material, such that physical properties do not vary in 
different directions. In all cases, Gassmann’s method [24] is used to fill empty pores 
with fluid, assuming low acoustic frequencies. When more than two rock members are 
present, the methods can be applied iteratively to any desired level of rock complexity.

Note All algorithms need a porosity log and a lithology fraction log.

Note Values for original and critical porosity should range between 0 and 0.9.

Backus
This algorithm is a combination of harmonic and simple averages.

Caution! Not suitable for low clay fractions (lower than 10%).

Cemented Spheres
[Scheme 1 or 2] This algorithm models sandstones consisting of spheres (quartz) with 
cement (clay) at the grain contacts. The cement is deposited only at the grain contacts 
(scheme #1) or evenly distributed around the grains (scheme #2). Extending the 
original model to larger clay fractions, excess clay is modeled as an additional layer 
and added to the sand using Backus averaging. The porosity is attributed to the first 
component (usually sand) only. In other words, “wet clay” is assumed as 
cement. 3 [13]

Critical porosity
This algorithm is based on the observation that rock properties exhibit transitions when 
the porosity increases beyond a certain critical porosity, that is, when the rock goes 
from consolidated to unconsolidated. It implements a Voigt-based critical porosity 
model, using a non-critical averaging to incorporate the sand and shale mixing. It is an 
approximation to the Xu-White model, but significantly faster computationally. This 
method makes for an excellent quick-look analysis. 4 [29] [24]

Dispersive and layered clay
This method is based upon the Dispersive Clay model described, except that the 
excess clay is modeled as a solid layer and added to the sand using Backus 

3. These algorithms require rock parameter values be supplied for original porosity.
4. This algorithm requires rock parameter values for critical porosity for the sandy rock and the shaley rock.
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averaging. All porosity is attributed to the sand component only, that is, the clay is 
assumed to be “wet clay.” 3

Dispersive Clay
This algorithm assumes the primary medium (sand) had the original porosity partially 
filled with the second medium (clay). The pore space insertion is also done 
iteratively. 3 [32]

Caution! Suitable for low clay fractions (<10%) and porosities lower than the original porosity.

Grain supported
In this model, spherical clay inclusions are inserted into the quartz mineral. Then the 
pores are introduced in the mixture. [32]

Caution! Not suitable for high clay fractions (greater than 80%).

Layered clay
This algorithm calculates the elastic properties of a medium consisting of layers of the 
two members. (The default minerals are sand and shale.) The fluid is included in the 
layers with the approximate Xu-White method. For the estimation of the effective 
properties of the layered medium, the Backus filtering is used.

Matrix supported
For this model, spherical quartz inclusions are introduced into the clay. Then pores are 
introduced into the mixture. [32]

Caution! Not suitable for low clay fractions (lower than 10%).

Self consistent
Similar to the Xu and White algorithm, this method uses Berryman’s self-consistent 
technique, rather than the Differential Effective Medium (DEM) method. [32] [4]

Note This method is better than Xu and White where the porosity exceeds 30%.

Wyllie
This algorithm calculates the mix properties assuming a simple volumetric average of 
velocities.

Xu-White
This algorithm mixes the two rock members volumetrically, while iteratively inserting 
pore space. The pore space is inserted iteratively using the Differential Effective 
Medium method, based on the relations by Kuster and Toksöz [20].

No assumptions are made about the structure of the mixture of the two rock members: 
a generic averaging is used (the time-average model). Consequently, it is not a priori 
limited to a particular member fraction range. However, that also means that the 
results may be less accurate for certain very specific mixture structures.[39]

Caution! The Xu and White approximation is less suited for very high porosities (30% or higher).

Xu-White Approximation
A non-iterative approximation to the original Xu-White model, using the approach of 
Keys and Xu. This model is the default algorithm and selected when the Figure: 20, 
‘Set Mix Defaults dialog”, on page 36 first displays. [18]
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Curve Fitting
To be added in July.
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RPM functionality

Command methods
You can select commands in the RPM for PowerLog software by using:
• Menus (below title bar)
• Right-click (MB3) shortcut menus
• Tool bar icons
• Keyboard shortcut keys

Command examples
RPM for PowerLog can perform all the calculations for an entire workflow. You can 
start this command using the four different techniques:
• Menu—Select the Calculate > Calculate Workflow command.
• Shortcut menu—Select a node, right-click (MB3), and select the Calculate > 

Calculate Workflow command.

• Tool bar icon—click the  icon.
• Keyboard shortcut—press the [F8] key.

Procedure convention
Throughout the next three sections, only the Menu method is described for each step-
by-step user procedure. Consult the “RPM User Interface” on page 119 the other 
methods (shortcut menus, toolbar icons, and keyboard shortcuts) you can use to 
invoke each RPM command.

To see a complete reference of all RPM user interface commands, go to the RPM 
PowerLog at a Glance.

Managing RPM projects
RPM for PowerLog is a calculation engine for implementing rock physics model 
computations. To display your input and resulting well curves for the best possible 
presentation, you use the PowerLog application. PowerLog contains many graphic 
views [log plots—with formation tops, histograms, cross plots, and cross-section 
collages] that automatically update (version 2.7 or greater) whenever your curves are 
updated with RPM and PowerLog calculations.
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Relationship between PowerLog and RPM projects
PowerLog organizes a collection of wells into a single exploration project that you 
would use for petrophysical analysis or perform rock physics modeling with the RPM 
for PowerLog add-on software. Each well is a set of recorded well curves and 
supporting identification information.

RPM projects can be created whenever a user wants to build a workflow. While an 
RPM workflow is created with an initial PowerLog project and well, the RPM project is 
not constrained to any specific PowerLog well. A workflow only needs the required 
input PowerLog curves to operate.

Starting PowerLog
Before you can start the RPM for PowerLog add-on module for the first time, you must:
• Start the PowerLog application
• Select a PowerLog project
• Open at least one PowerLog well

To start PowerLog
1 Start the PowerLog application using the Windows Start menu (Start > PowerLog 

> PowerLog command) or the PowerLog desktop icon. .

Selecting a PowerLog project and a well
When PowerLog starts, if it does not have a default project and well assigned, select 
the desired PowerLog project and well.

To select a PowerLog project and well
1 Select a PowerLog project using the PowerLog File > Project > Open command.

2 Display each well you need by repeatedly using the PowerLog File > Well > Open 
command. The well name, depth range, and sample interval display in a list similar 
to Figure: 21, ‘PowerLog window project title and <project name> Well List”.

3 Select a single well from the project well list. You can now start RPM for PowerLog.

Figure 21. PowerLog window project title and <project name> Well List
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Starting RPM
Once you have (1) started PowerLog, (2) chosen a PowerLog project, and (3) selected 
a well within the PowerLog project, you can start the RPM for PowerLog software.

To start RPM for PowerLog
1 Using the PowerLog menus, select the Interp > Rock Physics Module command.

or press the [Alt + N + R] key combination.

Note If a PowerLog project and well are not selected and you start the RPM for PowerLog 
application, a warning dialog displays saying, “No well selected.”

Adding a new RPM project
For situations when you need to start a workflow from the beginning, do this.

To add a new RPM project
1 Select the File > New Project command. A blank workspace displays.

Note If you made changes to your current RPM project before selecting the New Project 
command, a warning message displays. You can discard the changes (click Yes) or 
save the changes (click No and use the Save Project command).

Figure 22. Starting RPM for PowerLog

Figure 23. New RPM project warning message
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Using an existing RPM project
To start your work with an existing RPM project file, use this procedure.

To open an RPM project
1 Select the File > Open Project command.

2 When the Choose a file window displays, use the Look in drop-down selection list 
and the parent directory icon to move to your file folder containing the RPM 
projects. Use the Look in selection list to navigate within your local PC or mapped 
network drives containing file folders.

3 Select the RPM project file name (*.proj file extension) in the desired folder. It 
displays in the File name text box.

4 Click Open to begin using this RPM project.

Saving your RPM project
As you develop your workflow, you want to save each major addition to your rock 
physics model.

To save your current RPM project
1 Select the File > Save Project command.

2 If your RPM project has not been saved, the Save Project As window displays 
and you follow the “Backup your RPM project” on page 46 procedure, beginning 
at Step 2.

Figure 24. Choose a file window

Tools to locate
RPM project folder
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Otherwise, the message Project Saved displays in the status bar after your RPM 
project is saved. For more information about actual RPM project files, refer to the RPM 
for PowerLog — Getting Started Guide.

Storing your RPM project workflows
RPM for PowerLog always remembers the last file directory you used to store an RPM 
for PowerLog project. Additionally, the software keeps a list of where you stored your 
last five RPM projects. 

While RPM provides no constraints on where to store your workflow projects, you may 
want to consider:
• General Workflows—store these RPM projects in a common directory. Treat 

these RPM workflows similar to word-processing templates, starting points for 
developing other custom models.

• Project Workflows—store these RPM projects in the same file as your PowerLog 
wells, since these workflows may require specific input curves to perform the 
calculations successfully.

Backup your RPM project
Sometimes you need to save a copy of your workflow as a backup copy or to use this 
workflow with another well and make slight modifications.

To save the current RPM project under another name
1 Select the File > Save Project As command.

2 When the Save Project As dialog displays, you can navigate to another folder or 
create a new folder using the Save in drop-down selection list and the parent 
directory icon.
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3 In the File name text box, type the project name under which you want to save 
your information.

4 Click OK. Upon completion, the message Project Saved displays in the status 
bar.

Caution! When you use the Save Project As command, RPM for PowerLog continues working 
with this RPM project name as its current project.

Exiting RPM for PowerLog
To stop the RPM for PowerLog software
1 Select the File > Exit command. If all changes to the current RPM workflow are not 

saved, a Project Save Confirmation dialog displays.

2 Click Yes to save your changes. Click No to discard all changes made since you 
saved this RPM project with the Save Project or Save Project as commands.

Planning a workflow
Prior to developing your workflow, you may want to perform some preliminary steps to 
ensure that you have all the required rock model components. You can always perform 
any of these steps while building the workflow; however, focusing on these issues 
early in the workflow development can make your workflows easier to use.

Figure 25. Save Project As dialog

RPM project folder
Tools to select
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Some issues to consider prior to constructing the workflow:
• Determining workflow input curves
• Creating named constants
• Preparing Mix defaults
• Organizing Rock, Mineral, Fluid, and Gas Properties
• Setting up input curve and constant nodes

Determining workflow input curves

Use PowerLog to display key input curves
PowerLog’s presentation modules can help you create logplots and crossplots for one 
or more of your wells used with your RPM workflow. Use the logplots to quickly identify 
if any curves still need borehole or environmental corrections. Also, use the logplots to 
understand if substantial sections of your curves have undefined (UNDEF) values.

For additional information about using PowerLog’s presentation modules
1 In the PowerLog application, press [F1] to display the PowerLog help table of 

contents.

2 Double-click the Presentation book icon to reveal more help topics.

3 Read the Presentation Overview topic.

4 Double-click the Logplots book icon and scan these topics:

– Logplot Overview
– Format Dialog Box
– Default Curve Attributes

5 Double-click the Crossplots book icon and examine these topics:

– Overview
– Format
– Discriminators
– Grid and Label Options
– Z-Axis Colors
– Density Crossplots

Displaying curves list
Once you add or begin using an RPM project, you can display all the curve names 
found in the currently selected PowerLog project well.

To display the RPM list of well curve names
1 Select the Data > Curve list command.

2 Once the Curve List window displays, note the curve names you need as inputs to 
your workflow.

3 Click OK. The Curve List window closes.
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Displaying alias curve names
For workflows that you want to use across several wells, you may need to create one 
or more curve alias names to access all curve names needed for a specific workflow.

Example The gamma ray curve needed for workflow calculations to separate sands and shales 
may have several different names in the wells you want your workflow to access. 
Figure: 27, ‘PowerLog Curve Alias Table”, on page 50 shows an example of how 
gamma ray curve aliases could be defined in PowerLog. Example curve names in sev-
eral wells could be GRP, GRCP, NGRC, NGR, and ECGR To access each of these curves 
in the different wells, you need an alias name for your input node.

To assign an alias name in PowerLog to several curve names
1 Display the Curve Alias Table by selecting the Tools > Curve Alias Table Power-

Log command.

2 In the first yellow column, type the alias name that you want to use in PowerLog 
(plots) and in the RPM workflows (calculations).

3 Type one or more curve names in the adjacent columns of the same row you typed 
the curve alias name. You can associate a maximum of 49 curve names.

4 Click OK.

The alias resolves the actual curve name by searching from left to right—the first curve 
available in the well is used. 

Figure 26. Curve List window (example well)
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Once you have the alias curve names defined in PowerLog, you can display the alias 
curve names for your RPM project.

To display an RPM project curve alias list
1 Select the Data > Curve Alias List command. The Curve Alias List window dis-

plays

2 Click OK.

Figure 27. PowerLog Curve Alias Table

Figure 28. Curve Alias List example
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Creating named constants
Throughout your RPM for PowerLog workflow, you can use constant values as inputs 
to node functions. Most node function input parameters allow you to use a named 
Constant input or just type a UserValue (for example, 26.5 g/cc). (See “Node 
inputs” on page 20.) 

The reasons for using a named constant, include:
• Coefficients for unique mixing functions
• Documenting a constant value in the workflow
• Using the constant in multiple nodes and not retyping the same value

Adding named constants
Whenever you need to define a named constant, use this procedure. Once the 
constant is defined, you can insert it into any node input parameter that accepts a 
Constant.

To add user-defined named constants
1 Select the Data > Constants command.

2 When the Constant dialog displays, click Add.

3 The New Constants dialog displays. Type entries for these fields and click OK:

– Constant Name (Names cannot contain spaces) 5
– Value
– Units

4 Repeat steps two and three to define each named constant.

5 Click Save to retain the new constants. Click Cancel to delete all changes.

5. If you insert a space in a constant name, RPM for PowerLog replaces the space with an underscore character.

Figure 29. New Constants dialog
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Changing named constants
At any time you can modify the values of named constants.

To change named constants
1 Select the Data > Constants command (unless the Constants dialog is currently 

displayed).

2 Place your cursor in the Constant, Value, or Units cell of the constant to change.

3 Type your changes. Move the cursor to any other cells for this constant and make 
other required changes.

4 Repeat steps two and three to continue changing other constants.

5 Click Save to apply the changes. Click Cancel to disregard all changes.

Deleting named constants
To delete user-defined named constants
1 Select the Data > Constants command (unless the Constants dialog is already 

displayed).

Figure 30. New named constants added

RPM-defined
named constants

User-defined
named constants
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2 Select the row in the Constants dialog containing the named constant. You can 
select any cell within the row.

3 Click Delete.

4 Repeat steps two and three for each named constant.

5 Click Save to delete the selected items. Click Cancel to prevent deleting the 
named constants.

Caution! When you press Save and delete one or more constants, a warning message does not 
display.

Caution! When you delete one or more named constants using the Constants dialog, any node 
that uses the deleted name constant(s) produces an undefined calculation message 
when you perform workflow calculations.

Note You cannot delete an RPM-defined named constant. These RPM objects are protected 
and an information message displays if you attempt to delete one.

Preparing Mix defaults
The Set Mix Defaults dialog provides you the tools to:
• Choose the two minerals that predominate in the reservoir rock
• Select a pore fluid
• Specify the default mixing method or algorithm.

Hint For a complete list of mixing methods and the limitations that accompany each algo-
rithm, see “RPM mixing functions” on page 35.

Based on the mixing algorithm selected, key RPM function sets such as Gassmann, 
Greenberg-Castagna, and MixVelocity (Velocity synthesis) functions may required 
additional input parameters. Many of these needed mineral properties can be defined 
using the Rock and Fluid Properties dialog. (See “Organizing Rock, Mineral, 
Fluid, and Gas Properties” on page 54.)

Once you make the Set Mix Default choices (minerals, pore fluid, and algorithm), the 
rock, mineral, fluid, or gas Properties defined for the selected end minerals and fluid 
can act as default input parameters in many of the RPM rock physics functions.

To setup the mix defaults
1 Select the Data > Set Mix Defaults menu command.

2 Use the End Mineral 1 and End Mineral 2 drop-down selection lists to select 
minerals.

3 Specify the pore fluid using the Pore Fluid drop-down selection list.

4 Choose the mixing method with the Algorithm drop-down list.

5 Click OK.
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Organizing Rock, Mineral, Fluid, and Gas Properties

Structure
RPM for PowerLog comes with an RPM-defined set of rock, mineral, gas, and fluid 
properties. These RPM-defined rock physics properties can be changed to fit your 
reservoir geology. However, the RPM-defined set rock, mineral, fluid, and gas names 
cannot be deleted from the RPM software.

All user-defined property sets and values can be saved with the project, so that 
different geological regions can be customized with different rock physics parameters. 
Table 5 on page 54 shows the RPM-defined set of rock physics entities available in 
the RPM for PowerLog software.

All RPM- and user-defined rock physics items are classified as a:
• Rock
• Mineral
• Fluid or Gas

Figure 31. Set Mix Defaults dialog (mixing function defaults)

Table 5. RPM-defined rock, mineral, gas, and fluids

Type RPM-defined rock physics item

Rock Anhydriterock, Dolomiterock, Limestone, 
Mudstone, Saltrock, and Sandstone

Mineral Anhydrite, Calcite, Clay, Dolomite, Feldspar, 
Pyrite, Quartz, Siderite, and Salt

Fluid or Gas Brine, Deadoil, Gas, Liveoil, and Water
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Why rock and mineral properties default differently!
RPM for PowerLog handles minerals and rocks, differently, to the extent of using rock 
property default values differently from mineral property default values. How the 
defaulting mechanism described in the “RPM mixing functions” on page 35, differs 
for minerals and rocks, requires additional explanation.

RPM makes a distinction between minerals (such as quartz and calcite) and rocks 
(sandstone and limestone). Properties unsuitable for minerals (such as original 
porosity OriginalPorosity) have values that are initially set as undefined 
(UNDEF). Properties unsuitable for rocks (such as the density, Rho, which would imply 
dependencies on other Properties table parameters such as porosity) have values 
which are also initially undefined. From “RPM mixing functions” on page 35, only 
property values associated with minerals (not rocks) can be used as an automatic 
default in an RPM function parameter.

Example If the bulk modulus of a mineral phase is required as input parameter K_1 in 
MixVelocityVp function and the user does not specify a value, the quantity found in 
the Rock and Fluid Properties for mineral1.K is used; as indicated by the tool tip 
displayed when the cursor hovers over the input field. If mineral1 is quartz, then the 
default is quartz.K.

Caution! This automatic default value mechanism does not apply to rocks. There is no specifi-
cation of a default rock or rocks, and rock values are not automatically used from the 
Rock and Fluid Properties if the user leaves the input parameter blank for a rock. 

Example In MixVelocityVp, if the Orig_Poro1 parameter is blank, it cannot default to Origi-
nalPorosity for a rock, such as sandstone, because there is no default rock, and 
cannot default to OriginalPorosity for the default mineral. The user may change 
the UNDEF values for a rock or mineral in the Rock and Fluid Properties to specific 
values, but such property values associated with a rock or mineral are still not used as 
a default if the user leaves an input field associated with a rock blank (as opposed to a 
mineral) in a function. Input fields associated with rocks that are left blank default to 
undefined (UNDEF) values. The documentation and the tool tips indicate which input 
parameters default to undefined values for this reason.

The limitations on automatic defaulting described, do not inhibit your ability to explicitly 
select a rock or mineral value from the Rock and Fluid Properties, rather than 
entering a numerical value, as a rock input for a function.

Rock and Fluid entity and property names
Names used in rock, mineral, fluid, and gas properties cannot contain blank spaces. A 
spaces in a name is replaced with underscore (_) character.

Property names belonging to a rock, mineral, fluid, or a gas are case insensitive. This 
means is that all four spellings for the mineral name Barite are equivalent and its 
property name Shear_Velocity spellings are equivalent.

See Table , “Property or constant name variations,” on page 56.
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Rock and Fluid Properties dialog
The Rock and Fluid Properties dialog (Figure: 33, ‘Rock and Fluid Properties 
dialog”) displays for each rock, mineral, fluid, or gas property, its Name, Defined 
Value, and Units. Each RPM-defined rock, mineral, fluid, or gas has a complete set of 
“standard” properties. For user-defined additions to the Rocks, Fluids and Minerals 
list, you can add as few or as many properties as you need.

Example If you needed to set the properties for an RPM function that uses two mineral mem-
bers (quartz and clay) along with a brine fluid for coefficient correlations, the Rock and 
Fluid Properties dialog might look like this:

Table 6. Name variations in RPM properties or constants

Rock, Mineral, Fluid, or Gas
name variations

Property or constant
name variations

Barite Shear_Velocity

BARITE SHEAR_VELOCITY

barite shear_velocity

BARite Shear_velocity
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Caution! Since PowerLog expects US units for all of its operations, US units must be used in 
order to get accurate results. The exceptions are N/m2 is used bulk and shear moduli 
and g/cc for density values. All other properties must be expressed in US units.

You can use the Rock and Fluid Properties dialog to:
• Add new properties for a RPM-defined rock, mineral, fluid, or gas
• Change values of RPM-defined rock, mineral, fluid, or gas properties
• Add a user-defined rock, mineral, fluid, or gas
• Add, change, or delete user-defined rock, mineral, fluid, or gas properties

Figure 32. Quartz and Clay mineral properties example
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Adding a user-defined rock physics entity
In addition to the 20 RPM-defined rock, mineral, fluid, and gases (see Table 5 on 
page 54), you can define your own rock, mineral, fluid, or gas properties. The 
properties associated with each item can be used and imported into other workflows 
that work with similar geology. (See RPM for PowerLog — Getting Started Guide for 
a procedure to import rock, mineral, fluid, and gas properties.

To add a user-defined rock, mineral, fluid, or gas
1 Select the Data > Rock Fluid Properties command.

2 When the Rock and Fluid Properties dialog displays, click (+) under the Rock, 
Fluids and Minerals list.

Figure 33. Rock and Fluid Properties dialog

Set of Properties for Limestone

RPM-defined

User-defined

DeleteAdd

DeleteAdd
Properties

Retain
changes

Delete
changes

rock, mineral,
fluid, or gas

rock, mineral,
fluid, or gas
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3 Type the new name in the Rock or Fluid text box of the New Rock or Fluid 
dialog. For example, Halite.The name cannot contain blank spaces.6 7

4 Select the type from the Type drop-down list and click OK
– Rock
– Mineral
– Fluid or Gas

5 Repeat steps two through four for each user-defined rock, mineral, fluid, or gas.

6 Click Save to retain all your changes. Click Cancel to discard all changes.
The new entities display at the bottom of the Rock, Fluids and Minerals list. See 
Figure: 34, ‘New rock, mineral, fluid, or gas and properties added”.

Note When a user-defined rock, mineral, fluid, or gas is added, a default property (name of 
RenameProperty) is defined. You can immediately rename the property, add a value, 
and optionally add the property units.

Adding a property
To add a user-defined property
1 Select the Data > Rock Fluid Properties command.

2 When the Rock and Fluid Properties dialog displays, click (+) under the 
Properties area.

6. If you insert an entity name with a space, RPM for PowerLog replaces the space with an underscore character.
7. Duplicate names cannot be defined as illustrated in Table 6, “Name variations in RPM properties or constants,” 

on page 56.

Figure 34. New rock, mineral, fluid, or gas and properties added 

User-defined
properties
for GypsumUser-defined

rock, mineral,
fluid, or gas

RPM-defined
rock, mineral,
fluid, or gas
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3 When the New Rock or Fluid Property dialog displays, type the entries for:

– Property Name
– Property value
– Units

4 Click OK to close the New Rock or Fluid Property dialog.

5 Repeat steps two through four for all the properties to add.

6 Click Save to retain your new properties in the RPM project file. Click Cancel to 
discard all changes.

Renaming properties
To rename a user-defined property
1 Use the Data > Rock Fluid Properties command to display the New Rock or 

Fluid Property dialog.

2 Double-click in the desired property name cell under the Property column.

3 Change the property name by double-clicking and typing a new name in the cell.8

4 Repeat steps two and three for other property names.

5 Click Save to retain all your property name revisions. Click Cancel to discard all 
name changes.

Caution! If you have worked with user-defined rock, mineral, fluid, or gas properties in your 
workflow nodes and changes the names of one or more properties, you must return to 
the nodes where you used the “old” names. Right-click in the node input parameters 
with the “old” property name, select RockProperty, select the user-defined rock, 
mineral, fluid, or gas, and substitute the new property name.

Changing property value or units
To change RPM- or user-defined property information
1 Use the Data > Rock Fluid Properties command to display the New Rock or 

Fluid Property dialog.

2 Double-click in the desired property Value or Units cell.

3 Change the cell value to the desired number or other units.

4 Repeat steps two and three for other properties.

5 Click Save to retain property changes. Click Cancel to discard the changes.

Deleting a user-defined rock, mineral, fluid, or gas
To delete a user-defined rock, mineral, fluid, or gas
1 Use the Data > Rock Fluid Properties command to display the Rock and Fluid 

Properties dialog.

2 Select the user-defined rock, mineral, fluid, or gas to delete from the Rock, Fluids 
and Minerals list.

3 Click (-) under the Rock, Fluids and Minerals list.

8. If you insert a space in the name, the space is changed to an underscore (_) character
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4 Repeat steps two and three for each user-defined rock, mineral, fluid, or gas you 
want to delete.

5 Click Save to delete the items. Click Cancel to retain.

Caution! If you have worked with a user-defined rock, mineral, fluid, or gas properties in your 
workflow nodes and delete the names of one or more properties, you must return to 
the nodes where you used the property names and fix the input parameters. Right-
click in the node input parameters with the “deleted” names, select RockProperty, 
select a new rock, mineral, fluid, or gas, and substitute another property name.

Note If you select one of the RPM-defined rock, mineral, fluid, or gas by accident, RPM pre-
vents you from deleting this item and issues an information message.

Deleting a property
To delete a user-defined property
1 Use the Data > Rock Fluid Properties command to display the Rock and Fluid 

Properties dialog.

2 Select the user-defined rock, mineral, fluid, or gas from the Rock, Fluids and Min-
erals list.

3 Select the desired property by clicking in that row.

4 Click (-) under the Properties list.

5 Repeat steps two through four for each property.

6 Click Save to delete the properties. Click Cancel to discard changes.

Caution! If you have worked with user-defined rock, mineral, fluid, or gas properties in your 
workflow nodes and deleted the names of one or more properties, you must return to 
the nodes where you used the property names and fix the input parameter. Right-click 
in the node input parameters with the “deleted” property name, select RockProperty, 
select the user-defined rock, mineral, fluid, or gas, and substitute another property 
name.
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Note If you select one of the RPM-defined properties by accident, RPM prevents you from 
deleting these properties and issues an information message.

Setting up input curve and constant nodes

Input curves
The final step in beginning to prepare a workflow is to identify the PowerLog well 
curves you need as inputs. To define these input nodes, follow the procedures found 
in “Adding a node” on page 67.

Constant nodes
Caution! RPM for PowerLog provides you with the Constants dialog (see “Creating named 

constants” on page 51) and the Rock and Fluid Properties dialog (see “Organiz-
ing Rock, Mineral, Fluid, and Gas Properties” on page 54) to define physical prop-
erty constants, conditional logic constants, and computation flags. Using nodes to 
define constants unnecessarily increases the complexity of your workflows.

You may want to define UserValues or named constants to use in the workflow. 
There are several ways to create a UserValue constant node as these next four 
figures illustrate:

• Use the GetCurve function, type a value, and create the appropriate Label for the 
node. See Figure: 35, ‘GetCurve function used for a constant”, on page 63.

• Use the GetCurve function to create a constant that controls the workflow calcula-
tions with conditional logic (for example, a Gas/Oil flag where oil=1, gas=0). 
See Figure: 36, ‘Create constant as a computation flag”, on page 63.

• Use a simple calculation to create a meaningful constant. See Figure: 37, ‘Basic 
math operation used for a constant”, on page 64
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Figure 35. GetCurve function used for a constant

Figure 36. Create constant as a computation flag
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Hint Alternatively, you can defined named constants in the Constants dialog and use these 
throughout the workflow. To document the constant used in your workflow, you would 
use the GetCurve function and use the named constant as the input.

Note Using named constants (without nodes as documentation) can decrease the total 
number of workflow nodes and minimize extra connections. This results in a workflow 
that is easier to understand. You can use Groups to document your named constants 
and annotate elements of your workflow.

Figure 37. Basic math operation used for a constant

Figure 38. GetCurve function used to document a named constant
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Input curve nodes
Input curves from a PowerLog project well usually consisted of measured velocity, 
density, gamma ray, sonic, and other petrophysical curves that are edited and have 
had appropriate environmental corrections made.

Most PowerLog input curves are defined in a:
• Color-coded node (GetCurve function) to document the curve as a workflow input 

(For an example, see Figure: 39, ‘GetCurve function for PowerLog input 
curve”.)

• Simple calculation node. A common example is to convert a sonic log to a 
measured velocity curve. (For an example, see Figure: 40, ‘Creating an input 
curve with a calculation”, on page 66.)

Figure 39. GetCurve function for PowerLog input curve
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Figure 40. Creating an input curve with a calculation
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BUILDING ROCK PHYSICS WORKFLOWS

Working with nodes and connections

Adding a node

Ways to add a node
Adding a node is one of the most common operations you perform when building a 
rock physics model workflow. You can invoke this command four different ways:

• Menu—Select the Edit > Add Node command.
• Shortcut menu—In a blank portion of the workspace, right-click (MB3), and select 

the Add Node command.

• Tool bar—click the  icon.
• Keyboard shortcut—press the [cntl] and the [+] key.

Parts of a workflow node
As Figure: 41, ‘Parts of a workflow node”, on page 68 illustrates, a workflow 
computation node consists of a:
• Label—text that displays on the RPM workflow node box
• Function—performs arithmetic and conditional logic operations

– Type—collection of related functions
– Function (name)—specific function calculation

• Output—makes result available to workflow nodes or PowerLog curve storage
– Output (name)—node name used in workflow or PowerLog curve name 

(maximum eight characters)
– Type—resultant computation value type.
– Units—imperial or metric units. For the first RPM release, with some excep-

tions, most output units are US Imperial measurements.
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Adding a new node to the workflow
Adding a node to a workflow
1 Use one of the four methods (see “Ways to add a node” on page 67) to invoke 

the Add Node command.

2 When the cross-hair cursor displays, it can be moved to any position in the work-
flow. Click once (MB1) and a node of default size and color displays.

Hint Your color preferences (see “Applying a color to a single node, connection, or 
group” on page 80) define the initial node color.

3 Type in the Label text box a description that documents the node’s computation 
role in your workflow.

4 Select the function group using the Function Type drop-down selection list.

Figure 41. Parts of a workflow node
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Hint Use the context-sensitive help to find the desired function group and actual function-
name. See the RPM for PowerLog — Function Reference Guide for the same infor-
mation in a printed format.

5 Select the function name using the Function drop-down selection list.

6 [Optional] Click Help to display the function’s documentation, information about 
function input parameters, and parameter defaults using the Rock and Fluid 
Properties dialog.

7 For each input parameter, right-click (MB3) and use the shortcut lists to choose the 
desired input parameters or directly type values.

8 For the Output text box, you can type either a:

– Node number—use the output results in other workflow nodes.
– Curve name—stores the results in a PowerLog curve. You can use a 

maximum of eight characters for a name.

9 [Optional] Identify the output Type for this node. Some functions specifically create 
only one output type, such as acoustic velocity. See Figure: 41, ‘Parts of a work-
flow node”, on page 68.

10 Specify the output Units, unless the function has a specific output type specified in 
step 9.

11 Click OK.

Naming nodes
Workflow calculation nodes can specify a node number or a curve name as the output 
(written to the PowerLog project well). Curves are created as the results of RPM node 
calculations and written to the PowerLog well project. On the positive side, populating 
PowerLog with a number of intermediate curve results can be helpful in reviewing your 
calculations as you develop the workflow. The downside, you may need to delete 
curves later or the curve selection list begins to contain too many entries.

The RPM calculation nodes can be classified into three categories:
• Input nodes—Use PowerLog curve names or constants, along with the GetCurve 

function for these nodes. See “Determining workflow input curves” on 
page 48.

• Connection nodes—These nodes create outputs that are used as input 
parameters in other nodes. You should always use the node number for the input 
parameter, even if the curve has a different name. This creates the visual 
connection links between workflow nodes.

• Output nodes—These nodes produce results that you want to store in the 
PowerLog project well. Specify a curve name [maximum eight characters, no 
blank spaces] for the result you want stored.

Editing a node
Changing node information
1 Double-click the desired node or right-click (MB3) desired node and select the Edit 

Node shortcut menu command.
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Changing the Label, Output, or Units
1 Directly type new values for any of these fields you want to change.

2 Click OK, if this is the only information to change.

Selecting another function for this node
1 Using the Function Type drop-down selection list, select the desired function 

group. See Figure: 42, ‘Function Type selections and corresponding online 
help areas” for the complete list of function groups and the way to access docu-
mentation about each function in a group.

2 Use the Function drop-down list to select the actual rock physics or basic function 
you need. Click Help to display the function input parameters documentation.

3 Select the required input parameters for this function.

4 Click OK.

Hint Clicking the Help button displays the RPM function’s documentation in an Internet 
browser window. You can use the Select a Function Topic drop-down selection list to 
choose any major area of the online help and immediately jump to that HTML page.

Figure 42. Function Type selections and corresponding online help areas
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Selecting input parameters
Hint Before defining function input parameters for your first nodes, read “Inputs for func-

tion calculations” on page 24, for insight about the different input parameter types.

Selecting input parameters
1 Right-click on an input parameter under the Value/Name column and display the 

different input parameter types.

2 Select the parameter type and perform steps 3, 4, 5, or 6:

– Node—displays list of node names in the workflow with matching output type
– Curve—displays all PowerLog curves for this well
– CurveAlias—displays all PowerLog curve alias names
– RockProperty—displays all defined rock physics entities
– Constant—displays all defined named constants
– UserValue—user types a value

3 For a Node, Curve, or CurveAlias parameter, choose the desired item from the 
displayed selection list.

4 For a RockProperty:

a. Choose the desired rock, mineral, gas, or fluid from the second selection list.
b. For the chosen rock physics entity, select from the defined properties displayed 

in the subsequent selection list. (See Figure: 43, ‘RockProperty example 
selection lists”.)

5 For a Constant, choose the named constant from the selection list.

6 For a UserValue, type the value directly in the cell. A typed value can be an 
integer (42), real number (2.65), or scientific notation (8.7e+09, 2.3e-4).

7 Repeat steps one through six for all input parameters needed for this function.

8 Click OK.
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Naming a output
Determine if this node is an input, connection, or output node before deciding about 
the Output field. Consult the “Naming nodes” on page 69 section for directions.

Connecting nodes
In RPM for PowerLog, when you define the output of one node as the input to another 
node, the workflow shows this relationship with a directed arrow (for example, see 
nodes n67 and n68 in Figure: 14, ‘Example of different node types”, on page 30). 

Connect an output from one node to another
1 Double-click the node in which you want to use another node’s output, or 

right-click (MB3) desired node and select the Edit Node menu command.

2 Right-click the input parameter under the Value/Name column and display the 
parameter types.

3 Select Node.

4 When the node selection list displays, choose the desired workflow node to use.

5 Click OK.

Figure 43. RockProperty example selection lists

plus others
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A connection between the example nodes in Figure: 14, ‘Example of different node 
types”, on page 30 is established when you use n67 as an input parameter to the 
calculation in n68 in Figure: 44, ‘Creating a connection between nodes”.

Finding a node
RPM for PowerLog uses its Find Node function to help you locate any node within the 
workflow.

To find a node in the workflow
1 Use one of these methods to invoke the Find Node command:

– Select the View > Find Node menu command.
– Right-click in an empty workspace area and select Find Node from the 

Workspace shortcut menu.

– Click the toolbar icon.

2 When the Node Locator dialog displays, select the desired node and click OK.

The specified node flashes with a yellow background twice. If the node location is 
outside the screen display area, the screen scrolls left or right to display the node. 

Figure 44. Creating a connection between nodes
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If the specified node is hidden within a minimized group, the group opens to reveal 
the chosen node.

Deleting a node
RPM for PowerLog can delete workflow nodes that are not needed in your workflow 
computations.

Caution! Before deleting any node, check to see which workflow nodes depend upon this node 
for its output. Use the View > Show Descendents command and select the node you 
plan to delete. All impacted nodes impacted display with highlighted connections. Use 
View > Clear Selections command to clear the highlighted connections.

To delete a node
1 Select the node to delete with one mouse (MB1) click.
2 Right-click (MB3) and select the Delete Node command. RPM deletes the node.

Hint If you selected the wrong node, use the Edit > Undo command to restore the deleted 
node.

Deleting multiple nodes
You can delete several nodes at once by selecting an area containing the nodes to 
delete.

Caution! Before deleting any node, check to see which workflow nodes depend upon this node 
for its output. Use the View > Show Descendents command and select the node you 
plan to delete. All impacted nodes impacted display with highlighted connections. Use 
View > Clear Selections command to clear the highlighted connections.

To delete several nodes at once
1 Move the nodes you want to delete by clicking and dragging each node to an 

unused portion of the workflow. Ensure that any nodes you want to keep are not in 
the area you select in the next steps.

2 Click and hold the mouse down at a point in the workspace representing the top 
left-hand corner of your node deletion area.

3 Drag the cursor to the bottom right-hand corner of the area containing all the 
nodes you want to delete. Release the mouse button. Your workflow would look 
similar to Figure: 45, ‘Deleting nodes within a workflow area”.

4 Press the [Delete] key. This deletes the enclosed nodes.
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Hint If you included a node you did not want to delete, use the Edit > Undo command to 
restore all the deleted nodes to your workflow.

Efficient techniques for working with nodes

Keyboard shortcuts

Using Undo and Redo commands

Refreshing the workflow display

Redrawing the complete display

Refreshing the workflow node connections
Select the Edit > Reconnect command or press the [F6] function key. RPM for 
PowerLog redraws and saves all the connections when the workflow gets complex.

Performing and understanding workflow calculations
DOC_001 - insert workflow calculations

Controlling creation of computation curves

Overwriting PowerLog curves

Figure 45. Deleting nodes within a workflow area
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Displaying the node calculation order
What does this do

Blocking Curve Overwrite Warnings
DOC_001 - eliminating the warnings

Note The Block Curve Overwrite Warnings setting remains the same until you change the 
setting. That means, if you exit the RPM for PowerLog application, this setting is 
remembered from one RPM session to the next.

Caution! Curves must be write-protected in PowerLog to prevent RPM from overwriting (with or 
without the warning messages blocked).

Sending warning messages to the Output Log
xxxxxx

Performing a workflow calculation

Node

Group

Path

Workflow

RPM for PowerLog can perform all the calculations for the entire workflow. You can 
invoke this command four different ways:
• Menu—Select the Calculate > Calculate Workflow command.
• Shortcut menu—Select a node, right-click (MB3), and select the Calculate > 

Calculate Workflow command.

• Tool bar—click the  icon.
• Keyboard shortcut—press the [F8] key.

Displaying computation elements

Selecting a path

Finding a workflow node

A node's ancestors
DOC_005 determining inputs to a specific node calculation



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 77

Building Rock Physics Workflows Performing and understanding workflow calculations

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

A node's descendents

Clearing a path display

Troubleshooting a workflow calculation
The RPM for PowerLog application provides extensive freedom in structuring your 
workflow calculations. RPM first displays the Processing Order dialog to describe in 
what order RPM does the node calculations. Once you click OK, a calculation 
progress meter displays.

When a problem happens, such as in this example:

you need to begin a systematic procedure for eliminating possible calculation errors.

Tools—alert boxes, status bar, dialogs, and commands
The RPM for PowerLog software contains several user interface elements to help you 
create successful workflow calculations:
• Alert messages—during a calculation, these dialog boxes display error messages.
• Status bar—during the node calculations, the status bar displays messages for 

successful and failed node calculations
• Dialogs—the Curve List and Curve Alias dialogs can help identify missing well 

curves needed for this workflow. The Function Selection dialog can provide clues 
to invalid parameters or parameters that do not match this function.

• Commands—the Show Ancestors and Show Descendents commands (see 
“View menu” on page 124) help you retrace a calculation’s steps.

Figure 46. Node calculation order and progress meter
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Checking input curves
Selected curves used in the RPM workflow come directly from the PowerLog project 
and the project well you selected. If you select another well or a different project, you 
should check the input curve names to ensure that each curve name or its alias exists 
in the well. Use the “Curve List dialog” on page 141 and the “Curve Alias List 
dialog” on page 143. This situation is identified in the workflow calculation with an 
alert dialog that looks like:

Checking input values
Each of the functions available to any node in the workflow can receive inputs from 
other nodes. Use the “Output Log dialog” on page 142 to determine possible output 
curves at other nodes that affect this node. Check the node function using the “Node 
shortcut menu” on page 126 to determine its input parameters. When a calculation 
error happens, this alert message displays:

Fixing function parameters

Checking ancestors and descendents
In the previous section, we showed how to display a calculation’s steps, using the 
Show Ancestors and Show Descendents commands.

When a node calculation fails:
• Show Ancestors—provides a visual identification of all nodes that define most of 

input parameter values and curves.

Developing workflow calculation nodes

Node input and output naming conventions
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Using basic functions

Arithmetic Functions

Trigonometric Functions

Discrimination / Conditional Logic Functions

Random Numbers

Statistical Functions

Using Rock Fluids Physics functions

Using miscellaneous functions

Using mixing functions

Adding custom constants

Adding custom rock, fluid, and mineral properties
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Organizing your workflow

Setting preferences

Selecting colors

Selecting a usable workspace color

Node, connection, group, and path colors 

Applying a color to a single node, connection, or group

Refreshing and deleting a workflow

Organizing Nodes into Modular Groups

Groups
Nodes can be associated into groups by adding a group defined by drawing a 
rectangle around the desired nodes and dragging them into the group. The group can 
be minimized so that only one box shows in the place of all the nodes in the group. A 
group can be minimized or restored to its original size (see Figure: 47, ‘Group 
minimizing workflow complexity”). You can assigned a very descriptive name to a 
group, which can span several text lines. The group can be moved around as a whole 
and individual nodes can be moved inside the group. Complex workflows can be 
simplified by using groups to manage a related set of nodes.
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Adding a group
To define a group
1 First select this Edit > Define Group command or click the Group tool bar button.
2 Click and drag the mouse to define the rectangular area containing all the desired 

nodes.
3 Drag the nodes, for which you want to establish an association or workflow parti-

tion, together
4 Drag any nodes you do not want in the group to a part of the workspace outside 

the rectangular area. Do this by clicking the mouse on the nodes and dragging 
them to another part of the workflow. 

Note RPM considers any node, even partially contained in the group rectangle, to be a 
member of the group. If you want certain nodes are to be excluded, you need to phys-
ically move them to another part of the screen. The connections move with the nodes 
to the new locations. A node can be moved out of a group by clicking and dragging the 
node outside the group boundary.

The group can be minimized so that complex workflows can be made easier to use. It 
can be maximized when you want to show the nodes within the group. The upper 
right-hand corner of the group box contains the minimize and maximize control. You 
can resize groups by dragging the group edges or corners.

Deleting a group

Moving nodes on the workflow

Moving a node

Rubber-banding nodes

Figure 47. Group minimizing workflow complexity
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Moving a group of nodes

Deleting a group of nodes

Adding advanced workflow elements

Adding descriptive labels to document the workflow

Using conditional logic in calculations

Using SimpleExpression to minimize nodes

Importing parameters and constants from other projects

Planning for multi-well RPM projects

Displaying Curve Alias list

Troubleshooting calculations
DOC_005 determining inputs to a specific node calculation

Figure 48.

Figure 49.
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Using more complex member mix functions

Understanding mixing algorithms

Supplying additional needed parameters

Fitting curves

Figure 50.

Figure 51.

Figure 52.

Figure 53.
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This section contains:
• Rock Physics Models
• Tutorial workflow names
• What is a workflow?
• Symbols used in rock physics formulas
• Tutorial workflows overview
• Starting Point Workflow
• Curve Differences Statistics workflow
• SimpleExpression formulas and logic workflow
• RP Properties for AVO Checks workflow
• Fluid properties to estimate Vs workflow
• Lithology log construction workflow
• Gassmann fluid-substitution to predict seismic response workflow

Rock Physics Models

What’s the added value to my interpretation project?
Answer, a rock physics model that:
• Links the petrophysical analysis (ρ-density, P-sonic, and S-sonic logs) and seismic 

data to yield compatible seismic inversions.
• Enhances your comprehension of the reservoir production characteristics and the 

underlying geology.
• Provides a consistency check that demands that the elastic constants (E, K, λ, µ, 

and ν), minerals, and fluids match well logs and seismic data.
– Vp, density, and Vs obtained from logs must match the values obtained from 

the RP model using K, µ, and ρ for the minerals and fluids.
– Synthetic seismic data obtain from impedance and reflectivity curves must 

match the RP model using K, µ, and ρ for the minerals and fluids.

• Generates a P-sonic calculation that you can compare with the P-sonic 
measurements to check the porosity, minerals, and fluids.

• Computes S-sonic logs if AVO processing is unavailable.
• Uses algorithms to calculate density, Vp acoustic velocity, and Vs shear velocity
• Characterizes your reservoir

– Model hypothetical fluid substitutions
– Model impedance logs to create synthetic seismograms and compare these to 

seismic data.
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What are the rock physics model elements?
A rock physics model usually consists of:
• Pore fluids
• Porosity (φ)
• Mineral density (ρ), bulk modulus (K), and shear modulus (µ)
• Temperature and pressure
• Density of pore fluids (ρfluid) and bulk modulus of fluid (Kfluid)
• Grain and pore structure
• Mineral volume fraction for each mineral type
• Mineral grains for one or more types
• Water saturation (Sw), plus gas/oil ratio (GOR) if needed

Tutorial workflow names
The Fugro-Jason tutorial workflows included with the RPM software are:
• Starting Point Workflow—shows how to use basic curves and defined constants 

to develop basic properties and calculate bulk density, Vp and Vs for a rock physics 
model.

• Curve Differences Statistics—illustrates an approach to determining the RMS 
(root-mean squared) difference between a measured and a calculated (model) 
curve. Correlation coefficient and an average bias level are also calculated for the 
measured and calculated curves.

• SimpleExpression formulas and logic—demonstrates how to perform multiple 
testing logic and evaluate extensive mathematical and rock physics equations.

• RP Properties for AVO Checks—provides calculations of acoustic and shear 
velocities, effective porosity, and Zp and Zs impedances. Other elastic constants 
are computed from velocities and impedances such as:
– Bulk modulus (K)
– Shear modulus (µ)
– Young’s modulus (E)
– Poisson’s ratio (ν)
– Shear modulus/density product (µρ) proportional to shear impedance
– Lamé’s constant/density product (λρ) proportional to acoustic impedance

• Fluid properties to estimate Vs—uses named constants or PowerLog curves to 
calculate the fluid (brine, oil, and gas) properties, along with a mean value of each 
curve.

• Lithology log construction—demonstrates building a lithology log based on 
petrophysical curve values, that can be extended to building a lithology log with 
rock physics-derived parameters.

• Gassmann fluid-substitution to predict seismic response—demonstrates the 
computation of brine, oil, gas, and fluid properties for existing saturation and new 
fluid substitution. The results are used with the GassmannFull function to predict 
the acoustic velocity under fluid substitution conditions.
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What is a workflow?
A workflow is an RPM for PowerLog project that:
• Serves a starting point to develop more complex and customized rock physics 

models
• Uses PowerLog input curves and named constant values that a user can quickly 

change
• Reuses different PowerLog projects and wells to achieve multiple project results

Workflows are calculated from input curves belonging to a single PowerLog well 
project and for limited well depth intervals.

Fugro-Jason provides workflows with RPM for PowerLog software so you:
• Can develop useful computations when you first begin using RPM
• Have an initial starting point to develop your own customized workflows
• Learn some effective development techniques to apply to your own workflows

These workflows illustrate a single approach to accomplish a particular rock-physics 
computation, not necessarily the best way or the only way. You, the geoscience 
professional, ultimately need to decide that a specific set of workflows is appropriate 
for the pore fluids, lithology, and goals of your project. The RPM for PowerLog 
software provides the tools to build your workflow, without a set of rigid constraints or 
methodology.

This document section describes the tutorial workflows that you can use as a starting 
point for developing your own reservoir project workflows. Use these examples as 
models and configure your workflow to meet your specific needs.

Symbols used in rock physics formulas

Table 7. Commonly used symbols in rock physics

Symbol Name Purpose

λ lambda Lamé’s constant (K – 2µ/3)

Κ Kappa bulk modulus

Ε Epsilon Young’s modulus

µ mu shear modulus (G also used)

ρ rho (1) density or (2) correlation coefficient

ϕ phi porosity

σ sigma standard deviation (variance is σ2)

ν nu Poisson’s ratio

ω omega angular frequency

α alpha
(Vp0)

(1) crack (pore) aspect ratio, (2) P-wave velocity along the vertical sym-
metry axis of a transversely isotropic media, (3) mean deviation.

β beta
(Vs0)

S-wave velocity along the vertical symmetry axis of a transversely iso-
tropic media



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 87

Tutorial Workflows Tutorial workflows overview

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Tutorial workflows overview

Characteristics
These tutorial workflows have several common characteristics:
• Nodes where you must check for required curve names, are colored Red to denote 

input curves from a PowerLog well. In these nodes you insert a curve name appro-
priate for your well or you can insert an appropriate curve alias name.

• Significant rock physics values and workflow flags are defined as named constants 
and documented in the Rock and Fluid Properties and Constants software 
dialog displays.

• Input PowerLog curves, resulting output curves, workflow formulas and RPM func-
tions, and named constants are documented so that you can quickly grasp the 
workflow essentials.

• Workflow output curves are colored Blue.
• Nodes organized in groups, which can be minimized to hide details and show over-

all workflow organization.

Color schemes
RPM for PowerLog provides you the ability set the color preferences of your workflow 
elements:
• Node
• Group
• Connection
• Workspace background

∆ Delta Acoustic and shear sonic travel times (measured in µsec/ft.)

Μ Mu P wave modulus (Μ = ρVp
2)

Thomsen’s anisotropy parameters - relates P-wave and S-wave velocities along the vertical 
symmetry axis to three phase velocities propagating in the direction of a deviated well.

γ gamma The fractional difference in Vsh between the horizontal and vertical 
directions, and the normalized difference between Vsh and Vsv in the 
horizontal propagating S-waves.

δ delta Thomsen anisotropy parameter that relates P-wave and S-wave 
velocities along the vertical symmetry axis to the three phase velocities 
propagating in the direction of a deviated well.

ε epsilon Thomsen anisotropy parameter for P-wave anisotropy or the fractional 
difference in P-wave velocity between the horizontal and vertical 
directions.

Table 7. Commonly used symbols in rock physics (Continued)

Symbol Name Purpose
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Note The color scheme used to document the Tutorial Workflows section is described in the 
next table.

Starting Point Workflow
The Starting Point Workflow9 helps you get oriented to organizing some of your 
workflow elements into various groups. In this workflow you calculate a density, Vp, 
and Vs curve using a number of common petrophysical curves and constants.

Objectives
The Starting Point Workflow:
• Calculates density, acoustic velocity, and shear velocity.
• Outputs PowerLog curves to use in the Curve Differences Statistics workflow to 

determine a quantitative measure of the modeling effort’s success.
• Illustrates how the elastic moduli from brine, oil, and gas can be calculated using 

pressure, temperature, and salinity information.
• Shows how to use conditional logic functions to interchange gas and oil properties 

when computing the final hydrocarbon properties.
• Illustrates simple usage of MixVelocity functions using simple constants for modu-

lus constants and clay velocities.
• Calculates the fluid bulk modulus using Brie’s formula (Dvorkin at al. 1999 [12]) for 

patchy saturation.
• Describes and documents named constants to create an easy to use workflow.

Table 8. Example workflow color scheme

Workflow Element Color
Color Specification
Red: xxx, Green: yyy, Blue: zzz

Workspace (background) Red: 255, Green: 255, Blue: 192

PowerLog input curves (nodes) Red: 255, Green: 85, Blue: 0

Computation nodes Red: 255, Green: 255, Blue: 127

Groups (background) Red: 255, Green: 170, Blue: 0

Output results (nodes) Red: 173, Green: 216, Blue: 230

Labels - workflow and constants Red: 85, Green: 170, Blue: 255

Connections Black Red: 0, Green: 0, Blue: 0

9. Many thanks to Mark Sams of Fugro-Jason for developing the initial draft of this workflow.
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Computed results
These PowerLog output curves are created when the entire workflow is calculated.

Strategies
The key approach to solving this problem involves:
• Using the downhole temperature, pressure information, and named constants with 

the Fluid/Rock Physics for Brine, Oil, and Gas functions (BrineRho, BrineK, 
GasRho, GasK, LiveOilRho and LIveOilK).

• Use a conditional logic named constant Gas_oil_flag (oil=0, gas=1) to select 
one set of properties and designate these properties as the HC or hydrocarbon 
component.

• Specifying a set of clay velocity, density, and modulus constants, along with the 
clay pore aspect ratio to serve as inputs to the MixVelocity functions.

• Combine the brine and hydrocarbon fluid properties, with the clay properties, and 
use the Volume of wet clay curve as the fractional volume to run each of the 
MixVelocity functions (MixVelocityRho, MixVelocityVp, and MixVelocityVs).

PowerLog input curves
These PowerLog input curves are used to calculate the brine, gas, and oil properties. 
The water saturation curve is used in the Brie’s patchy saturation formula (Brie et al. 
1995 [6]) and to compute the density fraction of brine and hydrocarbons. The total 
porosity and Vclay curves are inputs to the MixVelocity functions.

Table 9. Starting Point Workflow - output curves

Node Curve 
Name

Type - Units Description

n17 VpVsmeas any none Measured Vp/Vs ratio, calculated from Vp and Vs 
measured curves

n23 rhocalc density g/cc Calculated bulk density

n24 Pvelcalc p_velocity ft/sec Calculated acoustic velocity

n25 Svelcalc s_velocity ft/sec Calculated shear velocity

n26 Zpcalc any none Calculated acoustic impedance

n27 Zscalc any none Calculated shear impedance

n28 DTpcalc p_sonic µsec/ft. Calculated acoustic sonic

n29 DTscalc s_sonic µsec/ft. Calculated shear sonic

n30 VpVscalc any none Vp / Vs velocity ratio
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Hint For your well, you may need to modify the curve names or replace them with a 
convenient curve alias name. The curve names in the previous table are from the 
tutorial Starting_Point_Workflow project.

Named Constants and Mineral Properties
This table displays the named constants, clay properties, grain/clay pore aspect ratios, 
and the conditional logic switch for gas and oil.

Table 10. Starting Point Workflow - input curves

Node Curve Name Type and Units Description

n0 SW SW none Water saturation

n1 PHIT porosity none Total porosity

n2 VCL any none Volume of Wet Clay

n3 PRES pressure psi Pressure of formation

n4 T temperature degF Downhole temperature

n5 RHOC any none Bulk density - measured

n6 DT p_sonic µsec/ft. P-sonic measured

n7 VP p_velocity ft/sec Vp measured

n8 VS s_velocity ft/sec Vs measured

Table 11. Starting Point Workflow - named constants and rock/fluid properties

Name Value Units Used in these workflow nodes

Brine_salinity 150000 ppm n9, n10—concentration

Gas_specific_gravity .07 none n11, n12, n13, n14—spec-grav

Gas_oil_ratio 44/5.615 none n13, n14—dimensionless Rs

Oil_api 33 api n13, n14—oil density

Gas_oil_flag 0 - Gas
otherwise 
Oil

none n15, n16—select which hydrocarbon to 
use in the fluid computations

Clay_Vs 6233.6 ft/sec Compute µclay and Kclay

Clay_Vp 13714 ft/sec Compute µclay and Kclay

Grain_aspect_ratio .08 none n23, n24, n25—nonclay (Quartz) pore 
aspect ratio

Clay_aspect_ratio .05 none n23, n24, n25—Clay pore aspect ratio

Brie_parameter 7 none n19—patchy saturation computation

Clay.Mu 9.747e9 N/m2 n23, n24, n25—clay shear modulus
= MuFromVel (Vs-clay, ρclay)
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Key workflow functions and formulas
The major expressions used in these workflow nodes are:
• n9—ρbrine = BrineRho10(Pressurecurve, Temperaturecurve, Brine_Salinity)
• n10—Kbrine = BrineK( Pressurecurve, Temperaturecurve, Brine_Salinity)
• n11—ρgas = GasRho( Pressurecurve, Temperaturecurve, Gas_specific_gravity, Bat-

zle&Wang)
• n12—Kgas = GasK( Pressurecurve, Temperaturecurve, Gas_specific_gravity, Bat-

zle&Wang)
• n13—ρoil = LiveOilRho( Pressurecurve, Temperaturecurve, Oil_api, Gas_oil_ratio, 

Gas_specific_gravity, blank, Batzle&Wang)

• n14—Koil = LiveOilK( Pressurecurve, Temperaturecurve, Oil_api, Gas_oil_ratio, 
Gas_specific_gravity, blank, Batzle&Wang)

• n15—KHC = ConditionalExpression( Gas_oil_flag, ==, 0, Kgas , Koil ) 11

• n16—ρHC= ConditionalExpression( Gas_oil_flag, ==, 0, ρgas, ρoil )
• n17—Vp/Vsmeas = VPcurve / VScurve
• n18—Density FractionHC= ( 1 - Gas_spec_gravity ) * ρHC
• n19—Kpatchy = ( Kbrine - KHC ) * SWcurve ** Brie_parameter
• n20—Density Fractionbrine= SWcurve * ρbrine
• n21—ρfluid = ( Density Fractionbrine + Density FractionHC )
• n22—Kfluid = ( Kpatchy + KHC )

Hint All three MixVelocity functions (MixVelocityRho, MixVelocityVp, and 
MixVelocityVs) take the same input constants and PowerLog curve names shown.

• n23— rhocalc = ρcalculated = MixVelocityRho ( PHITcurve , VCLcurve, Quartz.K, 
Clay.K, Quartz.Mu, Clay.Mu, Quartz.Rho, Clay.Rho, 
Grain_aspect_ratio, Clay_aspect_ratio, blank, blank, blank, blank, blank, 
blank, blank, Kfluid, ρfluid, XuWhiteApprox)

• n24— Pvelcalc = Vp_calculated = MixVelocityVp ( PHITcurve , VCLcurve, Quartz.K, 
Clay.K, Quartz.Mu, Clay.Mu, Quartz.Rho, Clay.Rho, 
Grain_aspect_ratio, Clay_aspect_ratio, blank, blank, blank, blank, blank, 
blank, blank, Kfluid, ρfluid, XuWhiteApprox)

Clay.K 3.418e10 N/m2 n23, n24, n25—clay bulk modulus
= KFromVel (Vp-clay, Vs-clay, ρclay)

Clay_rho 2.7 g/cc n23, n24, n25—clay density

Quartz.Mu 4.433e10 N/m2 n23, n24, n25—quartz shear modulus

Quartz.K 3.789e10 N/m2 n23, n24, n25—quartz bulk modulus

Quartz.Rho 2.65 g/cc n23, n24, n25—quartz density

10.Name of the RPM rock physics function used for this node. All other nodes use mathematical functions.
11.HC - Denotes hydrocarbon (oil or gas) selected with the ConditionalExpression RPM function for KHC and ρHC.

Table 11. Starting Point Workflow - named constants and rock/fluid properties (Continued)

Name Value Units Used in these workflow nodes
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• n25— Svelcalc = Vs_calculated = MixVelocityVs ( PHITcurve , VCLcurve, Quartz.K, 
Clay.K, Quartz.Mu, Clay.Mu, Quartz.Rho, Clay.Rho, 
Grain_aspect_ratio, Clay_aspect_ratio, blank, blank, blank, blank, blank, 
blank, blank, Kfluid, ρfluid, XuWhiteApprox)

• n26— Zpcalc = Zp_calculated = Vp_calculated * ρcalculated 
• n27— Zscalc = Zs_calculated = Vs_calculated * ρcalculated 
• n28— DTpcalc = ∆tp_calculated = 1000000. / Vp_calculated 
• n29— DTscalc = ∆ts_calculated = 1000000. / Vs_calculated
• n30— VpVscalc = Vp/Vs_calculated = Vp_calculated / Vs_calculated 
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Curve Differences Statistics
The Curve Differences Statistics workflow helps you to understand how accurately any 
calculated curve from a rock physics model workflow approximates the equivalent 
measured petrophysical log. A correlation value ≥ 0.8 suggests a strong correlation, 
while a value ≤ 0.5 suggests a weak correlation. You can use this workflow to assess 
the calculated results of the Starting Point Workflow against the measured well curves:
• Density (ρ)
• Vp (acoustic velocity)
• Shear velocity (Vs)
• Vp / Vs (acoustic / shear) velocity ratio

Objectives
The Curve Differences Statistics workflow:
• Provides information about the accuracy of a rock physics model curve calculation.
• Illustrates a workflow building block that can be used interchangeably with any set 

of measured and calculated curves
• Identifies if the measured and calculated (modeled) curves are strongly correlated, 

suggesting that the model approximates the measured response.
• Computes a quality control value in the form of the averaged RMS difference per-

centage between the calculated and measured curves. This value can be com-
pared with other workflow calculations to see if the model error is decreasing or 
increasing due to parameter or model variations.

• Computes a bias function. A significant average bias function suggests there are 
unaccounted factors not described by the model.

Computed results
The Curve Differences Statistics workflow yields these results for each measured and 
calculated curves:
• Error function curve (n2)—curve stored in PowerLog that can be plotted beside 

the calculated and measured curves. Node n2 is where you change the name of 
the output error function curve.

• RMS Difference Percentage (n7)—A value that describes the average difference 
between the calculated and measured curves. This value is the computed as:
n7—RMS Difference Percentage = 100 * ∆RMS / meanmeas, that is, the root-mean 
square of the curve difference, normalized by the mean of the measured curve

• Correlation Coefficient value (n3)—A value describing the amount of linear 
correlation between the measured and calculated curve. A correlation value ≥ 0.8 
suggests a strong correlation, while a value ≤ 0.5 suggests a weak correlation.

• Average Bias Percentage (n10)—A value equal to the average deviation 
between the measured and calculated curve.

Strategies
The computations in the Curve Differences Statistics workflow are a straightforward 
usage of the Correlation, Mean, Sum, and Rms RPM statistical functions.



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 95

Tutorial Workflows Curve Differences Statistics

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

You can use the Curve Differences Statistics workflow in two ways:
• Method One—Change the names of the two input PowerLog curves and the 

single output curve and rerun the workflow four times with the desired curves. For 
example, the density, Vp, Vs, and Vp/Vs curves from the Starting Point Workflow.

• Method Two—Make three identical copies of these workflow nodes. You can then 
calculate the curve difference statistics for density, Vp, Vs, and Vp/Vs in a single 
workflow.

Input curves
See Table 12, “Curve Differences Statistics workflow - curve names,” on 
page 95.

Named constants
The Curve Differences Statistics workflow uses no named Constants or Rock and 
Fluid Properties.

Key workflow functions and formulas
• n2—Difference function = 2 * (Meascurve - Calccurve) / ( Meascurve + Calccurve )
• n3— ρ = Correlation (Meascurve , Calccurve)

mcalc = mean of calculated curve, mmeas = mean of measured curve
σcalc = Standard deviation of calculated, σmeas = Standard deviation of measured 
Correlation Coefficient r = 
(1/N) *  (curvemeas - mmeas)(curvecalc - mcalc) / σmeas * σcalc

• n4—∆curve = Meascurve - Calccurve
• n5—meanmeas = Mean( Meascurve )
• n6— ∆RMS = RMS of curve difference = Rms( Meascurve - Calccurve )
• n7—RMS Difference Percentage = 100 * ∆RMS / meanmeas 
• n8—∑meas = Sum ( Meascurve )
• n9— ∑∆curve = Sum ( ∆curve )
• n10—Bias Percentage = 100 * ∑∆curve / ∑meas 

Table 12. Curve Differences Statistics workflow - curve names

Curve Type Calculated Curve
Node n0

Measured Curve
Node n1

Output Error 
Function Name

Density rhocalc RHOC Rhoerr

Vp Pvelcalc VP Vperr

Vs Svelcalc VS Vserr

Vp/Vs ratio VpVsmeas VpVscalc VpVserr
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SimpleExpression formulas and logic
This workflow demonstrates some of the computational formulas and sophisticated 
logic possible with the SimpleExpression function in RPM for PowerLog.

Objectives
The SimpleExpression formulas and logic workflow demonstrates how to:
• Control the computation sequence using parentheses
• Implement multiple decision logic two ways to determine a:

– curve that is limited between an minimum and a maximum value
– lithology coding
– fluid substitution value

• Implement a rock physics formula not found in RPM
– Brie’s patchy saturation formula
– λρ lambda-density product and µρ mu-density product
– Poisson’s ratio12

– Young’s modulus

Named Constants
This table displays the named constants, for the SimpleExpression formulas and logic 
workflow.

12.The Poisson function does perform this calculation.

Table 13. SimpleExpression formulas and logic workflow - named constants

Name Value Units Used in these workflow nodes

Sonic_min 90 µsec/ft. n3, n5—minimum sonic transit time

Sonic_max 100 µsec/ft. n3, n5—maximum sonic transit time

Previous_value 2 none n6, used in n11 and n10—previous 
lithology log value determination

Min_clay_volume .4 none n7, n11—minimum clay volume for 
calcareous shale

Min_coal_volume .1 none n8, n11—minimum coal volume for 
calcareous shale

Min_quartz_dominates .5 none n9, n11—maximum quartz volume 
for calcareous shale

Calcareous_shale 1 none n10, n11—value representing cal-
careous shale for lithology log

Vol_clay_max .2 none n12, n17—maximum clay volume 
permitted for fluid substitution

Phi_effective_min .05 none n14, n17—minimum effective poros-
ity required for fluid substitution
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Key workflow functions and formulas
The SimpleExpression formulas and logic workflow uses a few nodes and the 
SimpleExpression function to demonstrate each concept listed in the Objectives.

Computation Sequence
The Computational precedence group (in the workflow) demonstrates the use of 
parentheses to explicitly control how a complex mathematical expression is evaluated.

Without any parentheses inserted into a SimpleExpression function, the computation 
sequence defaults to trules two through six.
Operator precedence

Comments For each priority, operators that have the same rank level are evaluated from left to right.
Caution! The conditional operators are evaluated right to left.
Comments ( 8 - 2*3 + 3 ) ** 2 evaluates to 8 - 6 + 3 = 5 ** 2 = 25 because the 2*3 

multiplication operator has precedence over other arithmetic operators and the parenthesis 
operator has higher priority than the power (**) operator.

Two example nodes make this very clear:
• n0— 1 + 2 + 3 * 4 ^ 5 * 6 + 7 

evaluates to
1 + 2 + 3 * 1024 * 6 + 7
1 + 2 + 3072 * 6 + 7
1 + 2 + 18432 + 7 = 18442

• n1— (1 + 2) + (3 * 4) ^5 * (6+7) 
evaluates the same expression with parentheses to control the computation
3 + (12) ^ 5 * (13)
3 + 248832 * 13
3 + 3234816 = 3234819

Sw_new .2 none n15, n17—new water saturation is 
for fluid substitution

Z_conversion 92903.4 none n23, n24—converts µρ and λρ to 
metric

Priority Operator Type Operators Operator Description
1st Parenthesis ( or ) Parenthesis control order
2nd Arithmetic ^ or ** Raising a value to a power
3rd Arithmetic * or / Multiplication and Division
4th Arithmetic + or - Addition and subtraction
5th Comparison < <= > >= = == != <> Comparison
6th Conditional ? or : If-then and Else

Table 13. SimpleExpression formulas and logic workflow - named constants (Continued)

Name Value Units Used in these workflow nodes
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Curve range values limited, two implementations
The Two curve range implementations group shows how to limit the values within a 
PowerLog curve to a range between a minimum and maximum threshold:
• n3—all curve values are between the minimum and maximum values. If a curve 

sample exceeds the maximum, the curve sample is set to maximum threshold. 
Conversely, if a curve sample is less than the minimum, it is set to the minimum 
threshold.

• n5—uses the SimpleExpression to test each curve sample. If the curve sample 
exceeds either threshold value, the curve sample is set to an undefined value 
(UNDEF_POWERLOG).

Lithology coding decision making
The Lithology coding decision making group shows how to group multiple decision cri-
teria into a single SimpleExpression statement and reduce the number of RPM nodes 
from four to one:
• n7, n8, n9, and n10—use the ConditionalExpression for each test and 

then a SimpleExpression function to check that all three tests were true.
• n11—uses the SimpleExpression to perform a boolean AND operation with three 

separate conditional tests.

The logic for the n11 node can be diagrammed with each indentation level signifying a 
subordinate If-then-else structure (with PowerLog curves VCL, VCLC, and VCLQ):

Fluid substitution decision making
The Fluid Substitution decision making group shows two methods for selecting the 
appropriate water saturation value, based on clay volume and effective porosity:
• In nodes n12 through n16, the ConditionalExpression function is used to decide 

whether to use the new Sw value or take the existing water saturation value.
• n17—using the SimpleExpression compresses the decision making logic to a 

single node.

The logic for the n17 node can be diagrammed with each indentation level signifying a 
subordinate If-then-else structure (with PowerLog curves VCL, PHIE, and SW):
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Rock physics formulas
The Rock Physics Formulas group implements four expressions for elastic moduli:

• Poisson’s ratio (n20 and n26)— ν = (1/2) [ (Vp/Vs)2 - 2] / (Vp/Vs)2 - 1 ) 
• λρ and µρ (n18, n19, n23, and n24)—

µρ = Vs
2ρ2 * Z_Conversion, where Z_Conversion converts to metric units

λρ = Vp
2ρ2 * Z_Conversion - 2*µρ 

• Youngs Modulus (n21, n22, n25, and n27)— 
E = ρ*Vs

2 * [ (3*Vp
2 - 4*Vs

2) / (Vp
2 - Vs

2 ) ]
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RP Properties for AVO Checks
The RP Properties for AVO Checks workflow uses density, acoustic log, and shear 
velocity log to calculate elastic constants that are useful in checking direct 
hydrocarbon indicators. Goodway et al. [15] suggested that Lamé’s elastic parameters 
λ and µ, and their products with density, can be useful tools in AVO analysis.

In particular, λ*ρ is very sensitive to fluids, while µ*ρ has little variation within the 
reservoir zone. Smith and Gidlow [35] plotted Castagna and Smith’s [9] set of 25 
world-wide measurements of P- and S-wave velocities and densities. Cross-plot 
domain representations of 25 shale/brine sand, shale/gas sand, and gas sand/brine- 
sand sets using Vs vs. Vp crossplots and µρ vs. λρ crossplots clearly showed the 
distinction between gas-sands and non-pay lithologies,

Objectives
The RP Properties for AVO Checks workflow:
• Provides standard calculations of Vp and Vs velocities along with the acoustic 

impedance I =  Vpρ and shear impedance J = Vsρ. for:
– Corrected acoustic ∆tp, shear ∆ts, and density logs
– Identify wet sand acoustic ∆tp, shear ∆ts, and density interval
– Raw acoustic ∆tp, shear ∆ts, and density logs

• Calculate effective porosity based on measured volume of clay
• Calculate elastic moduli for bulk modulus (K), shear modulus (µ), Young’s 

modulus (E), Poisson’s ratio (ν), shear modulus*density product (µρ), and Lamé’s 
constant*density product (λρ).

• Illustrate how to restrict the range of a petrophysical curve values so that Vp/Vs 
ratios are reasonable. Curve values that exceed the range for ∆ts result in Vp/Vs 
points that are undefined (UNDEF).

Computed results
These PowerLog output curves are created when the entire workflow is calculated.

Table 14. RP Properties for AVO Checks Workflow - output curves

Node Curve 
Name

Type and Units Description

n12 Vp p_velocity ft/sec Acoustic velocity - corrected

n13 Vs s_velocity ft/sec Shear velocity - corrected

n14 VpVscor any none Vp/Vs ratio, calculated from Vp and Vs corrected

n16 Zp_cor any none Acoustic impedance - corrected

n17 Zs_cor any none Shear impedance - corrected

n21 Lithfrac any none Lithology fraction

n22 Phi_eff any none Effective porosity

n8 Vp_wet p_velocity ft/sec Acoustic velocity - wet sand
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PowerLog input curves
These PowerLog input curves are used to calculate the acoustic velocity and 
impedance, as well as the shear velocity and impedance. This workflow can use the 
corrected sonic and density logs, plus the raw logs for its Vp/Vs ratio calculations. The 
corrected density and velocities are used to calculate the three elastic moduli 
(Young’s, bulk, and shear), plus Poisson’s ratio and two AVO-related hydrocarbon 
indicators.

Hint For your well, you may need to modify the curve names or replace them with a 
convenient curve alias name. The curve names in the this table are from the tutorial 
RP_Properties_for_AVO_Checks_Workflow project.

n9 Vs_wet s_velocity ft/sec Shear velocity - wet sand

n10 Zp_wet any none Acoustic impedance - wet sand

n11 Zs_wet any none Shear impedance - wet sand

n18 Poisson any none Poisson’s ratio

n19 MuRho any none µρ hydrocarbon indicator

n20 LameRho any none λρ hydrocarbon indicator

n34 E_cor any N/m2 Young’s modulus - corrected

n35 K_cor bulk_modulus
N/m2

Bulk modulus - corrected

n36 Mu_cor shear_modulus
N/m2

Shear modulus - corrected

n39 VpVs_raw any none Vp/Vs ratios from raw curves, where Vs was limited 
to specific range defined by the named constants: 
Min_shear_tdel to Max_shear_tdel.
Vs values outside this range yield an undefined value 
for the corresponding Vp/Vs ratio.

Table 15. RP Properties for AVO Checks Workflow - input curves

Node Curve Name Type and Units Description

n0 DTC p_sonic µsec/ft. P-sonic corrected

n1 RHOC density g/cc Density corrected

n2 DTS s_sonic µsec/ft. S-sonic corrected

n3 PHIT porosity none Total porosity

n4 VCL any none Volume of Wet Clay

Table 14. RP Properties for AVO Checks Workflow - output curves (Continued)

Node Curve 
Name

Type and Units Description
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Named Constants
The RP Properties for AVO Checks workflow uses these named constants:
• Convert_Impedance_to_Metric—92903.4
• Max_shear_tdel—300 µsec/ft.
• Min_shear_tdel—100 µsec/ft.

Key workflow functions and formulas
• n8, n9, n12, n13, n26, n28—these workflow nodes implement the simple

division to convert a sonic log to the corresponding velocity values using the for-
mula: Velocityx_curve = 1000000 / ∆tx, where x = p (acoustic), x = s (shear)

• n10, n11, n16, n17, n29, n30—these workflow nodes calculate the acoustic
or shear impedance, using the product of the velocity and density curves:
Zx_curve = Velocityx_curve * ρcurve, where x = p (acoustic), x = s (shear)

• n18—Poisson’s ratio computed using ν = (1/2) [ (Vp/Vs)2 - 2] / (Vp/Vs)2 - 1 ) 
• n19—MuRho product = µρ = Vs

2ρ2 * Convert_Impedance_to_Metric
• nn20—LambdaRho product = λρ = Vp

2ρ2 * Convert_Impedance_to_Metric - 2*µρ 
• n22—ϕeff_curve = (1 - Vclaycurve) * PHITcurve 

• n34—Young’s modulus E = ρ*Vs
2 * [ (3*Vp

2 - 4*Vs
2) / (Vp

2 - Vs
2 ) ]

• n35—Bulk modulus K = KFromVel ( Vp, Vs, ρ )
• n36—Shear modulus µ = MuFromVel ( Vs, ρ )
• n39—Vp/Vs measured = Vp/Vs , if Min_shear_tdel ≤ ∆ts ≤ Max_shear_tdel

otherwise Vp/Vs measured = UNDEF_POWERLOG

n5 DTC p_sonic µsec/ft. P-sonic (wet)

n6 RHOC density g/cc Density (wet)

n7 DTS s_sonic µsec/ft. S-sonic (wet)

n23 DT_raw p_sonic µsec/ft. P-sonic (raw) - uncorrected

n25 RHOCraw density g/cc Density (raw) - uncorrected

n24 DTS_raw s_sonic µsec/ft. S-sonic (raw) - uncorrected

Table 15. RP Properties for AVO Checks Workflow - input curves (Continued)

Node Curve Name Type and Units Description
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Fluid properties to estimate Vs
The Fluid properties to estimate Vs workflow calculates the density and bulk modulus 
for the subsurface fluids (brine, oil, and gas) as a function of:
• Pressure
• Temperature
• Salinity
• Oil and gas gravity
• Gas oil ratio

Objectives
The Fluid properties to estimate Vs workflow shows you:
• How to use conditional logic (named constant and ConditionalExpression func-

tion) to select between a PowerLog curve and a constant as an input parameter.
• Compute density and bulk modulus using the Brine, Oil, and Gas functions.
• Use named constants as physical parameters and as workflow logic switches.
• Select the oil or gas properties as the dominant hydrocarbon, using the 

ConditionalExpression function.

Computed results
These PowerLog output curves are created when the entire workflow is calculated. 
Additionally, when a PowerLog curve is selected for use, the mean value of the 
calculated curves is also determined in the workflow.

Hint If you do not want to add the mean calculation nodes to your workflow, you can use 
the F8 (Calculate workflow) command to calculate the workflow. Once it finishes, you 
can place the mouse on each of the Curve Nodes in the next table. For each node, the 
function is shown in a tool tip and the node output curve name, mean value, and 
number of defined samples is displayed in the status bar. See Figure: 87, ‘Status 
bar”, on page 146.

Table 16. Fluid properties to estimate Vs workflow - output curves

Curve 
Nodes

Curve 
Name

Mean
Nodes

Type and Units Description

n7 Salinity n12 salinity ppm Salinity input

n13 D_brine n21 density g/cc Density of brine

n14 K_brine n22 modulus N/m2 Bulk modulus of brine

n15 Den_gas n23 density g/cc Density of gas

n16 K_gas n24 modulus N/m2 Bulk modulus of gas

n17 Den_oil n25 density g/cc Density of oil

n18 K_oil n26 modulus N/m2 Bulk modulus of oil

n19 Den_hydr n27 density g/cc Selected hydrocarbon density

n20 K_hydr n28 modulus N/m2 Selected hydrocarbon bulk modulus
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PowerLog input curves
These six PowerLog input curves are used to compute the density and bulk modulus 
of the fluid properties.

Hint For your well, you may need to modify the curve names or replace them with a 
convenient curve alias name. The curve names in the this table are from the tutorial 
Fluid_properties_to_estimate_Vs project.

Named constants
The named constants for the Fluid properties to estimate Vs workflow consists of two 
groups; one set for physical fluid properties and the other to control the workflow 
computations.

Table 17. Fluid properties to estimate Vs workflow - input curves

Node Curve Name Type and Units Description

n0 PRES pressure psi Pressure of formation

n1 T temperature degF Downhole temperature

n2 Sal salinity ppm Brine salinity

n3 API oil api Oil gravity

n4 SPEC any api Gas specific gravity

n5 GOR any none Gas oil ratio

Table 18.  Fluid properties to estimate Vs workflow - named constants

Constant Name Value Units Used in 
nodes

Salinity_brine 72000 ppm n7

Oil_gravity 43 api n8

Gas_specific_gravity .65 none n10

Gas_oil_ratio 15000 none n11

Constant Name used as
conditional logic flag

Value Units Used in 
nodes

Salinity_LogOrConstant 1 = Log, else constant none n7

Oil_grav_LogOrConstant 1 = Log, else constant none n8

Gas_grav_LogOrConstant 1 = Log, else constant none n10

GasOilRatio_LogOrConstant 1 = Log, else constant none n11

Hydrocarbon_gasoil_select 0 = Gas, otherwise oil none n19, n20
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Key workflow functions and formulas
Most of the functions used in the Fluid properties to estimate Vs workflow, are the 
Brine, Oil, and Gas functions (see online help from each of the workflow nodes). 

The ConditionalExpression function:
• Selects between a PowerLog curve and a constant value for salinity, oil gravity, 

gas specific gravity, and the gas-oil ratio inputs.
• Selects between the computed oil and gas constants (hydrocarbon density and 

bulk modulus) for this workflow calculation.

The Brine, Oil, and Gas functions used in this workflow are:
• n13—ρbrine = BrineRho (Pressure, Temp, salinitiy)
• n14—Κbrine = BrineK (Pressure, Temp, salinitiy)
• n15—ρgas = GasRho (Pressure, Temp, spec, Batzle&Wang)
• n16—Κgas = GasK (Pressure, Temp, spec, Batzle&Wang)
• n17—ρoil = LiveOilRho (Pressure, Temp, oil_api, Rs, spec, blank, 

Batzle&Wang)
• n18—Κoil = DeadOilK (Pressure, Temp, oil_api, Batzle&Wang)

The general form for the Conditional logic that selects a curve or constant is:
if (curvename_LogOrConstant == 1) then Curve, else Constant

The form for the Conditional logic that selects gas or oil is:
if (Hydrocarbon_gasoil_select == 0) then Gas, else Oil
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Lithology log construction
Petrophysicists construct lithology logs using many combinations of measured logs to 
infer geology and potential production zones. This RPM for PowerLog workflow uses 
six input PowerLog curves to construct a lithology coding log.

Objectives
The Lithology log construction workflow:
• Illustrates how a lithology log can be constructed by replacing petrophysical log 

measurements with rock physics parameters.
• Describes how to use name constants and RPM functions to define complex 

logical expressions.

Computed results
The Lithology log construction workflow result is a single PowerLog curve 
(LITHTYPE, N26) with lithology coding. The values are coded in the Table 20, 
“Lithology log construction workflow - named constants,” on page 111.
• 0 = shale (default)
• 1 = calcareous shale
• 2 = limestone
• 3 = coal
• 4 = sand
• 5 = gas sand

PowerLog input curves
Hint For your well, you may need to modify the curve names or replace them with a 

convenient curve alias name. The curve names in the this table are from the tutorial 
Lithology_log_construction_workflow project.

Named constants
The Lithology log construction workflow uses two sets of named constants; one to 
specify the decision making constants and another to implement the lithology coding.

Table 19. Lithology log construction workflow - input curves

Node Curve Name Type and Units Description

n0 VCLC any none Volume of calcite relative to total volume 
(correct shale velocity)

n1 VCOA any none Volume of coal relative to total volume

n2 VCL any none Volume of clay relative to total volume

n3 VQUA any none Volume of quartz relative to total volume

n4 PIGE any none Effective porosity minus irreducible water

n5 Sw Sw none Water saturation
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Throughout the conditional logic nodes in the Lithology log construction workflow, 
these values are used. If you want to extend these indicators, create additional named 
constants similar to the ones in the previous table.

Key workflow functions and formulas
Within these workflow nodes you can use either the ConditionalExpression or 
SimpleExpression functions to implement the decision logic. When multiple 
conditions must be combined (nodes n17, n18, and n19), set the output of each 
separate condition equal to 1 and test to see that all conditions (node n20) are true:

• n12— If (all curve samples not UNDEF) then LITHTYPE = Shale_lith, else UNDEF
• n15— If (Volcalcite ≥ Min_calcite_volume) then LITHTYPE = Limestone_lith
• n16— If (Volcoal ≥ Min_coal_dominates) then LITHTYPE = Coal_lith
• n17, n18, n19, n20— If (Volclay ≥ Min_clay_volume ) AND

( Volcoal ≥ Min_coal_volume ) AND ( Volquartz ≤ Min_clay_volume ) then 
LITHTYPE = Calcareous_shale_lith

• n21, n22, n23— If ( Volquartz ≥ Min_quartz_volume ) AND
( PIGE ≥ Min_porosity_effective) then LITHTYPE = Sand_lith

• n24, n25, n26— If ( LITHTYPE = Sand_lith ) AND (Rw ≤ Max_Sw_gassand)
then LITHTYPE = GasSand_lith

Table 20.  Lithology log construction workflow - named constants

Lithology coding constants Value Units Used in nodes

Shale_lith 0 n/a none

Calcareous_shale_lith 1 n/a n20

Limestone_lith 2 n/a n15

Coal_lith 3 n/a n16

Sand_lith 4 n/a n23

GasSand_lith 5 n/a n26

Conditional logic constants Value Units Used in nodes

Min_calcite_volume .45 none n15

Min_coal_dominates .5 none n16

Min_clay_volume .4 none n17

Min_coal_volume .1 none n18

Min_quartz_dominates .5 none n19

Min_quartz_volume .45 none n21

Min_porosity_effective .08 none n22

Max_Sw_gassand .7 none n25
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Gassmann fluid-substitution to predict seismic response
The Gassmann fluid-substitution to predict seismic response workflow performs a 
hydrocarbon fluid substitution for the original brine in reservoir rocks so that the 
resulting velocity change can predict the seismic response of oil or gas in a reservoir. 
The Sw measured in the logs describes the original fluid composition.

Fluid substitution criteria
The workflow dynamically determines whether to perform the fluid substitution:
• For rocks with good porosity and low clay content (reservoir rocks), you perform a 

fluid substitution that reduces Sw to a lower level, thus increasing the hydrocarbon 
content.

• For rocks that do not meet the porosity and clay content criteria (non-reservoir 
rocks), the original Sw log is retained and no fluid substitution takes place.

The cutoff for wet clay content (Vclay) in good reservoirs is found in named constant, 
Vol_clay_max. The Vclay maximum is initially set at 0.20, but can be adjusted.The 
cutoff for effective porosity (PHIE) in good reservoirs is found in the named constant 
Phi_effective_max. You can change the value (effective porosity maximum = 
0.05) by editing the named constant.

Thus rocks with Vclay < 0.2 and PHIEcurve >0.05 are considered reservoir rocks and 
fluid substitution is performed in these rocks. Sw in these rocks becomes 0.20, instead 
of the initial value in the Sw curve. The replacement value for Sw is set in the named 
constant Sw_new, and can be adjusted.

Fluid substitution overview
PowerLog Pressure and Temperature logs are used in the Brine, Gas, and Oil 
Properties group to compute the properties of the individual fluids in the borehole.

The properties of the original combined fluid are computed in the Combined Fluid 
Properties (OLD) group. The Water Saturation (Sw_old) node inputs the Sw curve 
from PowerLog, which determines the Sw prior to any fluid replacement. Brie’s formula 
for patchy saturation is used to compute the bulk modulus and density of the combined 
fluid in the Brie’s Formula (OLD) group. The empirical Brie parameter (set to 
one) can be adjusted as the named constant Brie_oldfluid_parameter.

Next, the we compute the elastic parameters for a new fluid (brine in the original fluid 
replaced by hydrocarbons), but only in rocks with good porosity and low clay content. 
The selection of rocks with good porosity and low clay content (good reservoir rocks) 
takes place in the Fluid Substitution Criteria Check group. PowerLog for 
effective porosity, bulk density, (wet) clay content, and velocities are found in the 
Gassmann Inputs group.

The new Sw (the replacement value in reservoir rocks, the old value in all other rocks) 
is computed in the SwFluid Sub node in the Combined Fluid Properties 
(NEW) group. The bulk modulus and density of the replacement fluid are computed in 
this group just like the Combined Fluid Properties (OLD) group. Brie’s patchy 
saturation formula in the Brie’s Formula (NEW) group is used again. The Brie 
parameter is again set to one in the named constant Brie_newfluid_parameter.
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The bulk modulus for the solid matrix is computed from a weighting of the K for clay (in 
the Kclay Fraction node) and the K for quartz (in the Kquartz Fraction node). Bulk 
modulus values for the minerals can be changed by using the Rock and FLuid 
Properties dialog.

Results from workflow
Finally, the Gassmann substitution, using the fluid parameters for the substituted fluid 
(which differ only in the reservoir rocks) is computed in the Gassmann FluidSub 
node. The rock density with the new fluid, P-sonic travel time, acoustic velocity 
(GassmannFull function), and impedance are calculated in the final workflow nodes.

Data consistency issues
Caution! There is sometimes a data-consistency issue with GassmannFull function in the 

Gassmann FluidSub node if input logs for the original rock (before the fluid substitu-
tion) are not sufficiently consistent with the relationship: K = Vp

2 * ρ – 4/3*µ,
where µ = Vs

2 * ρ and Vp, Vs, and ρ are calculated from log petrophysical analysis.

Bulk modulus K is independent of the input parameters for the densities and bulk and 
shear moduli of the mineral and fluid constituents of the rock-physics model. But K and 
the constituents of the model are used together in the Gassmann formula to calculate 
the bulk modulus of the rock with the initial fluid removed (the dry frame), and with a 
replacement fluid. 

Problems in the Gassmann calculation can occur if the rock-physics model chosen is 
not consistent with the ρ, Vp, and Vs data from the logs (in other words, if the model 
just is not a good match for the rocks in the well), or if the log ρ and velocity data are 
not internally consistent. If such inconsistencies are present, the GassmannFull 
function displays error messages and stops before producing an output curve.

These parameter conditions produce error messages:
• K ≤ 0, produces the error “Input bulk modulus illegal”
• Kdry (the bulk modulus of the rock frame without fluid), calculated from 

Gassmann’s formula using K ≤ 0, or greater than K for the mineral members, 
produces the error “Calculated empty frame modulus illegal”.

Objectives
The Gassmann fluid-substitution to predict seismic response workflow:
• Dynamically tests Vcl to see if the clay content is too high and ensures the effective 

porosity exceeds a minimum level before performing a fluid substitution at each log 
depth.

• Uses Brie’s formula to compute the bulk modulus (K) and density (ρ) of the 
combined fluid for the brine in reservoir rocks. It independently use’s Brie’s formula 
for patchy saturation again to compute K and ρ for the oil or gas replacement.

Computed results
The Gassmann fluid-substitution to predict seismic response workflow results permit 
you to predict appropriate seismic velocities and impedance.
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Strategies
To perform the fluid substitution effectively:
• Elastic properties (bulk modulus and density) of the original fluid, composed of 

brine (plus some gas or oil) are computed.
• A Gas/Oil conditional logic named constant group to chooses gas or oil (oil may 

contain gas) in the original fluid.
• Elastic parameters for a new fluid (much of the brine in the original fluid is replaced 

by hydrocarbons) are computed for rocks with good porosity and low clay content.
• The cutoffs for Vclay and ϕeff porosity are defined; Vclay cutoff is initially = 0.20 and 

the initial value for the PHIE cutoff = 0.05.
• The new Sw (the replacement value in reservoir rocks, the old value in all other 

rocks) is computed in the SwFluid Sub node.
• The bulk modulus for the solid matrix is computed from a weighting of the K for 

clay.
• The Gassmann substitution, using the fluid parameters for the substituted fluid 

(which differ in the reservoir rocks), is done in the Gassmann FluidSub node.

PowerLog input curves
These PowerLog input curves are used to calculate the brine, gas, and oil properties. 
The water saturation curve is used in the Brie’s patchy saturation formula and to 
compute the density fraction of brine and hydrocarbons. The total porosity and Vclay 
curves are inputs to the fluid substitution and Kmineral groups.

Hint For your well, you may need to modify the curve names or replace them with a 
convenient curve alias. The curve names in the previous table are from the tutorial 
Gassmann_fluid_substitution_predict_seismic_response project.

Table 21. Gassmann fluid-substitution to predict seismic response workflow - output curves

Curve 
Nodes

Curve 
Name

Type and Units Description

n30 SW_NEW Sw none Water saturation curve - taking into 
account the new fluid substitution

n36 Den_fsub density g/cc Bulk density with replacement fluid

n37 Vp_fsub P-velocity ft/sec Velocity for hydrocarbon substitution

n38 Sonic_fs p_sonic µsec/ft. ∆tp for hydrocarbon substitution

n39 Zp_fsub any none Acoustic impedance

Table 22. Gassmann fluid-substitution to predict seismic response workflow - input curves

Node Curve Name Type and Units Description

n1 PRES pressure psi Pressure of formation

n2 T temperature degF Downhole temperature

n3 SW Sw none Water saturation
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Named Constants and Mineral Properties
This table displays the named constants, clay and quartz bulk modulus, and the 
conditional logic switch (Gas_oil_selection) for gas and oil.

n4 PHIE porosity none Effective Porosity

n5 VCL any none Volume fraction of clay relative to total volume

n6 RHOC any none Bulk density - measured

n7 Vpcalcr p_velocity ft/sec Vp log

n8 Vscalcr s_velocity ft/sec Vs log

Table 23. Gassmann fluid-substitution to predict seismic response workflow - named constant 
and rock/fluid properties

Name Value Units Used in these workflow nodes

Brine_salinity 150000 ppm n13, n14—concentration in ppm

Gas_specific_grav .07 none n9, n10, n11, n12— Gas spec-grav

Gas_oil_ratio 44 none GOR (Gas Oil Ratio)

GOR_conversion 5.615 none Factor compute dimensionless Rs

Oil_API 33 api n11, n12—oil density

Gas_oil_selection 0 - Gas
else Oil

none n18, n19—select which hydrocarbon to 
use in the fluid computations

Brie_oldfluid_
parameter

1 none n24—Brie exponent for old fluid patchy 
saturation computation

Brie_newfluid_
parameter

1 none n34—Brie exponent for new fluid patchy 
saturation computation

Phi_effective_min .05 none n22—minimum porosity needed for fluid 
substitution

Vol_clay_max 7 none nxx, nxx—maximum clay volume 
allowed for fluid substitution

Rs_dimensionless 7.83615 none n11, n12—GOR dimensionless value

Sw_new .2 none n21—Sw replacement value

Clay.K 2.091e10 N/m2 n15—clay bulk modulus

Quartz.K 3.789e10 N/m2 n16—quartz bulk modulus

Table 22. Gassmann fluid-substitution to predict seismic response workflow - input curves 

Node Curve Name Type and Units Description
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Key workflow functions and formulas
• n09—ρgas = GasRho13 (Pressurecurve, Temperaturecurve, Gas_specific_grav, 

Batzle&Wang)
• n10—Kgas = GasK (Pressurecurve, Temperaturecurve, Gas_specific_grav, Batzle&Wang)
• n11—ρoil = LiveOilRho (Pressurecurve, Temperaturecurve, Oil_API, Rs_dimensionless, 

Gas_specific_grav, blank, Batzle&Wang)

• n12—Koil = LiveOilK (Pressurecurve, Temperaturecurve, Oil_API, Rs_dimensionless, 
Gas_specific_grav, blank, Batzle&Wang)

• n13—Kbrine = BrineK (Pressurecurve, Temperaturecurve, Brine_salinity)
• n14—ρbrine = BrineRho (Pressurecurve, Temperaturecurve, Brine_salinity)
• n15—Kclay_frac = Vcl * Clay.K
• n16—Kquartz_frac = (1-Vcl) * Quartz.K
• n17—Kmineral = Kclay_frac + Kquartz_frac

• n18—KHC = ConditionalExpression( Gas_oil_selection, ==, 0, Kgas , Koil ) 14

• n19—ρHC= ConditionalExpression( Gas_oil_selection, ==, 0, ρgas, ρoil )
• n20—ρBrine_frac_(old) = ρbrine * SWcurve
• n21—Vclay test = ConditionalExpression( Vcl_curve, <, Vol_clay_max, 1, 0 )
• n22—ϕeff test = ConditionalExpression( ϕeff _curve, >, Phi_effective_min, Vclay test, 

0 )
• n23—ρHC_frac_(old) = ρHC * (1 - SWcurve)
• n24—KBrie_(old)= ( Kbrine - KHC ) * SWcurve ** Brie_oldfluid_parameter
• n26—No Fluid Sub = (1 - ϕeff test)* SWcurve [use Sw old]
• n27—Fluid Sub = (ϕeff test)*Sw_new [use Sw new]
• n28—ρfluid_(old) = ρHC_frac(old) + ρBrine_frac_(old)
• n29—Kfluid_(old) = KHC + KBrie_(old)
• n30—SW_NEWcurve = Sw_FluidSub = Fluid Sub + No Fluid Sub
• n31—ρBrine_Frac_(new) = Sw_FluidSub * ρBrine
• n32—ρHC_Frac_(new) = (1 - Sw_FluidSub) * ρBrine
• n33—ρFluid_(new) = ρBrine_Frac_(new) + ρHC_Frac_(new) 
• n34—KBrie_(new) = ( Kbrine - KHC ) * SWcurve ** Brie_newfluid_parameter
• n35—KFluid_(new) = KBrie_(new) + KHC 
• n36—Den_fsubcurve = ρFsub = RHOCcurve + ϕeff * ( ρFluid_(new) - ρFluid_(old) )
• n37—Vp_fsubcurve = GassmannFull (Vpcurve, Vscurve, RHOCcurve, ϕeff, KFluid_(new), 

ρFluid_(new), Kmineral, KFluid_(old), ρFluid_(old) )
• n38—Sonic_fscurve = Psonic - Fsub = 1000000. / Vp_fsubcurve 
• n39—Zp_fsubcurve = Vp_fsubcurve * Den_fsubcurve 

13.Name of the RPM rock physics function used for this node.
14.HC - Denotes hydrocarbon (oil or gas) selected with the ConditionalExpression RPM function for KHC and ρHC.
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Introduction
In RPM, you interact with a Windows application that uses these GUI elements:
• A workflow model user interface
• Main menus
• Shortcut menus (context-sensitive)
• Application Dialogs
• Miscellaneous user interface tools - tool bar, status bar, and tool tips

A workflow model user interface
RPM for PowerLog integrates rock physics calculations using a workflow (a directed 
graph) developed on a screen area (workspace). Unlike a spreadsheet approach, the 
workflow directly reveals the calculation dependencies in the form of ancestors 
(nodes that affect this node’s inputs) and descendents (nodes affected by this node’s 
output). The main user interface is a workflow that shows a directed graph, 
containing nodes (where calculation functions operate) and connections (arrows) that 
determine the calculation dependencies.

Figure 61. Partial RPM workflow example
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Workflow management

Nodes
The node layout can be changed by dragging the node with the mouse to the desired 
location. When a project is saved, the nodes and connections graphical positions are 
also saved. The workflow is redrawn the next time the project is opened with the 
nodes in the new locations. When the nodes are moved, the connections follow the 
nodes to which they are attached. The size of the node is defined by the size of the 
label you define for the node and cannot be customized.

Groups
Nodes can be associated into groups by adding a group defined by drawing a 
rectangle around the desired nodes and dragging them into the group. The group can 
be minimized so that only one box shows in the place of all the nodes in the group. A 
group can be minimized or restored to its original size (see Figure: 62, ‘Group 
minimizing workflow complexity”). You can assigned a very descriptive name to a 
group, which can span several text lines. The group can be moved around as a whole 
and individual nodes can be moved inside the group. Complex workflows can be 
simplified by using groups to manage a related set of nodes.

Context - node, group, connection, workspace
RPM uses the mouse cursor location to define the context of its operations. For 
example, if the cursor hovers over a node, RPM considers the node to be the current 
node and any operation from the node shortcut menu (such as Delete Node) applies to 
that node. The node can also be selected by clicking with the left mouse button (MB1). 
Similarly, if the cursor hovers over a connection line, that line is considered to be the 
current context. This is also true for groups. If the cursor is in the blank area outside of 
any group or node rectangles (that is, the workspace), then the RPM main menus 
apply.

Main menus
Menu functionality is active or inactive, based on the workflow and application context 
in which you select the menus. If a menu does not apply to the current context, it does 
not display in the shortcut menu or is grayed out in the main menus. The RPM 
application contains the File, Edit, Data, Calculate, View, and Help menus.

Figure 62. Group minimizing workflow complexity
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Keyboard shortcuts used in RPM for PowerLog
Note In the next six menu sections, the keyboard shortcuts (next to each menu command 

on the menus) corresponding to the RPM menu commands are displayed in brackets.

Example The keyboard shortcut combination for the File > New Project command is 
[Ctrl+N], that is, the Ctrl (Control) and N key pressed together.

For Windows XP, you can selectively hide or display the underlined menu letters that 
designate the shortcuts.

To display the Windows XP keyboard accelerator underlined items
1 Select an unused area of the Windows XP desktop, right-click (MB3), and select 

the Properties command from the shortcut menu.
2 When the Display Properties dialog shows, select the Appearance tab.
3 Click the Effects button.
4 When the Effects dialog displays, un-select the check box with the label Hide 

underlined letters for keyboard navigation until I press the Alt key.
5 Click OK twice.

File menu

• New Project [Ctrl+N]—creates a new project; building new RPM project, node, 
and graphic workflow files with the project name you typed.

• Open Project [Ctrl+O]—opens a previously saved RPM project, plus the 
corresponding graphic workflow, and node files.

• Save Project [Ctrl+S]—saves the data for the current RPM project in its current 
files.

• Save Project As [Alt+F+A]—saves the current project file as a different name. It 
does not change the project name stored within the file and is used primarily to 
make a backup copy. of the RPM

Figure 63. File menu
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• Print Workflow—sends a graphic workflow image to one of your printers.
• Most Recently Used (MRU) List [Alt+F+1,2,3,4,or 5]—provides quick 

access to the five most recently used RPM project files.
• Exit [Alt+F+X]—exits the RPM software. You are prompted to save data if you 

made changes to the workflow or functions.

Note Once a project is defined or opened, the Edit, Data, Calculate, View, and Help 
application menus become active.

Edit menu

The Edit menu helps you develop and build the workflow model in the workspace with 
several features, operations, and preferences:
• Undo [Ctrl+Z]—undoes the last workflow operation, such as deleting a node.
• Redo [Ctrl+Y]—redoes the last workflow operation after you selected an Undo 

operation.
• Refresh [F5]—redraws the currently displayed workflow.
• Reconnect [F6]—redraws all the connections for the current workflow.
• Erase Workflow [Ctrl+E]—erases the entire workflow.

Note The workflow can be restored by reopening the workflow prior to saving any project 
changes or by using the Undo command.

• Add Node [Ctrl + Keypad “+”]—adds a single node when you click a 
workflow location. You use this command each time to create an individual node.

• Define Group [Ctrl+G]—draws a rectangle around a group of nodes. This is 
useful for grouping nodes together that have a related workflow goal. Helps to 
minimize the number of graphic elements in a complex workflow.

• Preferences [Alt+E+P]—changes drawing characteristics (colors, line sizes, and 
so forth) for the workflow. Changes can apply to a specific node or to all the nodes 
by selecting the Apply to existing nodes check box. 

Figure 64. Edit menu



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 123

RPM User Interface Main menus

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

• Set Workspace Size [Alt+E+W]—sets the size of the screen on which to draw the 
workflow. If the current workflow is truncated at its edges, resizing to a larger 
workspace size can fix the problem. The invalid area is shown by crosshatching in 
the background. The current size of the workspace is displayed in the status bar.

Note Setting the workspace size is critical for printing the workflow because the workflow 
size controls the scaling of the hardcopy image.

Data menu 
The Data menu displays dialogs for defining specifics about the node or the project, or 
to examine the curves defined in PowerLog for the currently selected well:
• Set Mix Defaults [Ctrl+M]—sets the end members, fluid type, and the algorithm 

to use for mixing of curves. These mixing defaults are used in many functions 
when optional parameter values are not specified directly by the user. The 
parameters come from the mineral members Rock and Fluid properties. 15

• Constants [Ctrl+C]—displays a list of named constants which can be 
customized to the particular needs of your current project.

• Rock Fluid Properties [Ctrl+K]—displays a list of rocks, minerals, gases, and 
fluids, along with their properties, which can be customized to the particular needs 
of your current project.

• Curve List [Ctrl+L]—displays the curve names curves available for the current 
well selected in PowerLog. The curve list is updated dynamically when a new 
curve is created in PowerLog.

• Curve Alias List [Ctrl+A]—displays the Curve Alias List from PowerLog. This 
displays log curve name aliases you can use for curve names that vary from well to 
well. Used for designing flexible workflows that can access the different curve 
names, when using a different well.

Calculate menu

• Calculate Workflow [F8]—calculates all nodes in the current project workflow.
• Block Curve Overwrite Warnings [Ctrl + Keypad “-”]—a check box to turn 

off the overwriting curves check. This is useful when you recalculate the entire 
workflow. The status of this check box displays in the lower right on the status bar. 

15.Currently only the Xu-White Approximation algorithm is defined.

Figure 65. Calculate menu



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 124

RPM User Interface Main menus

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

If the item is checked, OVR (overwrite) displays in the status bar area (left of the 
workspace size) and the overwrite confirmation for each PowerLog curve does not 
display.

• Show Node Process Order [Ctrl+V]—prior to calculating the entire workflow, 
RPM can display the sequence in which the nodes are calculated. You can use this 
as a preliminary validation that your workflow sequence is correct. Select this 
command if you want to see the Node Process order display.

• Output Log [Ctrl+/]—receives internal status messages generated by the RPM 
application. These messages show calculation errors and helps you see which 
nodes may require additional work.

• Curve Fitting [Ctrl+T]—displays the Curve Fit dialog that helps you 
approximate a curve with one of the RPM function outputs. With this dialog you 
identify the (1) node with the function to approximate the curve, (2) curve to be 
approximated, and (3) the input parameter value ranges to use.

• View Curve Fitting Log File [Ctrl+W]—displays a file describing in detail the 
curve fitting algorithm computation parameters and iterative computation results.

Note The Block Curve Overwrite Warnings setting remains the same until you change the 
setting. That means, if you exit the RPM for PowerLog application, this setting is 
remembered from one RPM session to another.

Note If you display the Output Log dialog and calculate a part or all of your workflow, the 
messages display in the Output Log dialog only. Individual error alerts do not display. 
If you want to see the individual alerts, close the Output Log dialog box.

Note You can copy-and-paste Output Log messages into other Windows applications using 
standard Windows commands.

Hint These messages can assist the technical support team to provide you provide better 
customer assistance, when you have a question or issue.

View menu

• Find Node [Ctrl+F]—finds and highlights a specific node in the workflow.
• Select Path [Ctrl+P]—highlights all nodes in the path between a starting and 

ending node to define a calculation sequence. You must first select this command, 
then click the beginning and ending nodes to define a calculation path. If there is 
no path between them, a message box warning displays.

Figure 66. View menu
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• Show Descendents [Ctrl+D]—highlights the nodes that are dependent upon 
(descendents of) a chosen node’s output calculation.

• Show Ancestors [Ctrl+R]—highlights the ancestor nodes that provide 
calculation inputs upon which a chosen node depends.

• Clear Selections [Ctrl+I]—removes all highlighting of the selected path or 
nodes.

Help menu
Help menu (Figure: 67, ‘Help menu for RPM for PowerLog”) provides you access to 
the online RPM for PowerLog documentation. Documentation is formatted as standard 
user guides (Adobe Acrobat files) and online HTML help.

• User Guide[F1]—displays the Acrobat online guide describing the RPM 
workflows, user guide, user interface, plus available functions and their usage. 
Examples of function calculations are provided.

• Function Reference—displays HTML help (Internet Browser window) that 
provides an explanation for every RPM function and its example usage.

• Frequently Asked Questions [Alt+H+Q]—displays an Acrobat PDF file providing 
answers to common questions and workarounds required by customers.

• Create Problem Report [Alt+H+P]—starts the Microsoft Word application and 
uses the RPM Problem Report template to help you report an RPM difficulty. You 
can save the Problem Report document, attach it to an email, then send a request 
to the Fugro-Jason support team.

• Printable Documentation [Alt+H+D]—displays a cascading menu that provides 
you a way to display the RPM for PowerLog documentation with Acrobat Reader. 
Once displayed, you can print sections of each document or search each online 
document for information. You can display and print the:
– Quick Reference Card
– User Guide (this document)
– Function Reference Guide
– Getting Started Guide
– Tutorial Workflows
– Problem Report Form

• About [Alt+H+A]—displays the RPM software version number and source code 
build date used to create this version of RPM for PowerLog. Technical support 
contact information (telephone, email, and fax numbers) is listed in this dialog.



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 126

RPM User Interface Shortcut menus

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Hint Please supply the RPM software version number and source code build date to help 
Fugro-Jason provide you with superior customer support, whenever you have a ques-
tion or issue.

Shortcut menus
Shortcut menus display when you click the third mouse button (MB3) or right-click in a 
specific area of the RPM application. These four shortcut menus are context-sensitive, 
that is, the menus contain only those commands or dialogs appropriate for this RPM 
workflow element.

Node shortcut menu

Right-click (MB3) over a node to display this shortcut menu:
• Edit Node—displays the current function definition for a node. The Function 

Selection dialog can also be opened by double-clicking on the node.

Figure 67. Help menu for RPM for PowerLog

Figure 68. Node shortcut menu
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• Delete Node—deletes the node currently under the mouse cursor. A delete can 
also be done using the delete key.

• Change Color—displays the Color Selection dialog to help the user to define an 
existing or custom color for the node. This is useful in highlighting certain functions 
or areas of commonality in the workflow.

• Show Descendents—highlights the nodes that depend upon (descendents of) a 
chosen node’s output calculation.

• Show Ancestors—highlights the ancestor nodes that provide calculations upon 
which a chosen node depends.

• Clear Selections—removes the highlighting of the selected path and nodes.
• Calculate...

– Calculate Node—calculates the function defined for the current node. If no 
function is defined, a message box displays to alert you. Errors are reported 
and the calculation result is displayed in the status bar.

– Calculate Workflow—calculates all workflow nodes by using a sorting algo-
rithm; so that dependencies are calculated first and then all subsequent nodes 
are calculated in order.

– Calculate Path—performs computations for the nodes in the selected path.
– Calculate Group—performs computations for the nodes in the selected group.

Connection shortcut menu
Right-click (MB3) over a connection to display this shortcut menu:
• Change Color—displays the Color Selection dialog to help you define an existing 

color or a custom color for this connection.

Figure 69. Connection shortcut menu
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Workflow shortcut menu

Right-click over a blank part of the workspace to display this shortcut menu. For 
screen shots of these dialogs, See “Application Dialogs” on page 129:
• Add Node—adds a single node when you click on a location in the worksheet. You 

must use this item each time to create a new nodes.
• Define Group—draws a rectangle around a group of nodes
• Find Node—finds and highlights a single workflow node.
• Set Mix Defaults—displays the Set Mix Defaults dialog.
• Constants—displays the Constants dialog where you can define named 

constants for use within the workflow nodes.
• Rock Fluid Properties—displays the Rock and Fluid Properties dialog.
• Curve List—displays the Curve List dialog.
• Curve Alias List—displays the Curve Alias List dialog.
• Curve Fitting—displays the Curve Fit dialog to approximate a curve with another 

RPM function node.

Group shortcut menu

Figure 70. Workflow shortcut menu
if

Figure 71. Group shortcut menu
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Right-click over a group box to display this shortcut menu.
• Edit Group Name—changes the default label that is shown in the group box. This 

name is displayed in the group box when it is minimized. The name can wrap and 
be several lines in length to describe this group’s function.

• Release Group—removes a group from the workflow.
• Change Color—displays the color selection dialog to help you define an existing 

color or a custom color for the group box background.
• Calculate—performs calculations for the:

– Node
– Workflow
– Path
– Group

Application Dialogs
The RPM for PowerLog dialogs help you organize information, customize your display, 
and specify calculations for each node of the workflow. These dialogs include:
• Preferences dialog
• Select color dialog
• Workspace Size dialog
• Function Selection dialog
• Set Mix Defaults dialog
• Rock Fluid Properties dialog
• Constants dialog
• Curve List dialog
• Output Log dialog
• Curve Alias List dialog
• Curve Fit dialog

Preferences dialog
This dialog helps you to select preferences for the workspace, nodes, connections, 
groups, and paths such as line width and default colors. If you select a node, then 
request the Preferences dialog, the color of the node can be changed by choosing the 
color bar in the Nodes group and picking a new color for the node. If the user wants to 
make all of the nodes the same color, the Apply to existing nodes/groups/
connections check box can be selected. Clicking the OK button saves the changes.
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Figure 72. Preferences dialog
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Select color dialog
This dialog displays when you select a Default Color button on the Preferences 
dialog. It helps you to pick a predefined or custom color for the current context, that is, 
for the current workspace, node, connection, path, or group.

You can select standard colors or specify a custom color by:
• Typing in values for Red, Green, and Blue to specify the color.
• Typing in values for Hue, Saturation, and Val (lightness) to specify the color.
• Moving the cross-hair cursor to the desired color in the spectrum display.

Figure 73. Select Color dialog



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 132

RPM User Interface Application Dialogs

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

Workspace Size dialog
This dialog displays when you choose the Edit > Workspace Size menu command. 
You can choose a desired size for the workspace (canvas where you draw the 
workflow), where the workflow is drawn. You also have an option to specify a non-
standard workspace size. This option is very useful when you print a hardcopy of the 
workflow (see “File menu” on page 121). The chosen size displays in the lower right-
hand corner of the main window in the Status bar.

Figure 74. Workspace Size dialog
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Function Selection dialog
This dialog provides all the centralized functionality necessary to change the 
calculation performed at a node. With this dialog, you select the function, define inputs 
parameters, specify the output (and sometimes the type), and supply a node name. 
The Function Type must be chosen first, followed by the specific Function in that 
category. The function name can be selected in the Function drop-down selection list. 
You can optionally supply a node label or a default label is created for you.

Output curve names
The Output field helps you specify a name for the output curve that is created in 
PowerLog. 

Note The Output curve names used for PowerLog are case insensitive. All PowerLog curve 
names display in capital letters.

Output node numbers
If no curve name is specified, the Node name is used by default. 

Hint Using the Node name for the curve permits the node output to be referenced and 
used by multiple workflow nodes.

Figure 75. Function Selection dialog
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Output units
The output units are specified for the function that is selected. You can change the 
units for situations where the output units are designated as none to the appropriate 
units. This may be necessary if the node is used as input into another calculation 
which requires particular units. Each parameter in the dialog shows the expected units 
for that value.

Note RPM only uses specific unit values and anything entered must conform to the RPM 
standard.

Function types
The RPM for PowerLog function classifications provided are:
• Arithmetic (14)
• Conditional Logic (8)
• Empirical Velocity (5)
• Fluid/Rock Physics for Brine, Gas, and Oil (13)
• Gardner (5)
• Gassmann’s Fluid Substitution (3)
• Greenberg Castagna (4
• Miscellaneous Supporting (5)
• Random Numbers (5)
• Simple Modulus-related (5)
• Statistical (15)
• Three-Phase Media Bounds (3)
• Trigonometric (10)
• Two-Phase Media Bounds (7)
• Velocities for Bounds (4)
• Velocity-Synthesis (3)
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For the selected function, Help is available by clicking on the Help button on the 
Function Selection dialog. (See “Help menu” on page 125) for more details. 

The individual input parameter cells help you choose the parameter values. The cells 
shows mandatory and optional parameters used by the function when it executes. The 
optional parameters may or may not have defaults that are used by the program.

Right-clicking over a value cell displays a shortcut menu. You can select what type of 
node parameter to use and pick a value from the shortcut menu. Curve names are 
always capitalized in PowerLog. Alias curve names start with an ampersand (&).

For a complete list of the RPM functions and their usage, refer to the RPM for 
PowerLog — Function Reference Guide.

Figure 76. Example functions for a single type
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Bulk modulus calculation version [Future Release]
For some of the rock physics algorithms, you can choose which bulk modulus 
calculation algorithm to use. This option displays on the Function Selection dialog 
and the version input parameter. The version selection defaults to Batzle &Wang.

Set Mix Defaults dialog
This dialog helps you choose defaults that are used by the project when calculating 
mixed curves, and when default values are required for optional parameters where the 
user did not specify a value. The two End Member fields have drop-down selection 
lists to help you choose the name of any mineral that is defined in the Rock 
Properties dialog.

Figure 77. Bulk modulus calculation selection

Figure 78. Set Mix Defaults dialog
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The complete list of algorithms available for calculating the members/fluid mix is 
described in “RPM mixing functions” on page 35.

The minerals list includes:
• Anhydrite
• Calcite
• Clay
• Dolomite
• Feldspar
• Quartz
• Pyrite
• Salt
• Siderite

The Pore Fluid drop-down selection list helps you choose the default pore fluid. The 
initial pore fluid list includes:
• Brine
• Water
• Dead Oil
• Live Oil
• Gas

The algorithms which you can choose are described in “Mix algorithms” on page 36.

The values you choose are stored in the project file when the project file is saved and 
also displayed on the title bar of the application. You can refer to this at any time to see 
the current default values.

Rock Fluid Properties dialog
This dialog help you to create (or change existing values for) a new rock, mineral, or 
fluid definitions and values. The values can be saved with the project, so that different 
geographical regions can have regional values. The Rocks, Fluids, and Minerals list 
shows the current list of defined entities. The Rock Fluid Rock and Fluid Properties 
displays three columns, Property Name, Defined Value, and used Units.

Since PowerLog expects US units for all of its operations, US units must be used in 
order to get accurate results. (Exceptions are N/m2 used for bulk and shear moduli 
and g/cc for density values, all other properties are in US units.)
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Entities or Values can be added by clicking the plus (+) button or removed by selecting 
the item and then selecting the minus (-) button. If the changes are not saved, they do 
not propagate to the calculations or are available when the Rock Fluid Properties 
dialog re-displays.

Why rock and mineral properties default differently!
RPM for PowerLog handles minerals and rocks, differently, to the extent of using rock 
property default values differently from mineral property default values. How the 
defaulting mechanism described in the “RPM mixing functions” on page 35, differs 
for minerals and rocks, requires additional explanation.

RPM makes a distinction between minerals (such as quartz and calcite) and rocks 
(sandstone and limestone). Properties unsuitable for minerals (such as original 

Figure 79. Rock and Fluid Properties dialog
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porosity OriginalPorosity) have values that are initially set as undefined 
(UNDEF). Properties unsuitable for rocks (such as the density, Rho, which would imply 
dependencies on other Properties table parameters such as porosity) have values 
which are also initially undefined. From RPM mixing functions, only property values 
associated with minerals (not rocks) can be used as an automatic default in an RPM 
function parameter.

Example If the bulk modulus of a mineral phase is required as input parameter K_1 in 
MixVelocityVp function and the user does not specify a value, the quantity found in 
the Rock and Fluid Properties for mineral1.K is used; as indicated by the tool tip 
displayed when the cursor hovers over the input field. If mineral1 is quartz, then the 
default is quartz.K.

Caution! This automatic default value mechanism does not apply to rocks. There is no specifi-
cation of a default rock or rocks, and rock values are not automatically used from the 
Rock and Fluid Properties if the user leaves the input parameter blank for a rock. 

Example In MixVelocityVp, if the Orig_Poro1 parameter is blank, it cannot default to Origi-
nalPorosity for a rock, such as sandstone, because there is no default rock, and 
cannot default to OriginalPorosity for the default mineral. The user may change 
the UNDEF values for a rock or mineral in the Rock and Fluid Properties to specific 
values, but such property values associated with a rock or mineral are still not used as 
a default if the user leaves an input field associated with a rock blank (as opposed to a 
mineral) in a function. Input fields associated with rocks that are left blank default to 
undefined (UNDEF) values. The documentation and the tool tips indicate which input 
parameters default to undefined values for this reason.

The limitations on automatic defaulting described, do not inhibit your ability to explicitly 
select a rock or mineral value from the Rock and Fluid Properties, rather than 
entering a numerical value, as a rock input for a function.

Constants dialog
This dialog helps you define named constants that can be used in the calculations. It is 
advantageous to define them once and use the constants in multiple calculations. 
Named constants can be added by clicking the Add button and filling in the fields of 
the New Constants Dialog. Constants can be deleted by selecting the value to be 
deleted and then clicking the Delete button. The dialog must be closed with the Save 
button for your changes to be saved. 

Default values can be set as well as the actual value. If the actual value is blank, the 
default is used. The value UNDEF refers to the value -999.0, which is how undefined 
values are denoted in PowerLog.
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Figure 80. Constants dialog
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Curve List dialog
The Curve List dialog shows the current list of curves defined in PowerLog for the 
selected well. Once a function is performed, a new output curve name is dynamically 
added to this list. PowerLog Curve names are always capitalized.

Hint When a node is calculated, it is helpful to refer to the Curve List dialog to see that the 
newly calculated curve is added.

Find Node dialog
This dialog helps you locate a specific node within your workflow. Use the View > 
Find Node command or right-click in any empty workspace area and use Find Node 
shortcut menu command to display this dialog.

Figure 81. Curve List dialog

Figure 82. Node Locator dialog
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Once you select the desired node and click OK, the chosen node displays with a 
flashing color. If the node’s location is outside the current screen display, the 
workspace display shifts left or right to show the node. If a minimized group contains 
the node, the group displays its nodes and the selected node displays with a flashing 
color.

Output Log dialog
The Output Log dialog has several uses within the RPM for PowerLog application:
• Provides a concise summary of the workflow calculations performed. Listed for 

each node is its number, function calculated, and the output curve name.
• Lists error messages that were displayed during the workflow calculation.

Figure 83. Output Log dialog
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Curve Alias List dialog
The Curve Alias List dialog shows the current list of PowerLog project aliases 
defined. Aliases always start with an ampersand (&). Aliases help you in using 
workflows for multiple wells. 

Currently RPM workflows use curves from only a single well at a time. Logs in multiple 
wells with different curve naming conventions can be referenced using common 
aliases. If you want to switch to another PowerLog well in which the curve names 
would be different, the curve alias names in your workflow nodes prevent you from 
having to constantly change curve names.

Figure 84. Curves Alias List dialog
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Curve Fit dialog
The dialog is used by RPM to perform curve fitting; to find the best parameters to 
approximate an Observed Data Node (usually a measured velocity or density curve) 
with an RPM function node (Calculated Node to Fit). The Curve Fit dialog displays 
the parameters from the RPM Function node (Calculated Node to Fit).to permit you 
to set a lower and upper bound for each input parameter variation. You select which 
Calculated Node to Fit input parameters to vary and decide how much variation 
(range between lower and upper bound) to allow.

Figure 85. Curve Fit dialog
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Help dialog
Every RPM function used in the Function Selection dialog has an HTML help file that 
contains information about the function’s appropriate usage, input parameters, and 
default values. Each rock physics function has a least one example calculation and 
commentary.

Miscellaneous user interface tools
The RPM for PowerLog software contains several miscellaneous tools to help you 
construct, test, and present your workflow:
• Tool bars
• Status bar
• Tool tips
• Logging files

Tool bars 
These tool bar icons help you create a new project, open an existing project and save 
an RPM project. There are arrow icons that Undo and Redo the previous workflow 
operation. A tool tip, describing the function of that icon, displays if the mouse cursor 
hovers over the icon for a short period of time.

[

Figure 86. Help displayed in an Internet Browser window
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The tool bar icons that display under the RPM main menus:
• New Project
• Open Project
• Save Project
• Undo
• Redo
• Refresh (redraws the entire workflow)
• Erase Workflow
• Find Node
• Add Node
• Define Group
• Select Path
• Show Descendents
• Show Ancestors
• Clear Selection
• Calculate Workflow

Status bar
The Status bar is located at the bottom of the drawing main window and displays 
Status messages generated by the RPM for PowerLog program. 

If your mouse hovers over a:
• Node—the node number or curve output name displays in the Status bar. When a 

node is calculated, the node number and its value displays. If the output is a curve, 
the curve name, calculated mean value, and number of samples display.

• Toolbar icon—a description of that command’s actions displays in the status bar.

Tool tips
If you hover over a cell in the Function Selection Dialog, you see an evaluation of the 
current parameter and its type, or the default parameter that RPM supplies if the field 
is left blank. Fields marked by bold blue text do not have any default parameters and 
input values are required.

Figure 87. Status bar

Status
Bar
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Figure 88. Tool tips examples
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Logging files
RPM for PowerLog has log files to (1) capture all the messages issued during a 
workflow calculation and (2) hold the details of the curve fitting computations.

Figure 89. RPM log files

Workflow
Calculation 
Messages

Curve Fitting
Computation 
Details
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GLOSSARY
ancestors The collection of workflow nodes that affect the input connections to a 

selected node.

anisotropy Predictable variation of a property of a material with the direction in which it is 
measured, which can occur at all scales. For a crystal of a mineral, variation 
in physical properties observed in different directions is anisotropic. In rocks, 
variation in seismic velocity measured parallel or perpendicular to bedding 
surfaces is a form of anisotropy. See isotropy.

AVO Amplitude Variation with Offset. Variation in seismic reflection amplitude with 
change in distance between shotpoint and receiver that indicates differences 
in lithology and fluid content in rocks above and below the reflector. AVO 
analysis is a technique by which geophysicists attempt to determine 
thickness, porosity, density, velocity, lithology and fluid content of rocks. 
Successful AVO analysis requires special processing of seismic data and 
seismic modeling to determine rock properties with a known fluid content.

bubble point pressure Pressure below which (for constant temperature) gas in solution in oil is 
released. Also called saturation pressure.

connection Input from one node of a workflow to another node which defines the 
ancestor and descendent relationships within the workflow.

crack aspect ratio Also called pore aspect ratio. The ratio [α = a/b] of the minor (a) and 
major (b) ellipsoidal axes that characterize the spheroidal pore shape of the 
representative reservoir rock.

critical porosity Porosity below which compressive load is transmitted through mineral grain 
physical contact, and above which compressional load is transmitted through 
the pore fluid, and the rock becomes a slurry.

crossplot porosity Porosity obtained by plotting two porosity logs against each other, normally a 
density and neutron porosity. The computation assumes a particular fluid, 
usually fresh water, and particular response equations. The result is largely 
independent of lithology and is often a more reliable porosity estimate than 
one porosity log.

dead oil Oil that contains no gas in solution.



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 150

Glossary DEM

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

DEM Differential Effective Medium. This method is derived by assuming the 
composite is formed by successively mixing very small (infinitesimal) 
fractions of one inclusion material in another host material.

descendents The collection of workflow nodes affected by the output connections from a 
selected node.

deviation The angle at which a wellbore diverges from vertical. Wells can deviate from 
vertical because of the dips in the beds being drilled through.

directed graph Another name for a workflow containing nodes (where calculation functions 
happen) and connections (with arrows) that determine the calculation 
dependencies.

effective porosity Porosity due to movable plus hydrostatically bound fluids. The interconnected 
pore volume or void space in a rock that contributes to fluid flow or 
permeability in a reservoir. Effective porosity excludes isolated pores and 
pore volume occupied by water adsorbed on clay minerals or other grains. 
Usually less than total porosity.

function A calculation or a boolean operation applied to one or more connection inputs 
and yielding an output (value or curve).

gas-oil ratio The volume of liberated gas at one atmospheric pressure (and 15.6° C) 
produced per unit of oil produced. Given as Rs as a dimensionless volume 
ratio and as GOR in Scf/BBl. 

group A collection of nodes that can be named and manipulated together, so that 
the workflow complexity can be managed. These node collections help a user 
associate a workflow subsection with a computation goal.

inclination The deviation from vertical, irrespective of compass direction, expressed in 
degrees. For most vertical wellbores, inclination is the only measurement of 
the path of the wellbore.

inversion A mathematical process by which data are used to generate a model that is 
consistent with the data, the process of solving the inverse problem. In 
seismology, surface seismic data, vertical seismic profiles and well log data 
can be used to perform inversion, the result of which is a model of Earth 
layers and their thickness (seismic trace), density and P- and S-wave 
velocities. Successful seismic inversion usually requires a high signal-to-
noise ratio and a large bandwidth.

isotropy A quality of directional uniformity in material such that physical properties do 
not vary in different directions. In rocks, changes in physical properties in 
different directions, such as the alignment of mineral grains or the seismic 
velocity measured parallel or perpendicular to bedding surfaces, are forms of 
anisotropy. See anisotropy.

live oil Oil that contains some gas in solution.
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node A point in the workflow where you can define a function, using one or more 
connection inputs (values or curves), and generate an output (value or 
curve). A node’s output can be delivered to one or more other nodes.

MRU Most Recently Used list. List of the last five RPM projects accessed with the 
RPM software on this computer.

path A set of RPM nodes defined by a selected beginning node, a selected final 
node, and all connection nodes between the two selections. RPM for 
PowerLog permits you to perform all the calculations along a chosen 
workflow path.

RPM Rock Physics Module for PowerLog. A porting of the rock physics portion of 
the Jason Geoscience Workbench product that uses a Windows graphical 
user interface and takes advantage of the project and well management 
capabilities of PowerLog. PowerLog provides presentation displays and also 
performs some of the computations found in the previous product.

saturation equation An equation for calculating the water saturation from resistivity and other 
logs. There are many saturation equations. Practical equations are all 
extensions of the Archie equation, which is valid for a rock with very little clay, 
or very high salinity water, and with a regular pore structure. The majority deal 
with the problem of shaly sands, and can be divided into two main groups; 
(1) those that treat the shale as a volume of conductive material (Vsh 
models), and (2) those that analyze the effect of clay counter-ions.

Vsh models take many forms. Typical examples are the Simandoux, 
laminated sand, and Indonesian equations. The clay counter ion group 
includes the Waxman-Smits, Dual Water and SGS equations. Most nonshaly 
sand equations deal with the problem of mixed pore types, for example 
combinations of fractures, isolated pores, and intergranular pores.

specific gravity The ratio of a material’s density to the density of water; often used for gas.

survey A completed measurement of the inclination and azimuth of a location in a 
well (typically the total depth at the time of measurement). In both directional 
and straight holes, the position of the well must be known with reasonable 
accuracy to ensure the correct wellbore path and to know its position in the 
event a relief well must be drilled. The measurements themselves include 
inclination from vertical, and the azimuth (or compass heading) of the 
wellbore if the direction of the path is critical.

total porosity Total porosity = effective porosity + clay (electrostatically) bound porosity. 
The total pore volume per unit volume of rock. It is measured in volume/
volume, percent or porosity units. Total porosity is the total void space and as 
such includes isolated pores and the space occupied by clay-bound water.
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workflow A set of nodes that define the order and calculation dependencies for a set of 
rock physics calculations. Nodes can be linked together by using the output 
value or output curve of one node as an input for another node. A workflow is 
developed in an iterative manner and refined as you develop your 
methodology.

workspace A rectangular screen size chosen to construct and display the workflow.
The compass direction of a directional survey or of the wellbore as planned or 
measured by a directional survey. The azimuth is usually specified in degrees 
with respect to the geographic or magnetic north pole.
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INDEX

A
adding

entity (user-defined) 58
group 81, 128
named constant 139
named constant (user-defined) 51
node 68, 122, 128
node commands 67
node connection 30
project (RPM) 44
property (rock, fluid, mineral) 123, 138
property (user-defined) 59
RPM project 121

alias curve names
displaying 49, 128

ancestor nodes
example 23
highlighting 125, 127

audience
this document 7

AVO
definition 149

B
basic functions

workflow constant 64
benefits

example workflows 86
best practices

color-code input nodes 30
better interpretation

rock physics models 84
blocking

overwrite warnings 123
bold text

GUI objects 10
bookmarks

online guide 12
building blocks

workflows 19

bulk modulus
calculation selection 136

C
Calculate

RPM menu 123
calculating

group 127, 129
node 127, 129
path 127, 129
workflow 127, 129

calculation alerts
block the display 124

calculations
conditional logic constant 63
node types 29
RPM is best 42
workflow 123

cascading menus
notation 9

case insensitive
rock and fluid properties 55

caution
reader alert meaning 10

Cemented Spheres
mix function 37

changes
documentation 15

changing
colors 127
displayed online guide 12
group box color 129
group name 129
named constant 52
node 69
node color 127
node functions 126
property value or unit 60

clay-sand mixtures
velocity model 40

clearing
highlighted nodes 127

colors
applying to all objects 129
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changing 127
selecting 131
signifying input nodes 30
workflow scheme 87

connections
defining between nodes 30
outputs as inputs 18
overview 22
shortcut menu 127

consequences
deleting a property 61
deleting an entity 61
renaming properties 60

constants
calculations flag 63
math operation 64

contact information
technical support 15

context
operations on workflow 120

context-sensitive menus
overview 126

Critical porosity
mix function 37

critical porosity
definition 149

crossplots
presentations 48

Curve Alias List
dialog 143

curve alias names
ampersand notation 143
displaying 123, 128
function input 26

Curve Differences Statistics
tutorial workflow 94

curve fitting
Fit Curves dialog 124
log file 124, 148
selecting 128

Curve List
dialog 141

curve names
capitalized 141
displaying 123, 128

curves
displaying names 48
function input 25
input nodes (PowerLog) 48
limiting value range 99
node output 21
overwriting automatically 123

customer support
contact information 15

D
Data

RPM menu 123
decision making

lithology coding 99
select water saturation 99

default property values
minerals provided 27, 55, 138
rocks not provided 28, 55, 139

deleting
entity (consequences) 61
entity (RPM-defined) 54
entity (user-defined) 60
group 129
named constant 52, 139
node 74, 127
nodes (multiple) 74
property 61
property (consequences) 61
property (rock, fluid, mineral) 138
workflow 122

DEM
definition 150

descendent nodes
highlighting 125, 127

descendents
deleted node impact 74
deleted nodes impact 74
example 23

descriptions
Status bar 146

dialog
Function Selection elements 67

dialogs
Constants 139
Curve Alias List 143
Curve List 141
Fit Curves 144
Function Selection 133
Help 145
Output log 142
Preferences 129
Rock and Fluid Properties 56, 57, 137
RPM user interface 129
Select Color 131
Set Mix Defaults 136
Workspace 132

Dispersive and layered clay
mix function 37
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Dispersive Clay
mix function 38

displaying
alias curve names 49
calculation alerts in output log 124
curve alias names 123, 128
curve names 48, 123, 128
navigation toolbar (Acrobat) 11
online guide 11
Output Log 124

documentation
procedure convention

procedures
starting with menus 42

E
Edit

RPM menu 122
editing

node 69
nodes with this dialog 133

effective porosity
definition 150

elements
rock physics models 85

email
technical support 2, 15

empirical models
benefits 17

entities
adding (user-defined) 58
deleting (RPM-defined) 54
deleting (user-defined) 60

erasing
workflow 122

error messages
status bar 35

errors
Status bar 146

examples
ancestor nodes 23
basic RPM workflow 88, 94, 97, 102, 106, 110, 113
computation precedence 98
curve alias list for input 26
curve list for input 25
descendents 23
illustrated workflows 85
named constants 28
nodes for inputs 25
Output Log 35
paths 23
reader alerts 10

rock physics constants 27
RockProperty selection lists 72
simple 3 node workflow 18
starting an RPM command 42
tool tip 146
tutorial workflow uses 95
workflow 86

examples of workflows
Curve Differences Statistics 96
Fluid properties to estimate Vs 109
Gassmann fluid-substitution 118
Lithology log construction 112
RP Properties for AVO checks 105
SimpleExpression formulas & logic 101
Starting Point workflow 93

F
features

RPM for PowerLog 16
File

RPM menu 121
finding

node 73, 124, 128
RPM software version 125

Fit Curves
dialog 144

Fluid properties to estimate Vs
tutorial workflow 106

fluid substitution
estimating Vp changes (Mavko) 40

fonts
used in document 10

formulas for workflows
Curve Differences Statistics 95
Fluid properties to estimate Vs 108
Gassmann fluid-substitution 117
Lithology log construction 111
RP Properties for AVO checks 104
SimpleExpression formulas & logic 98, 100
Starting Point workflow 91

Fugro-Jason
Internet site 15

function classifications
Function Selection dialog 133
RPM defined 134

function inputs
curve 25
curve alias name 26
named constant 28
node 24
rock physics property 26
user value 29
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Function Selection dialog
edit node 133

functions
description in tool tip 34
detailed documentation 69, 145
input types 24
node 20
online help 70, 125
rock physics groups 16
selecting 70
type 134

G
gas-oil ratio

definition 150
Gassmann fluid-substitution

tutorial workflow 113
Grain supported

mix function 38
Greek symbols

rock property variables 86
Group

shortcut menu 128
groups

adding 81, 128
calculating 127, 129
changing color 129
changing name 129
deleting 129
excluding nodes 81
minimize 81
node collections 80, 120
overview 23
remove node 81
simplify model 80, 120

H
Help

dialog 145
function details 135
function reference 125
function specific 69
RPM menu 125

highlighting
ancestor nodes 125, 127
descendent nodes 125, 127
paths 124
removing 125, 127

hint
reader alert meaning 10

hyperlinks
blue in document 11

I
impact

deleting a node 74
deleting nodes 74

industry publications
RPM related 39

information
finding 7

input constants
named constant 64
nodes 62

input curves for workflows
Curve Differences Statistics 95
Fluid properties to estimate Vs 107
Gassmann fluid-substitution 115
Lithology log construction 110
RP Properties for AVO checks 103
Starting Point workflow 89

input nodes
color-coding 30
curves required (PowerLog) 48
types 29

input parameters
type 71

inputs
curve alias names 26
curves 25
named constants 28
nodes 25
rock physics constants 27
user value 29

Internet site
Fugro-Jason 2, 15

inversion
definition 150

italics
document usage 10

J
jumping

to page in online guide 12

K
keyboard shortcuts

notation 10

L
Layered clay

mix function 38
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lists
mix end members 137

lithology coding
decsision making 99

Lithology log construction
tutorial workflow 110

log files
curve fitting 148

logplots
presentations & quality control 48

logs
curve fitting computations 124

M
Matrix supported

mix function 38
maximize

group 81
members

initial list 137
menus

Calculate 123
Data 123
Edit 122
File 121
Help 125
RPM title bar 120
used in document 9
View 124

methodology
unstructured 86

methods
bulk modulus calculation 136

mineral properties for workflows
Gassmann fluid-substitution 116
Starting Point workflow 90

minerals
default property values provided 27, 55, 138

minimize
group 81

Mix Defaults
initial algorithms 137
overview 35
selecting 53
setting 123, 128

mixing algorithms
list 36

model workflows
developing 120
layout 120

models
measure of accuracy 94
workflows to help customers 87

modifying
node 69

Most Recently Used list
RPM projects 122

multiple decisions
logic diagram 99

multiple options
notation 10

N
named constants

adding 51, 139
changing 52
deleting 52, 139
dialog 139
function input 28
node documentation 64
setting 123, 128

named constants for workflows
Fluid properties to estimate Vs 107
Gassmann fluid-substitution 116
Lithology log construction 110
RP Properties for AVO checks 104
SimpleExpression formulas & logic 97
Starting Point workflow 90

names
node output 21

naming
node types 69

node outputs
characteristics 21
curve or value 21
name 21
type 22
units 22

nodes
adding 68, 122, 128
adding (different commands) 67
ancestors highlighted 125, 127
calculating 127, 129
calculation usage 29
changing 69
changing color 127
connection added 30
defined relationships 23
deleting 74, 127
deleting multiple 74
descendents highlighted 125, 127
displaying functions 126
excluding from a group 81



Rock Physics Module for PowerLog v2.7 — User Guide [Maintenance Release] August 25, 2006 Page 158

notation properties

Ja
so

n 
Ge

os
cie

nc
e W

or
kb

en
ch

 7.
1

finding 73, 124, 128
function input 24
function overview 20
input constants 62
input types 20
naming 69
output types 22
overview 20
parts 67
parts diagram 68
remove from group 81
restoring 74
shortcut menu 126

notation
fonts 10
menu selection 9

note
reader alert meaning 10

O
objectives for workflows

Curve Differences Statistics 94
Fluid properties to estimate Vs 106
Gassmann fluid-substitution 114
Lithology log construction 110
RP Properties for AVO checks 102
SimpleExpression formulas & logic 97
Starting Point 88

online guide
changing display size 12
displaying 11
printing 13
searching (Acrobat 6) 13
using 11

opening
project (PowerLog) 43
project (RPM) 45, 121

optimized parameters
curve fitting 144

optional elements
notation 10

Output fields
curve name 133

Output Log
displaying 124
example 35

output types
nodes 22

overviews
connections 22
groups 23
Mix Defaults 35

nodes 20
shortcut menus 126
workflow elements 19

overwriting
curves-without confirmation 123

P
parameters

multiple allowed (notation) 10
paths

calculating 127, 129
example 23
highlighting 124

planning
workflow inputs 47

pore fluids
initial list 137
mixing list 36

PowerLog
RPM data management 43
starting software 43

precedence
examples 98
SimpleExpression computations 98

Preferences
dialog 129

preferences
colors and line sizes 122

presentations
PowerLog 43
PowerLog is best 42

printing
online guide 13
workflow 122

projects
adding 121
adding (RPM) 44
backup (RPM) 46
MRU Most Recently Used 122
named constants 123
opening (RPM) 45, 121
saving (RPM) 45, 121
selecting (PowerLog) 43
workflow types 46

properties
adding 59, 138
changing 60
deleting 61, 138
names case insensitive 55
renaming 60
rocks, fluids, minerals 54, 137
two-mineral media 56
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R
range of values

curve techniques 99
reconnecting

workflow nodes 122
Redo

reapply last undone workflow action 122
redrawing

workflow 122
relationships

groups of nodes 23
removing

highlighted 125, 127
workflows 122

renaming
consequences 60
property (user-defined) 60

restoring
node 74

results for workflows
Curve Differences Statistics 94
Fluid properties to estimate Vs 106
Gassmann fluid-substitution 114
Lithology log construction 110
RP Properties for AVO checks 102
Starting Point workflow 89

revisions
document 15

right-click menus
MB3 126

Rock and Fluid Properties
adding 123
dialog 56, 137
usage 57

rock models
added value 17

rock physics
industry publications 39

rock physics models
interpretation value 84
key elements 85

rock physics properties
function input 26

rocks
default property values not provided 28, 55, 139

RP Properties for AVO Checks
tutorial workflow 102

RPM
starting software 44

RPM commands
example 42

ways to invoke 42

S
saving

project (RPM) 45, 121
scientific notation

UserValue 71
screen size

Status bar 132
searching

node 73, 124, 128
online guide (Acrobat 6) 13

Select Color
dialog 131

selecting
colors 131
curve fitting 128
function 70
menus (notation) 9
mix defaults 53
project (PowerLog) 43
wells (RPM and PowerLog) 43

selection lists
input parameters 71
RockProperty example 72

selections
clearing 127

Self consistent
mix function 38

Set Mix Defaults
dialog 136

setting
Mix Defaults 123, 128
named constants 123, 128
workspace drawing size 123

shortcut menus
Connection 127
Group 128
Node 126
overviews 126
RPM 126
Workflow 128

shorthand
notation for menu selection 9

SimpleExpression formulas and logic
tutorial workflow 97

software
features 16
stopping RPM 47

software version
RPM 125
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starting
PowerLog 43
RPM commands 42
RPM software 44

Starting Point
tutorial workflow 88

Status bar
results and error messages 35
RPM messages 146
workspace drawing size 132

stopping
RPM for PowerLog 47

strategies for workflows
Curve Differences Statistics 94
Gassmann fluid-substitution 115
Starting Point workflow 89

T
technical support

contact information 15
output log dialog 124
provide software version 125

templates
workflow 86

tool bars
displaying Navigation (Acrobat) 11
RPM main window 145

tool tips
example 146
function descriptions 34
RPM objects 146

total porosity
definition 151

troubleshooting
calculation log 142

tutorial steps
notation 10

two mineral media
properties 56

types
function inputs 24
functions 134
input node 29
node output characteristics 21
node outputs 22
nodes inputs 20
select input parameter 71

U
Undo

eliminate last workflow action 122

units
exceptions to US 57, 137
node outputs 22

user interface
RPM summary 119

User Preferences
colors and line sizes 122

user values
function input 29

UserValue
values permitted 71

V
values

curve outputs 21
scientific notation 71

variables
Greek symbols 86

version
bulk modulus calculation method 136

View
RPM menu 124

W
water saturation

decsision making 99
website

Fugro-Jason 15
wells

selecting (RPM and PowerLog) 43
Windows XP

display shortcuts 121
workflow

shortcut menu 128
workflow examples

Fugro-Jason 87
RPM project names 87

workflows
add node 68
backup project 46
basic concepts 16
benefits 86
building block 94
calculating 127, 129
calculation record 142
characteristics 86
color scheme 87
Curve_Differences_Statistics 94
deleting 122
example names 85
Fluid properties to estimate Vs 106
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Gassmann fluid-substitution 113
Lithology log construction 110
message log file 148
model development 120
organizing 46
overview of building blocks 19
planning 47
printing 122
reapply last undone action 122
reconnect nodes 122
redraw 122
RP Properties for AVO Checks 102
run calculations 123
simple 3 node example 18
SimpleExpression formulas and logic 97
Starting_Point_Workflow 88
undoing last action 122

Workspace
dialog 132

workspace
display size in Status bar 132
setting drawing size 123

X
Xu-White

mix function 38
mix function (approximation) 38
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